duplicate job id: '2013.com.canonical.certification::graphics/screenshot_opencv_validation'

Bug #1629838 reported by Yung Shen on 2016-10-03
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Checkbox
High
Pierre Equoy

Bug Description

checkbox sru failed on trusty(3.19) + stable ppa

Traceback (most recent call last):
  File "/usr/bin/plainbox", line 9, in <module>
    load_entry_point('plainbox==0.31', 'console_scripts', 'plainbox')()
  File "/usr/lib/python3/dist-packages/plainbox/impl/box.py", line 123, in main
    raise SystemExit(PlainBoxTool().main(argv))
  File "/usr/lib/python3/dist-packages/plainbox/impl/clitools.py", line 310, in main
    self._parser = self.construct_parser(early_ns)
  File "/usr/lib/python3/dist-packages/plainbox/impl/clitools.py", line 469, in construct_parser
    self.add_subcommands(subparsers, early_ns)
  File "/usr/lib/python3/dist-packages/plainbox/impl/clitools.py", line 659, in add_subcommands
    self.add_subcommands_with_hints(subparsers, early_ns.rest)
  File "/usr/lib/python3/dist-packages/plainbox/impl/clitools.py", line 716, in add_subcommands_with_hints
    self.add_subcommands_without_hints(subparsers, command_collection)
  File "/usr/lib/python3/dist-packages/plainbox/impl/clitools.py", line 747, in add_subcommands_without_hints
    command.register_parser(subparsers)
  File "/usr/lib/python3/dist-packages/plainbox/impl/commands/cmd_session.py", line 115, in register_parser
    metavar=_('FORMAT'), choices=[_('?')] + get_all_exporter_names(),
  File "/usr/lib/python3/dist-packages/plainbox/impl/applogic.py", line 132, in get_all_exporter_names
    with SessionManager.get_throwaway_manager() as manager:
  File "/usr/lib/python3.4/contextlib.py", line 59, in __enter__
    return next(self.gen)
  File "/usr/lib/python3/dist-packages/plainbox/impl/session/manager.py", line 560, in get_throwaway_manager
    device_context.add_provider(provider)
  File "/usr/lib/python3/dist-packages/plainbox/impl/session/state.py", line 400, in add_provider
    self.add_unit(unit)
  File "/usr/lib/python3/dist-packages/plainbox/impl/session/state.py", line 419, in add_unit
    self.state.add_unit(unit)
  File "/usr/lib/python3/dist-packages/plainbox/impl/session/state.py", line 1075, in add_unit
    return self._add_job_unit(new_unit, recompute)
  File "/usr/lib/python3/dist-packages/plainbox/impl/session/state.py", line 1102, in _add_job_unit
    raise DependencyDuplicateError(existing_job, new_job)
plainbox.impl.depmgr.DependencyDuplicateError: duplicate job id: '2013.com.canonical.certification::graphics/screenshot_opencv_validation'

-

dpkg -l|grep -E 'plainbox|checkbox|canonical'
ii checkbox-autostart-desktop 0.1+bzr3108+pkg1~ubuntu14.04.1 all Automatic system testing for desktop systems
ii checkbox-gui 0.34~ppa~ubuntu14.04.1 amd64 QML based interface for system testing based on PlainBox.
ii checkbox-ng 0.29~ppa2~ubuntu14.04.1 all PlainBox based test runner
ii checkbox-ng-service 0.23~ppa~ubuntu14.04.1 all CheckBox D-Bus service (transitional package)
ii plainbox 0.31~ppa~ubuntu14.04.1 all toolkit for software and hardware integration testing
ii plainbox-insecure-policy 0.31~ppa~ubuntu14.04.1 all policykit policy required to use plainbox (insecure version)
ii plainbox-provider-checkbox 0.4-1 amd64 CheckBox provider for PlainBox
ii plainbox-provider-resource-generic 0.28~ppa~ubuntu14.04.1 amd64 CheckBox generic resource jobs provider
ii plainbox-provider-sru 1.5~ppa2~ubuntu14.04.1 all CheckBox SRU jobs provider
ii python3-checkbox-ng 0.29~ppa2~ubuntu14.04.1 all PlainBox based test runner (Python 3 library)
ii python3-checkbox-support 0.28~ppa~ubuntu14.04.1 all collection of Python modules used by PlainBox providers
ii python3-plainbox 0.31~ppa~ubuntu14.04.1 all toolkit for software and hardware testing (python3 module)

Related branches

Yung Shen (kaxing) on 2016-10-03
description: updated
Taihsiang Ho (taihsiangho) wrote :

I was hit by this issue as well.

Test environement:
201507-18607 - Dell OptiPlex 5040
OEM Image
Linux 201507-18607 3.19.0-30-generic #33~14.04.1-Ubuntu SMP Tue Sep 22 09:27:00 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

ubuntu@201507-18607:~$ dpkg -l *plainbox* *checkbox*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-=============================================-===========================-===========================-===============================================================================================
ii plainbox-insecure-policy 0.32+bzr4516+pkg46~ubuntu14 all policykit policy required to use plainbox (insecure version)
ii plainbox-provider-checkbox 0.4-1 amd64 CheckBox provider for PlainBox
ii plainbox-provider-resource-generic 0.3-1 amd64 CheckBox generic resource jobs provider
ii plainbox-provider-sru 1.6+bzr4516+pkg11~ubuntu14. all CheckBox SRU jobs provider
un plainbox-secure-policy <none> <none> (no description available)
ii python3-plainbox 0.32+bzr4516+pkg46~ubuntu14 all toolkit for software and hardware testing (python3 module)

Taihsiang Ho (taihsiangho) wrote :

I tried Checkbox dev PPA with Xenial image on a XPS 13 (CID 201507-18777), and could not reproduce this issue yesterday. Packages are bzr4515.

Taihsiang Ho (taihsiangho) wrote :

Against the comment#2, I update the packages to use build bzr4516. I could not reproduce this issue. That is, this issue could not reproduce on Xenial. It may be specific to Trusty.

Sylvain Pineau (sylvain-pineau) wrote :

12:38:22) spineau: taihsiang: ok, that's what I thought. the job opencv is both defined in the checkbox provider AND the sru provider
(12:38:43) taihsiang: \o/
(12:39:52) spineau: but that's super weird as we removed it from trunk as soon as we moved it to sru provider
(12:40:16) spineau: looks like the version of the checkbox provider is outdated, don't know why
(12:41:05) spineau: ok, got it, it's indeed the one from the ubuntu archive (0.4-1) not the one from the ppa
(12:41:53) spineau: either we add a minimum requirement in the sru provider packaging or in the preseed

Changed in checkbox:
status: New → Triaged
importance: Undecided → High
Sylvain Pineau (sylvain-pineau) wrote :

Let's add a strict requirement on the checkbox provider in the ppa packaging branch:

http://bazaar.launchpad.net/~checkbox-dev/checkbox/ppa-packaging-plainbox-provider-sru/view/head:/debian/control#L16

Changed in checkbox:
assignee: nobody → Pierre Equoy (pierre-equoy)
Pierre Equoy (pieq) on 2016-10-06
Changed in checkbox:
status: Triaged → In Progress
Pierre Equoy (pieq) on 2016-10-06
Changed in checkbox:
status: In Progress → Fix Committed
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers