Mentions of Ubuntu Friendly in checkbox need to be removed.

Bug #1224533 reported by Daniel Manrique on 2013-09-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
Critical
Daniel Manrique
checkbox (Ubuntu)
Critical
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

[Impact]
Ubuntu Friendly will be discontinued on September 15, 2013. However, checkbox still mentions Ubuntu Friendly in a few places, this could mislead users into thinking the service is still active and cause them to waste time testing when those tests will no longer be useful to the community.

UF is mentioned in three places in checkbox:

- When deselecting tests, a warning that results may be not valid for UF appears.
- The desktop file refers to Ubuntu Friendly, mainly to enable finding of checkbox by typing "ubuntu friendly" on the dash search field.
- The "submit results" default message mentions Ubuntu Friendly, in the message asking for an e-mail address to submit to. In practice, this is replaced by a different prompt so this shouldn't need changing, nor does the user ever see this message.

Checkbox revision 2366 removes these three mentions of Ubuntu Friendly, and allows users to deselect any test without receiving a warning.

The proposed SRU omits the change to the desktop file, since it contains a translatable string which would imply additional and undesirable changes to translations.

[Test Case]

- Use an active, supported Ubuntu release (12.04, 12.10, 13.04).

1)
- Open the dash and search "ubuntu friendly". It will locate the "system testing" application. Note this behavior will not be changed since it implies changing a translatable string, which is undesirable in an SRU.
- Open a terminal (ctrl-alt-t), type "checkbox-qt" and press ENTER. The system testing application will start.
- Press "Continue" on the first screen (welcome message).
- Enter password when prompted

2)
- On the "choose tests to run on your system" screen, deselect any of the component categories.
- A message will pop up: "Unselecting a test will invalidate your submission for Ubuntu Friendly. If you plan to participate in Ubuntu Friendly, please, select all tests. You can always skip individual tests if you don't have the needed equipment." (desired behavior: no message appears).
- Dismiss the message, then click "Deselect all" and dismiss the message again.
- Click "Start testing"

3) Once testing finishes, validate that Ubuntu Friendly is not mentioned in the "submit results" screen (since the string mentioning Ubuntu Friendly is replaced before the user sees it, this shouldn't need any changes, just verification that it behaves as described/desired)

[Regression Potential]

The deselection warning has practically no regression potential, removing it simply toggles showing the warning dialog which has no other side effects or implications.

The string change in the "submit results" message is also unlikely to cause regressions, as the string is not even included in translation catalogs and isn't even shown to the end-user (it's basically a placeholder in the UI, which at runtime gets replaced before the user ever sees it).

The string change for the desktop file, which is the one causing "Ubuntu Friendly" to be searchable in the dash, would cause users accustomed to finding checkbox by typing "Ubuntu Friendly" to be unable to find checkbox this way. They'd have to type "system testing" or "checkbox" in order to locate it. This constitutes a behavior change that could be thought of as a regression. This change was omitted from the final SRU proposal so the regression potential, understood as "change in previous behavior", is null. The behavior is somewhat inconsistent with availability of the Ubuntu Friendly service, but this was deemed acceptable versus changing a translatable string and causing fallout in the form of untranslated text and the resulting bugs (see comment #1).

Related branches

Daniel Manrique (roadmr) on 2013-09-12
Changed in checkbox:
assignee: nobody → Daniel Manrique (roadmr)
importance: Undecided → Critical
status: New → In Progress
tags: added: checkbox-core
Daniel Manrique (roadmr) on 2013-09-12
Changed in checkbox:
status: In Progress → Fix Committed
Daniel Manrique (roadmr) on 2013-09-16
Changed in checkbox:
status: Fix Committed → Fix Released
Daniel Manrique (roadmr) on 2013-09-16
description: updated
Daniel Manrique (roadmr) on 2013-09-20
description: updated
Daniel Manrique (roadmr) on 2013-09-20
Changed in checkbox (Ubuntu):
status: New → Fix Released
importance: Undecided → Critical
Brian Murray (brian-murray) wrote :

It is not clear to me why changing the .desktop file is necessary, it seems to me that people familiar enough with Ubuntu Friendly to type it in the dash will know that the project has been sunsetted. Additionally, I think the change may lead to some bug reports from users regarding not being able to find checkbox. Finally, the data isn't really lost if it is still in Launchpad so "data loss" doesn't seem like a good reason for this change.

Is there something I'm missing?

Daniel Manrique (roadmr) wrote :

Hi Brian,

Historically people have run into checkbox while simply exploring the available applications, these people may potentially be confused by a mention of Ubuntu Friendly in the dash. However, as you mention, it's likely even in that case they will do a bit of research and learn that the project is no longer operational.

Since the risk of confusing these people is less than the risk of bug reports and other confusion when an already-translated string changes from under people's feet, as you mention in comment #1, we're agreeing with your concerns and reverting the patch that changes the .desktop file. The other two changes remain as originally proposed.

I've updated the bug description accordingly, and uploaded new SRU source and packages to account for this change.

Thanks!

description: updated

Hello Daniel, or anyone else affected,

Accepted checkbox into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/checkbox/0.13.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in checkbox (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Changed in checkbox (Ubuntu Raring):
status: New → Fix Committed
Stéphane Graber (stgraber) wrote :

Hello Daniel, or anyone else affected,

Accepted checkbox into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/checkbox/0.15.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Hello Daniel, or anyone else affected,

Accepted checkbox into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/checkbox/0.14.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in checkbox (Ubuntu Quantal):
status: New → Fix Committed
Daniel Manrique (roadmr) wrote :

Hi, I tested this by installing Precise (12.04.3) on a virtual machine and running the test case.

First I tested with the non-fixed 0.13.9 version of checkbox that came with this Ubuntu image.

1- searching for ubuntu friendly in the dash shows the system testing application.
2- clicking on that launches checkbox
3- on the test selection screen, deselecting a test (I did it with Audio Tests) showed a "checkbox-qt-service" dialog with a message about my submission being invalidated for Ubuntu Friendly if I unselected a test.
4- Right-clicking on the test list and selecting "deselect all" showed the same warning.
5- I then did a test run with no tests selected so it finishes quickly.
6- A message saying "please enter the e-mail address associated with your
  launchpad account (if applicable) and click the Submit Results button to submit these test results to Ubuntu Friendly" appeared.
7- I entered email address and clicked submit results.
8- A "successfully finished testing" message appeared.

I then added the -proposed repository, updated and installed checkbox and checkbox-qt, bringing me up to version 0.13.10 in both.

I did the exact same procedure as before, and I noticed the following differences:

- Deselecting either one or all tests (step 3 and 4) doesn't pop up any messages.
- The submission screen (step 6) now says "Please enter the e-mail address associated with your Launchpad account (if applicable) and click the Submit Results button to submit these test results to Launchpad."

Both mentions of Ubuntu Friendly are gone. The only remaining instance is ability to search for "ubuntu friendly" on the dash (step 1).

These results are consistent with what's expected as per the test procedure. About the only difference I saw was that the test procedure mentions "The string change in the "submit results" message is also unlikely to cause regressions, as the string is not even included in translation catalogs and isn't even shown to the end-user", while in my case I did see the old Ubuntu
Friendly string and the change to the new one which doesn't mention it. Still, this is the desired behavior (not mentioning Ubuntu Friendly at all) and since the change doesn't affect translatable strings I think it's OK.

I'll tag with verification-done-precise.

tags: added: verification-done-precise
Daniel Manrique (roadmr) wrote :

Testing on Quantal was similar to testing on precise.

First I installed 12.10 on a virtual machine and ran the test case.

I tested with the non-fixed 0.14.9 version of checkbox that came with this Ubuntu image.

1- searching for ubuntu friendly in the dash shows the system testing application.
2- clicking on that launches checkbox
3- on the test selection screen, deselecting a test (I did it with Optical Drive Tests) showed a "checkbox-qt-service" dialog with a message about my submission being invalidated for Ubuntu Friendly if I unselected a test.
4- Clicking the dedicated "deselect all" button showed the same warning.
5- I then did a test run with no tests selected so it finishes quickly.
6- A message saying "The following report has been generated for submission to the Launchpad hardware database" appeared. No mention of Ubuntu Friendly as expected and described in the test case.
7- I entered email address and clicked submit results.
8- A "successfully finished testing" message appeared.

I then added the -proposed repository, updated and installed checkbox and checkbox-qt, bringing me up to version 0.14.10 in both.

I did the exact same procedure as before, and I noticed the following differences:

- Deselecting either one or all tests (step 3 and 4) doesn't pop up any messages.
- The submission screen (step 6) didn't change and still says "The following report has been generated for submission to the Launchpad hardware database"

One mention of Ubuntu Friendly is gone. The only remaining instance is ability to search for "ubuntu friendly" on the dash (step 1).

I'll tag with verification-done-quantal.

tags: added: verification-done-quantal
Daniel Manrique (roadmr) wrote :

Testing on Raring was also similar, if a bit easier because I was able to test on my local system still running 13.04.

First I tested with the existing, non-fixed 0.15.6 version of checkbox.

1- searching for ubuntu friendly in the dash shows the system testing application.
2- clicking on that launches checkbox
3- on the test selection screen, deselecting a test (I did it with Miscellaneous Tests) showed a "checkbox-qt-service" dialog with a message about my submission being invalidated for Ubuntu Friendly if I unselected a test.
4- Clicking the dedicated "deselect all" button showed the same warning.
5- I then did a test run with no tests selected so it finishes quickly.
6- A message saying "The following report has been generated for submission to the Launchpad hardware database" appeared. No mention of Ubuntu Friendly as expected and described in the test case.
7- I clicked submit results (as an email address is pre-entered in the field).
8- A "successfully finished testing" message appeared.

I then added the -proposed repository, updated and installed checkbox and checkbox-qt, bringing me up to version 0.15.7 in both.

I did the exact same procedure as before, and I noticed the following differences:

- Deselecting either one or all tests (step 3 and 4) doesn't pop up any messages.
- The submission screen (step 6) didn't change and still says "The following report has been generated for submission to the Launchpad hardware database"

One mention of Ubuntu Friendly is gone. The only remaining instance is ability to search for "ubuntu friendly" on the dash (step 1).

I'll tag with verification-done-raring and remove verification-needed as all SRU candidates have been verified.

tags: added: verification-done-raring
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.13.10

---------------
checkbox (0.13.10) precise-proposed; urgency=low

   [Daniel Manrique]
   * Removed references to Ubuntu Friendly due to sunsetting of the project.
    (LP: #1224533)
 -- Daniel Manrique <email address hidden> Wed, 25 Sep 2013 16:36:00 -0400

Changed in checkbox (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.14.10

---------------
checkbox (0.14.10) quantal-proposed; urgency=low

  [Daniel Manrique]
  * Removed references to Ubuntu Friendly due to sunsetting of the project.
    (LP: #1224533)
 -- Daniel Manrique <email address hidden> Mon, 23 Sep 2013 15:00:29 -0400

Changed in checkbox (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.15.7

---------------
checkbox (0.15.7) raring-proposed; urgency=low

  [ Daniel Manrique ]
  * Removed references to Ubuntu Friendly due to sunsetting of the project.
    (LP: #1224533)
 -- Daniel Manrique <email address hidden> Mon, 23 Sep 2013 13:11:53 -0400

Changed in checkbox (Ubuntu Raring):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers