Comment 2 for bug 1296965

Rod Smith (rodsmith) wrote :

I noticed on one failed test that the returned text included the message that '"package.name == 'nmap'" evaluates to false'. I therefore tried installing the nmap package, and it worked; I got:

DEBUG:root:Passed benchmark
------------------------------------------------------------
Client connecting to 10.0.0.1, TCP port 5001
TCP window size: 85.0 KByte (default)
------------------------------------------------------------
[ 3] local 10.0.0.51 port 44880 connected with 10.0.0.1 port 5001
[ ID] Interval Transfer Bandwidth
[ 3] 0.0-10.7 sec 1.00 GBytes 804 Mbits/sec

Transfer speed: 804 Mb/s
80.40% of theoretical max 1000Mb/s

If the test really needs nmap, then a dependency should be included.

One other point: I wasn't aware that the iperf test was supposed to be reading data from /etc/xdg/certification.conf; I set the location of the iperf server in /etc/checkbox.d/network.cfg. The iperf server was running on 10.0.0.1, and that's what I set in that file, so I assume that's the file that this test was reading. As I'm writing up the self-testing guide for this software, it's important that somebody tell me these things.