keystone FATAL ERROR: Could not determine OpenStack codename for version 8.1.0

Bug #1572358 reported by Firl on 2016-04-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
keystone (Juju Charms Collection)
Undecided
Unassigned
openstack-base (Juju Charms Collection)
High
Ryan Beisner
openstack-telemetry (Juju Charms Collection)
High
Ryan Beisner

Bug Description

cs:trusty/keystone-31
```
2016-04-20 00:53:21 ERROR juju-log FATAL ERROR: Could not determine OpenStack codename for version 8.1.0
2016-04-20 00:53:21 ERROR juju.worker.uniter.operation runhook.go:103 hook "config-changed" failed: exit status 1
```
cs:trusty/keystone-32
```
2016-04-20 00:58:19 ERROR juju-log FATAL ERROR: Could not determine OpenStack codename for version 8.1
2016-04-20 00:58:19 ERROR juju.worker.uniter.operation runhook.go:103 hook "config-changed" failed: exit status 1
```
cs:trusty/keystone-33
```
2016-04-20 00:59:30 ERROR juju-log FATAL ERROR: Could not determine OpenStack codename for version 8.1
2016-04-20 00:59:30 ERROR juju.worker.uniter.operation runhook.go:103 hook "config-changed" failed: exit status 1
```

Deploying the base bundle from the charm store did not work.

bundle that I used.
http://paste.ubuntu.com/15939784/

Related branches

Firl (celpa-firl) wrote :
Ryan Beisner (1chb1n) wrote :

Per bug 1559935, the keystone package received a stable release update (SRU) in the Liberty cloud archive. Use of this updated package requires a corresponding keystone charm upgrade. The stable keystone charm received a SRU at rev:
https://github.com/openstack/charm-keystone/commit/3d312fcea5409885c928705647b08de4b13b0889

That code has been injested into the charm store stable Keystone charm at:
https://jujucharms.com/keystone/trusty/253

And for backwards-compatibility, synced to the old LP branch location at:
http://bazaar.launchpad.net/~openstack-charmers/charms/trusty/keystone/trunk/revision/204

If you find that there are other issues not addressed by this information, please update this bug. Thank you.

Changed in keystone (Juju Charms Collection):
status: New → Invalid
summary: - keystone deploy doesn't work
+ keystone FATAL ERROR: Could not determine OpenStack codename for version
+ 8.1.0
Ryan Beisner (1chb1n) wrote :

The openstack-base bundle will need to be updated to pull the updated keystone charm rev.

Changed in openstack-base (Juju Charms Collection):
status: New → Confirmed
Ryan Beisner (1chb1n) on 2016-04-20
Changed in openstack-telemetry (Juju Charms Collection):
status: New → Confirmed
Changed in openstack-base (Juju Charms Collection):
importance: Undecided → High
Changed in openstack-telemetry (Juju Charms Collection):
importance: Undecided → High
Changed in openstack-base (Juju Charms Collection):
assignee: nobody → Ryan Beisner (1chb1n)
Changed in openstack-telemetry (Juju Charms Collection):
assignee: nobody → Ryan Beisner (1chb1n)
Ryan Beisner (1chb1n) on 2016-04-20
Changed in openstack-base (Juju Charms Collection):
status: Confirmed → In Progress
Changed in openstack-telemetry (Juju Charms Collection):
status: Confirmed → In Progress
James Page (james-page) on 2016-04-20
Changed in openstack-base (Juju Charms Collection):
status: In Progress → Fix Released
Changed in openstack-telemetry (Juju Charms Collection):
status: In Progress → Fix Released
Abbas Bangash (abangash) wrote :

Facing the same issue of keystone FATAL ERROR: Could not determine OpenStack codename for version 8.1.0 while installing openstack using Autopilot script

James Page (james-page) wrote :

Hi Abbas

There was a new release of the landscape autopilot last week which should resolve this problem - please confirm that you're using the latest version!

Abbas Bangash (abangash) wrote :

The following is the landscape-bundle.yaml file I use to deploy landscape on Ubuntu 14.04

services:
  haproxy:
    charm: cs:trusty/haproxy-10
    num_units: 1
    to:
    - lxc:0
    options:
      default_timeouts: queue 60000, connect 5000, client 120000, server 120000
      enable_monitoring: true
      monitoring_allowed_cidr: 0.0.0.0/0
      monitoring_password: haproxy
      services: ""
      source: backports
      ssl_cert: SELFSIGNED
    annotations:
      gui-x: "1200"
      gui-y: "120"
  landscape-server:
    charm: cs:trusty/landscape-server
    num_units: 1
    to:
    - lxc:0
    options:
      key: 4652B4E6
      source: deb http://ppa.launchpad.net/landscape/15.11/ubuntu trusty main
    annotations:
      gui-x: "950"
      gui-y: "120"
    constraints: mem=2048
  postgresql:
    charm: cs:trusty/postgresql-27
    num_units: 1
    to:
    - lxc:0
    options:
      extra-packages: python-apt postgresql-contrib postgresql-.*-debversion
      max_connections: 500
      max_prepared_transactions: 500
    annotations:
      gui-x: "600"
      gui-y: "120"
    constraints: mem=2048
  rabbitmq-server:
    charm: cs:trusty/rabbitmq-server-26
    num_units: 1
    to:
    - lxc:0
    annotations:
      gui-x: "600"
      gui-y: "370"
machines:
  "0": {}
series: trusty
relations:
- - landscape-server
  - rabbitmq-server
- - landscape-server
  - haproxy
- - landscape-server:db
- postgresql:db-admin

Abbas Bangash (abangash) wrote :

Is the newer version of landscape 16.03 compatible with 14.04 and do I only have to change http://ppa.launchpad.net/landscape/15.11/ubuntu TO http://ppa.launchpad.net/landscape/16.03/ubuntu?

Peter Sabaini (peter-sabaini) wrote :

Is http://bazaar.launchpad.net/~openstack-charmers/charms/trusty/keystone/trunk/revision/204 really correct? This seems to be about adding designate support, right?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers