Installation broken

Bug #1160590 reported by Marius B. Kotsbak on 2013-03-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
node-app (Juju Charms Collection)
Undecided
Unassigned

Bug Description

Now, this line in the install hook:

 sudo apt-get -y install -qq nodejs nodejs-dev build-essential npm curl

gives: "E: Unable to correct problems, you have held broken packages".

because of updates to the nodejs PPA.

I think this is because of packages "npm" and "nodejs-dev" are removed from there (included in "nodejs").

Related branches

Marius B. Kotsbak (mariusko) wrote :

Japp, changing the line to:

sudo apt-get -y install -qq nodejs build-essential curl

solves the problem.

description: updated
Changed in node-app (Juju Charms Collection):
status: New → Fix Committed
Changed in node-app (Juju Charms Collection):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers