charmhelpers.fetch.__init__ "Liberty" source missing

Bug #1543261 reported by Alvaro Uría on 2016-02-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
haproxy (Juju Charms Collection)
Undecided
Unassigned

Bug Description

Hi,

When deploying haproxy charm with source="trusty-updates/liberty", hooks/install fails:
"""
charmhelpers.fetch.SourceConfigError: Unsupported cloud: source option trusty-updates/liberty
"""

Reason is "charmhelpers.fetch" is not up to date.

http://bazaar.launchpad.net/~charmers/charms/trusty/haproxy/trunk/view/head:/hooks/charmhelpers/fetch/__init__.py#L44

By adding liberty targets in dict, deploy works as expected. However, it might be good syncing with latest charmhelpers release.

Cheers,
-Alvaro.

Alvaro Uría (aluria) wrote :

Hi,

We're currently working with a patched version of fetch.__init__.py -> http://pastebin.ubuntu.com/15204715/

Cheers,
-Alvaro.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers