install hook fails due to missing dep

Bug #1604618 reported by james beedy on 2016-07-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
docker (Juju Charms Collection)
High
Matt Bruzek

Bug Description

install hook fails due to missing dep -> http://paste.ubuntu.com/20108281/

To replicate:
Deploy docker charm.

To fix:
Add `sudo apt-get install libssl-dev` somewhere.

Matt Bruzek (mbruzek) wrote :

I am able to come up with the same error. Thanks to James for filing this bug and a merge proposal https://code.launchpad.net/~jamesbeedy/charms/trusty/docker/fix_apt_dep/+merge/300544

Changed in docker (Juju Charms Collection):
status: New → Confirmed
Matt Bruzek (mbruzek) on 2016-07-27
Changed in docker (Juju Charms Collection):
importance: Undecided → High
assignee: nobody → Matt Bruzek (mbruzek)
Kevin W Monroe (kwmonroe) wrote :

Matt, is this still an issue with the layered docker charm? If not, is there any reason to fix in the non-layered version?

Matt Bruzek (mbruzek) wrote :

Kevin, I will need Chuck's help on this. I believe the plan was to deprecate the old docker charm in favor of the layered one, but this has not happened. I suspect the bug does not occur on the layered charm.

We will need to to some administrative work to get this bug figured out.

@jamesbeedy can you confirm that the layered charm does not have this bug and is more useful than this original charm?

james beedy (jamesbeedy) wrote :

@mbruzek xenial build of layer-docker seems to be working as expected as a standalone charm.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers