The charm store needs a single sponsorship queue.

Bug #993643 reported by Clint Byrum on 2012-05-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Juju Charms Collection
High
Clint Byrum

Bug Description

The charm store should, if possible, make use of the same methods that this report uses to report on items that need action from privileged users in the charm store:

http://reports.qa.ubuntu.com/reports/sponsoring/index.html

Clint Byrum (clint-fewbar) wrote :

Note that this works reasonably well actually:

https://code.launchpad.net/~charmers/+activereviews

Jorge Castro (jorge) wrote :

Daniel,

Can you give us some pointers on where we can get the code to your reports so we can start to do this for the charm store?

Juan L. Negron (negronjl) wrote :

As I work on the page for this ( based on Daniel's code ), I see that the charmers have a different approach to this.
I see that we ( for now ) follow two things:
- bugs ( using something similar to this: https://bugs.launchpad.net/charms/?field.searchtext=&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.component-empty-marker=1&field.tag=new-charm&field.tags_combinator=ANY&field.status_upstream-empty-marker=1&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_no_package.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on&search=Search&orderby=datecreated&start=0 )
- reviews: ( using something similar to this: https://code.launchpad.net/~charmers/+activereviews )

For now, I think we should consolidate both of the above pages into a single one. This gets us charmers used to the idea of always looking for things to review on the same page ( we could put this on jujucharms.com/review or something similar ). This also allows us to start with something similar to what we have now and evolve it over time.

I will have a temporary page built soon so we can start have something up and running...

Comments, opinions, feedback, etc... post it here.

-Juan

Juan L. Negron (negronjl) wrote :

I have the code and templates ready. Talked to Kapil about this and he is going to put this on jujucharms.com.
When this is done, we can review/critique as we see fit.

-Juan

Jorge Castro (jorge) wrote :
Changed in charms:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers