Charm Needed: openstack vnc components.

Bug #1151785 reported by Pierre Amadio on 2013-03-07
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Juju Charms Collection
Undecided
Liam Young

Bug Description

Openstack comes with some vnc related components that let end users access vm's console in two ways:

- horizon dashboard vnc pannel
- stand alone java vnc client

http://docs.openstack.org/trunk/openstack-compute/admin/content/getting-started-with-vnc-proxy.html

Those components are currently not charmed.

It is still possible to install them manually.

Here are the steps needed to install the horizon vnc console on folsom:

* Install nova-consoleauth on the controller node
   sudo apt-get install nova-consoleauth

* Install nova-novncproxy on a node with access to both the public network, and the fixed_range network used by vms (where the real vnc servers will be available).

sudo apt-get install novnc nova-novncproxy websockify

Note that a similar packages (wich i m not 100% sure about the name) should be installed in order to allow access from the standalone java vnc client (openstack component name is nova-xvpvncproxy).

* Set the following flags in (all ?) nova.conf :

vnc_enabled=true
vncserver_listen="0.0.0.0"
novncproxy_base_url="http://A.B.C.D:6080/vnc_auto.html"

I am not 100% sure what is needed for the java client proxy, but i am guessing:

xvpvncproxy_base_url=http://E.F.G.H:6081/console
xvpvncproxy_host=0.0.0.0
xvpvncproxy_port=6081

Where A.B.C.D and E.F.G.H are ip on the public/floating networks (those are the template for generating urls the end user will use to connect to the vnc proxy server) where the vnc proxy service is listening.

* For each compute nodes, set the following:

vncserver_proxyclient_address=I.J.K.L

where I.J.K.L is the ip of this compute node on the fixed_range network on the bridge (so the proxy server knows on wich ip is this compute node listening for vnc connexions).

The last bit may be a bit problematic as with nova-network and flatdhcpmanager, the compute nodes do not have an ip on the bridge set before a vm is actually running on this node.

Changed in charms:
assignee: nobody → Adam Gandelman (gandelman-a)
Juan L. Negron (negronjl) wrote :

Hi Adam:

Has there been any progress on this?

-Juan

tags: added: cloud
Subhranshu Dwivedi (subhranshu) wrote :
Download full text (3.2 KiB)

Dear Pierre,

Thanks for this report,

I am using the 4 node maas juju openstack folsom cluster here, suggested in the following url,
>https://gist.github.com/joethemongoose/4032705

Now everything works fine except the VNC, console,

I tried your suggestion but could not get the packages installed, the errors are mentioned below,

Is there something which i am missing out here, please help,
---------------------------------------------------------------------
 sudo apt-get install nova-consoleauth
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  nova-consoleauth
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 4,488 B of archives.
After this operation, 78.8 kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  nova-consoleauth
Install these packages without verification [y/N]? y
Err http://ubuntu-cloud.archive.canonical.com/ubuntu/ precise-updates/folsom/main nova-consoleauth all 2012.2.4-0ubuntu3~cloud0
  403 Forbidden
Failed to fetch http://ubuntu-cloud.archive.canonical.com/ubuntu/pool/main/n/nova/nova-consoleauth_2012.2.4-0ubuntu3~cloud0_all.deb 403 Forbidden
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

ubuntu@srv407:~$ sudo apt-get install novnc nova-novncproxy websockify
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  binutils cpp cpp-4.6 gcc gcc-4.6 libblas3gf libc-dev-bin libc6-dev libgfortran3 libgomp1 liblapack3gf libmpc2 libmpfr4 libquadmath0 linux-libc-dev manpages-dev
  python-novnc python-numpy
Suggested packages:
  binutils-doc cpp-doc gcc-4.6-locales gcc-multilib make autoconf automake1.9 libtool flex bison gdb gcc-doc gcc-4.6-multilib libmudflap0-4.6-dev gcc-4.6-doc
  libgcc1-dbg libgomp1-dbg libquadmath0-dbg libmudflap0-dbg binutils-gold glibc-doc python-numpy-doc python-numpy-dbg python-dev gfortran
The following NEW packages will be installed:
  binutils cpp cpp-4.6 gcc gcc-4.6 libblas3gf libc-dev-bin libc6-dev libgfortran3 libgomp1 liblapack3gf libmpc2 libmpfr4 libquadmath0 linux-libc-dev manpages-dev
  nova-novncproxy novnc python-novnc python-numpy websockify
0 upgraded, 21 newly installed, 0 to remove and 1 not upgraded.
Need to get 28.1 MB of archives.
After this operation, 74.9 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
WARNING: The following packages cannot be authenticated!
  libquadmath0 libgfortran3 libgomp1 libmpfr4 libmpc2 binutils cpp-4.6 cpp gcc-4.6 gcc libblas3gf libc-dev-bin linux-libc-dev libc6-dev liblapack3gf manpages-dev
  python-novnc python-numpy websockify novnc nova-novncproxy
Install these packages without verification [y/N]? y
Err http://archive.ubuntu.com/ubuntu/ precise/main libquadmath0 amd64 4.6.3-1ubuntu5
  403 Forbidden
Err http://ubuntu-cloud.archive.canonical.com/ubuntu/ precise-updates/folsom/main python-novnc all 2012.2~20120906+dfsg-0ubuntu4~cloud0
  403 Forbidden
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
===========...

Read more...

Jonathan Davies (jpds) on 2013-09-04
Changed in charms:
status: New → Confirmed
Kaya LIU (kayaliu) wrote :

Would be good if we add the configuration to charm the SPICE support as well.

James Page (james-page) on 2014-07-28
Changed in charms:
assignee: Adam Gandelman (gandelman-a) → Liam Young (gnuoy)
status: Confirmed → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers