error due to missing internal binding

Bug #1913313 reported by Edward Hope-Morley on 2021-01-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
TrilioVault Data Mover Charm
High
Edward Hope-Morley
charms.openstack
Undecided
Edward Hope-Morley

Bug Description

With version 5 of the charm we get:

2021-01-15 12:04:46 DEBUG install During handling of the above exception, another exception occurred:
2021-01-15 12:04:46 DEBUG install
2021-01-15 12:04:46 DEBUG install Traceback (most recent call last):
2021-01-15 12:04:46 DEBUG install File "/var/lib/juju/agents/unit-trilio-data-mover-18/charm/hooks/install", line 22, in <module>
2021-01-15 12:04:46 DEBUG install main()
2021-01-15 12:04:46 DEBUG install File "/var/lib/juju/agents/unit-trilio-data-mover-18/.venv/lib/python3.6/site-packages/charms/reactive/__init__.py", line 74, in main
2021-01-15 12:04:46 DEBUG install bus.dispatch(restricted=restricted_mode)
2021-01-15 12:04:46 DEBUG install File "/var/lib/juju/agents/unit-trilio-data-mover-18/.venv/lib/python3.6/site-packages/charms/reactive/bus.py", line 390, in dispatch
2021-01-15 12:04:46 DEBUG install _invoke(other_handlers)
2021-01-15 12:04:46 DEBUG install File "/var/lib/juju/agents/unit-trilio-data-mover-18/.venv/lib/python3.6/site-packages/charms/reactive/bus.py", line 359, in _invoke
2021-01-15 12:04:46 DEBUG install handler.invoke()
2021-01-15 12:04:46 DEBUG install File "/var/lib/juju/agents/unit-trilio-data-mover-18/.venv/lib/python3.6/site-packages/charms/reactive/bus.py", line 181, in invoke
2021-01-15 12:04:46 DEBUG install self._action(*args)
2021-01-15 12:04:46 DEBUG install File "/var/lib/juju/agents/unit-trilio-data-mover-18/charm/reactive/layer_openstack.py", line 39, in default_config_changed
2021-01-15 12:04:46 DEBUG install instance.config_changed()
2021-01-15 12:04:46 DEBUG install File "/var/lib/juju/agents/unit-trilio-data-mover-18/.venv/lib/python3.6/site-packages/charms_openstack/charm/classes.py", line 433, in config_changed
2021-01-15 12:04:46 DEBUG install self.configure_tls(certificates_interface=tls)
2021-01-15 12:04:46 DEBUG install File "/var/lib/juju/agents/unit-trilio-data-mover-18/.venv/lib/python3.6/site-packages/charms_openstack/charm/classes.py", line 465, in configure_tls
2021-01-15 12:04:46 DEBUG install certificates_interface=certificates_interface)
2021-01-15 12:04:46 DEBUG install File "/var/lib/juju/agents/unit-trilio-data-mover-18/.venv/lib/python3.6/site-packages/charms_openstack/charm/classes.py", line 389, in get_certs_and_keys
2021-01-15 12:04:46 DEBUG install 'cn': os_ip.resolve_address(endpoint_type=ep_type)})
2021-01-15 12:04:46 DEBUG install File "/var/lib/juju/agents/unit-trilio-data-mover-18/.venv/lib/python3.6/site-packages/charms_openstack/ip.py", line 174, in resolve_address
2021-01-15 12:04:46 DEBUG install resolved_address = _network_get_primary_address(binding)
2021-01-15 12:04:46 DEBUG install File "/var/lib/juju/agents/unit-trilio-data-mover-18/.venv/lib/python3.6/site-packages/charms_openstack/ip.py", line 93, in _network_get_primary_address
2021-01-15 12:04:46 DEBUG install address = hookenv.network_get_primary_address(binding).decode('utf-8')
2021-01-15 12:04:46 DEBUG install File "/var/lib/juju/agents/unit-trilio-data-mover-18/.venv/lib/python3.6/site-packages/charmhelpers/core/hookenv.py", line 1166, in inner_translate_exc2
2021-01-15 12:04:46 DEBUG install return f(*args, **kwargs)
2021-01-15 12:04:46 DEBUG install File "/var/lib/juju/agents/unit-trilio-data-mover-18/.venv/lib/python3.6/site-packages/charmhelpers/core/hookenv.py", line 1370, in network_get_primary_address
2021-01-15 12:04:46 DEBUG install .format(binding))
2021-01-15 12:04:46 DEBUG install charmhelpers.core.hookenv.NoNetworkBinding: No network binding for internal
2021-01-15 12:04:46 ERROR juju.worker.uniter.operation runhook.go:136 hook "install" (via explicit, bespoke hook script) failed: exit status 1

It seems this is caused by the code at [1] which was added by [2]

[1] https://github.com/openstack/charms.openstack/blob/946ee47cf0f17ab90562e7ae7ea8502a39bdc898/charms_openstack/charm/classes.py#L395
[2] https://review.opendev.org/c/openstack/charms.openstack/+/752873

Revision history for this message
Edward Hope-Morley (hopem) wrote :
Changed in charm-trilio-data-mover:
importance: Undecided → High
milestone: none → 21.01
Changed in charms.openstack:
status: New → In Progress
assignee: nobody → Edward Hope-Morley (hopem)
Revision history for this message
Edward Hope-Morley (hopem) wrote :
Changed in charm-trilio-data-mover:
status: New → In Progress
assignee: nobody → Edward Hope-Morley (hopem)
Changed in charms.openstack:
status: In Progress → Fix Committed
Revision history for this message
Edward Hope-Morley (hopem) wrote :

Stable backport submitted for stable/20.10 charm since there will be no 21.01 release for this charm according to [2]

[1] https://review.opendev.org/c/openstack/charm-trilio-data-mover/+/772744
[2] https://review.opendev.org/c/openstack/charm-guide/+/772524

Changed in charm-trilio-data-mover:
milestone: 21.01 → 20.10
Revision history for this message
Aurelien Lourot (aurelien-lourot) wrote :
Revision history for this message
Aurelien Lourot (aurelien-lourot) wrote :
Changed in charms.openstack:
status: Fix Committed → Fix Released
Changed in charm-trilio-data-mover:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers