relationship between nova-compute and mysql should be removed

Bug #1713807 reported by Felipe Reyes on 2017-08-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Bundles
High
Andrew McLeod
OpenStack Charm Test Infra
High
Ryan Beisner
OpenStack Charm Testing
High
Ryan Beisner
OpenStack LXD Charm
Critical
Chris MacNaughton
OpenStack ceilometer charm
Critical
Chris MacNaughton
OpenStack ceilometer-agent charm
Critical
Chris MacNaughton
OpenStack ceph-mon charm
Critical
Chris MacNaughton
OpenStack ceph-osd charm
Critical
Chris MacNaughton
OpenStack ceph-radosgw charm
Critical
Chris MacNaughton
OpenStack cinder charm
Critical
Chris MacNaughton
OpenStack heat charm
Critical
Chris MacNaughton
OpenStack nova-cloud-controller charm
Critical
Chris MacNaughton
OpenStack nova-compute charm
Medium
Felipe Reyes
OpenStack odl-controller charm
Undecided
Unassigned
Openstack Mojo Testing
High
Chris MacNaughton

Bug Description

during the troubleshooting of the bug 1713059 , it was found that uosci is exercising the relation between nova-compute and mysql which produces the inclusion of the database configuration in /etc/nova/nova.conf and it was hiding the previously referenced bug.

This line https://bazaar.launchpad.net/~ost-maintainers/openstack-charm-testing/trunk/view/head:/bundles/sparse/default.yaml#L112 should be dropped as nova-compute access the database through nova-conductor, I couldn't find documentation when this was completely dropped, but some people mention at least since Kilo.

On the nova-compute charm side, it should log a deprecation warning when it's added and do not include the database connection in the generated nova.conf for newer releases than X[0]

[0] X needs to be defined.

Tags: sts Edit Tag help

Related branches

Felipe Reyes (freyes) on 2017-08-29
Changed in charm-test-infra:
assignee: nobody → Felipe Reyes (freyes)
Felipe Reyes (freyes) wrote :

In a functional trusty-icehouse deployment with the relation in place nova-compute does NOT connect to nova.

root@juju-1e80fa-icehouse-17:~# grep connection /etc/nova/nova.conf
sql_connection = mysql://nova:8NKTTLFswGmdZZXGXHh7SMFN852BFPXC@10.5.1.76/nova
root@juju-1e80fa-icehouse-17:~# netstat -neopa | grep 3306
root@juju-1e80fa-icehouse-17:~# netstat -neopa | grep `pgrep nova-compute`
tcp 0 0 10.5.1.82:52856 10.5.1.77:5672 ESTABLISHED 107 8222327 22163/python keepalive (6563.38/0/0)
tcp 0 0 10.5.1.82:52854 10.5.1.77:5672 ESTABLISHED 107 8222267 22163/python keepalive (6563.38/0/0)
tcp 0 0 10.5.1.82:52855 10.5.1.77:5672 ESTABLISHED 107 8222268 22163/python keepalive (6563.38/0/0)
unix 3 [ ] STREAM CONNECTED 8222273 22163/python

Changed in charm-nova-compute:
assignee: nobody → Felipe Reyes (freyes)
Changed in charm-test-infra:
assignee: Felipe Reyes (freyes) → nobody

Fix proposed to branch: master
Review: https://review.openstack.org/499823

Changed in charm-nova-compute:
status: New → In Progress
James Page (james-page) on 2017-09-21
summary: - relationship between nova-compute and mysql should be deprecated
+ relationship between nova-compute and mysql should be removed
Changed in charm-nova-compute:
importance: Undecided → Medium
Changed in charm-test-infra:
status: New → Triaged
importance: Undecided → Medium
Felipe Reyes (freyes) on 2017-10-02
Changed in openstack-charm-testing:
assignee: nobody → Felipe Reyes (freyes)
Alex Kavanagh (ajkavanagh) wrote :

For info purposes, nova-conductor was introduced in grizzly: https://blog.russellbryant.net/2013/02/19/deployment-considerations-for-nova-conductor-service-in-openstack-grizzly/ - thus it is present in icehouse/kilo which is still in support.

Ryan Beisner (1chb1n) wrote :

We will need to make a sweep of amulet tests to ensure the following (and similar expressions of the same) are no longer declared:

'nova-compute:shared-db': 'percona-cluster:shared-db'

Ryan Beisner (1chb1n) wrote :

We will also need to make a sweep of all lp:openstack-charm-testing bundles to make sure these are removed:

[ nova-compute, mysql ]

Ryan Beisner (1chb1n) wrote :

And, we will need to make sure the specs and bundles in lp:~ost-maintainers/openstack-mojo-specs/mojo-openstack-specs have this relation removed.

Changed in openstack-mojo-specs:
assignee: nobody → Chris MacNaughton (chris.macnaughton)
status: New → Confirmed
importance: Undecided → High
Ryan Beisner (1chb1n) wrote :

Re-triaged the test projects as high, because they will break once the nova-compute charm change lands, which is likely very soon.

Changed in charm-test-infra:
status: Triaged → In Progress
assignee: nobody → Ryan Beisner (1chb1n)
Changed in openstack-charm-testing:
assignee: Felipe Reyes (freyes) → Ryan Beisner (1chb1n)
importance: Undecided → High
Changed in charm-test-infra:
importance: Medium → High
Changed in charm-nova-compute:
milestone: none → 17.11
Changed in charm-test-infra:
milestone: none → 17.11
Ryan Beisner (1chb1n) on 2017-10-13
Changed in openstack-bundles:
assignee: nobody → Ryan Beisner (1chb1n)
importance: Undecided → High
Changed in openstack-charm-testing:
status: New → Confirmed
Changed in openstack-bundles:
status: New → Confirmed
James Page (james-page) on 2017-10-16
Changed in openstack-charm-testing:
status: Confirmed → Fix Released
Ryan Beisner (1chb1n) on 2017-11-14
Changed in openstack-bundles:
assignee: Ryan Beisner (1chb1n) → Andrew McLeod (admcleod)
James Page (james-page) on 2017-12-01
Changed in charm-test-infra:
milestone: 17.11 → 18.02
Changed in charm-nova-compute:
milestone: 17.11 → 18.02
Ryan Beisner (1chb1n) on 2018-03-09
Changed in charm-test-infra:
milestone: 18.02 → 18.05
Changed in charm-nova-compute:
milestone: 18.02 → 18.05
David Ames (thedac) on 2018-06-11
Changed in charm-test-infra:
milestone: 18.05 → 18.08
Changed in charm-nova-compute:
milestone: 18.05 → 18.08

Reviewed: https://review.openstack.org/499823
Committed: https://git.openstack.org/cgit/openstack/charm-nova-compute/commit/?id=584a8414fe07a77ba93276e2c569045f8356001e
Submitter: Zuul
Branch: master

commit 584a8414fe07a77ba93276e2c569045f8356001e
Author: Felipe Reyes <email address hidden>
Date: Mon Oct 2 17:59:34 2017 -0300

    Remove databases relation

    Since Icehouse nova-compute does not need to access to a database, all
    accesses are made through nova-conductor.

    This patch removes shared-db relation and their hook handler.

    Change-Id: I7c4f6a70785d7dad1727d52cf86508209849ca35
    Closes-Bug: 1713807

Changed in charm-nova-compute:
status: In Progress → Fix Committed
Changed in charm-lxd:
assignee: nobody → Chris MacNaughton (chris.macnaughton)
importance: Undecided → Critical
status: New → In Progress
Changed in charm-ceilometer:
assignee: nobody → Chris MacNaughton (chris.macnaughton)
importance: Undecided → Critical
status: New → In Progress
Changed in charm-ceilometer-agent:
assignee: nobody → Chris MacNaughton (chris.macnaughton)
importance: Undecided → Critical
status: New → In Progress
Changed in charm-ceph-mon:
assignee: nobody → Chris MacNaughton (chris.macnaughton)
importance: Undecided → Critical
status: New → In Progress
Changed in charm-ceph-osd:
assignee: nobody → Chris MacNaughton (chris.macnaughton)
importance: Undecided → Critical
status: New → In Progress
Changed in charm-cinder:
assignee: nobody → Chris MacNaughton (chris.macnaughton)
importance: Undecided → Critical
status: New → In Progress
Changed in charm-heat:
assignee: nobody → Chris MacNaughton (chris.macnaughton)
importance: Undecided → Critical
status: New → In Progress
Changed in charm-nova-cloud-controller:
assignee: nobody → Chris MacNaughton (chris.macnaughton)
importance: Undecided → Critical
status: New → In Progress
Changed in charm-ceph-radosgw:
assignee: nobody → Chris MacNaughton (chris.macnaughton)
importance: Undecided → Critical
status: New → In Progress
Changed in openstack-mojo-specs:
status: Confirmed → Fix Released

Reviewed: https://review.openstack.org/583493
Committed: https://git.openstack.org/cgit/openstack/charm-ceilometer-agent/commit/?id=ddc41e7e4b2256905df53774344c4336965a4285
Submitter: Zuul
Branch: master

commit ddc41e7e4b2256905df53774344c4336965a4285
Author: Chris MacNaughton <email address hidden>
Date: Wed Jul 18 10:19:42 2018 +0200

    Remove old nova-compute / mysql relation

    Change-Id: I27ed69f500e10b574fa86504fd6c93d916cb7da2
    Closes-Bug: #1713807

Changed in charm-ceilometer-agent:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/583495
Committed: https://git.openstack.org/cgit/openstack/charm-ceph-osd/commit/?id=6847ff93733f3238eeb67c2a098e5f803ff7ca5b
Submitter: Zuul
Branch: master

commit 6847ff93733f3238eeb67c2a098e5f803ff7ca5b
Author: Chris MacNaughton <email address hidden>
Date: Wed Jul 18 10:20:09 2018 +0200

    Remove old nova-compute / mysql relation

    Change-Id: I0f07da697cb96279dcd7f7f70826c0c465737fb3
    Closes-Bug: #1713807

Changed in charm-ceph-osd:
status: In Progress → Fix Committed
Changed in charm-ceilometer:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/583492
Committed: https://git.openstack.org/cgit/openstack/charm-ceilometer/commit/?id=fed72d6f2efbbbfaa5af701d4c1cca9e9b10efa5
Submitter: Zuul
Branch: master

commit fed72d6f2efbbbfaa5af701d4c1cca9e9b10efa5
Author: Chris MacNaughton <email address hidden>
Date: Wed Jul 18 10:19:27 2018 +0200

    Remove old nova-compute / mysql relation

    Change-Id: I9ad9e7668a2664a0ac9fde680869737e76ed87b6
    Closes-Bug: #1713807

Reviewed: https://review.openstack.org/583494
Committed: https://git.openstack.org/cgit/openstack/charm-ceph-mon/commit/?id=eb5f3ba080d6f1d7c6992e9d0ad6d948c0163ce9
Submitter: Zuul
Branch: master

commit eb5f3ba080d6f1d7c6992e9d0ad6d948c0163ce9
Author: Chris MacNaughton <email address hidden>
Date: Wed Jul 18 10:19:55 2018 +0200

    Remove old nova-compute / mysql relation

    Change-Id: Id4c2b5a1e2409adf375aba282d9ca0b7ebd4d847
    Closes-Bug: #1713807

Changed in charm-ceph-mon:
status: In Progress → Fix Committed
Changed in charm-ceph-radosgw:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/583496
Committed: https://git.openstack.org/cgit/openstack/charm-ceph-radosgw/commit/?id=a2a3250afb29c67924526bd9e1286014557b3027
Submitter: Zuul
Branch: master

commit a2a3250afb29c67924526bd9e1286014557b3027
Author: Chris MacNaughton <email address hidden>
Date: Wed Jul 18 10:20:23 2018 +0200

    Remove old nova-compute / mysql relation

    Change-Id: I45bf4f6b9eb1fb50629acc0f00ccde774a7a5a03
    Closes-Bug: #1713807

Reviewed: https://review.openstack.org/583498
Committed: https://git.openstack.org/cgit/openstack/charm-heat/commit/?id=58ed31327b63dcde2daa5e1cea3e73d15871b362
Submitter: Zuul
Branch: master

commit 58ed31327b63dcde2daa5e1cea3e73d15871b362
Author: Chris MacNaughton <email address hidden>
Date: Wed Jul 18 10:20:50 2018 +0200

    Remove old nova-compute / mysql relation

    Change-Id: Id45ab06b04de380188b5bceb3313b853b9481ccf
    Closes-Bug: #1713807

Changed in charm-heat:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/583500
Committed: https://git.openstack.org/cgit/openstack/charm-nova-cloud-controller/commit/?id=4e7dfc3714e06ab81dfe5bc26625a5cc1be7cda2
Submitter: Zuul
Branch: master

commit 4e7dfc3714e06ab81dfe5bc26625a5cc1be7cda2
Author: Chris MacNaughton <email address hidden>
Date: Wed Jul 18 10:21:15 2018 +0200

    Remove old nova-compute / mysql relation

    Change-Id: I1a90043581bc5845df19538f1fd9d307863cf22f
    Closes-Bug: #1713807

Changed in charm-nova-cloud-controller:
status: In Progress → Fix Committed
Changed in charm-cinder:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/583497
Committed: https://git.openstack.org/cgit/openstack/charm-cinder/commit/?id=cef0c23583a5ad6c7faa2883486e1fc2f561c618
Submitter: Zuul
Branch: master

commit cef0c23583a5ad6c7faa2883486e1fc2f561c618
Author: Chris MacNaughton <email address hidden>
Date: Wed Jul 18 10:20:36 2018 +0200

    Remove old nova-compute / mysql relation

    Change-Id: I4880ed1d6f7dbdcb3db7a2c22ba5294b60c6e1f8
    Closes-Bug: #1713807

Reviewed: https://review.openstack.org/583501
Committed: https://git.openstack.org/cgit/openstack/charm-odl-controller/commit/?id=18326375bd6de02fd44bdceab3dcb8a3de2d035a
Submitter: Zuul
Branch: master

commit 18326375bd6de02fd44bdceab3dcb8a3de2d035a
Author: Chris MacNaughton <email address hidden>
Date: Wed Jul 18 10:21:28 2018 +0200

    Remove old nova-compute / mysql relation

    Change-Id: I41630fa316d1ea24a9fa067179764bf7c72b8693
    Closes-Bug: #1713807

Changed in charm-odl-controller:
status: New → Fix Committed
David Ames (thedac) on 2018-09-06
Changed in charm-nova-compute:
status: Fix Committed → Fix Released
Changed in charm-nova-cloud-controller:
milestone: none → 18.08
Changed in charm-heat:
milestone: none → 18.08
Changed in charm-cinder:
milestone: none → 18.08
Changed in charm-ceph-radosgw:
milestone: none → 18.08
Changed in charm-ceph-osd:
milestone: none → 18.08
Changed in charm-ceph-mon:
milestone: none → 18.08
Changed in charm-ceilometer-agent:
milestone: none → 18.08
Changed in charm-ceilometer:
milestone: none → 18.08
David Ames (thedac) on 2018-09-06
Changed in charm-odl-controller:
milestone: none → 18.08
James Page (james-page) on 2018-09-12
Changed in charm-test-infra:
milestone: 18.08 → 18.11
James Page (james-page) on 2018-09-12
Changed in charm-nova-cloud-controller:
status: Fix Committed → Fix Released
Changed in charm-heat:
status: Fix Committed → Fix Released
Changed in charm-cinder:
status: Fix Committed → Fix Released
Changed in charm-ceph-radosgw:
status: Fix Committed → Fix Released
Changed in charm-ceph-osd:
status: Fix Committed → Fix Released
Changed in charm-ceph-mon:
status: Fix Committed → Fix Released
Changed in charm-ceilometer-agent:
status: Fix Committed → Fix Released
Changed in charm-ceilometer:
status: Fix Committed → Fix Released
Changed in charm-odl-controller:
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/583499
Committed: https://git.openstack.org/cgit/openstack/charm-lxd/commit/?id=4d7b3e924008af878b0c369c1bd3e92238d51a93
Submitter: Zuul
Branch: master

commit 4d7b3e924008af878b0c369c1bd3e92238d51a93
Author: Chris MacNaughton <email address hidden>
Date: Wed Jul 18 10:21:03 2018 +0200

    Remove old nova-compute / mysql relation and patch for nova-lxd bug

    This review is modified to include a patch to resolve bug #1793137
    which is due to a bug in nova-lxd where the wrong pool name (lxd) is
    used with zfs if lxd is new enough that the storage.zfs_pool_name key
    is missing from the config. This is the case on bionic and snap
    installed lxd.

    Closes-Bug: #1713807
    Related-Bug: #1793137
    Change-Id: I1123d9882bdb00e9183424b363fc3d1ff25f2346

Changed in charm-lxd:
status: In Progress → Fix Committed
David Ames (thedac) on 2018-11-20
Changed in charm-test-infra:
milestone: 18.11 → 19.04
David Ames (thedac) on 2018-11-20
Changed in charm-lxd:
milestone: none → 19.04
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers