check_octavia_loadbalancers needs more controls to reduce undesired alerts

Bug #1887561 reported by Paul Goins on 2020-07-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
charm-openstack-service-checks
Medium
Unassigned

Bug Description

The current Octavia load balancer checks don't allow for controlling which load balancers we monitor. It's either on (along with all the other octavia checks, via the check-octavia config option), or off (again, along with all the other octavia checks).

A few use cases to consider:

* Load balancers may be used by the end users, but are not necessary for correct functionality of the cloud. We may want to turn off monitoring of such user-created load balancers, so as to avoid alerting when a load balancer goes into a degraded state due to user actions, such as e.g. adding members without removing no-longer used members.

* Certain load balancers may be critical for overall cloud functionality, e.g. the load balancers associated with k8s instances. We may want to allow filtering based upon domain, project, and/or specific load balancer IDs so we can monitor those load balancers without having alerts fire for other non-critical load balancers.

Related branches

Adam Dyess (addyess) wrote :

./files/plugins/check_octavia.py doesn't do any such filtering of bad loadbalancers.
It also only signals the first load_balancer with an issue.

I propose that ALL of the crit|warn loadbalancers be listed in the check. And then a filtering process be applied by configuration similar to contrail_ignored_alarms.

Changed in charm-openstack-service-checks:
status: New → Confirmed
importance: Undecided → Medium
Adam Dyess (addyess) on 2020-07-14
Changed in charm-openstack-service-checks:
assignee: nobody → Adam Dyess (addyess)
Adam Dyess (addyess) on 2020-07-16
Changed in charm-openstack-service-checks:
status: Confirmed → Fix Committed
Adam Dyess (addyess) wrote :
Changed in charm-openstack-service-checks:
status: Fix Committed → Fix Released
Jeremy Lounder (jldev) on 2020-07-16
Changed in charm-openstack-service-checks:
milestone: none → 20.08
Adam Dyess (addyess) on 2020-07-16
Changed in charm-openstack-service-checks:
assignee: Adam Dyess (addyess) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers