The manila-charm blocked with ports not opened after installed before first upgrade-status

Bug #1706568 reported by Alex Kavanagh on 2017-07-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Manila Charm
Low
Unassigned

Bug Description

Essentially:

Model Controller Cloud/Region Version
manila lxd localhost/localhost 2.2-beta2

App Version Status Scale Charm Store Rev OS Notes
keystone 9.3.0 active 1 keystone jujucharms 300 ubuntu
manila blocked 1 manila local 0 ubuntu
manila-generic active 1 manila-generic jujucharms 7 ubuntu
percona-cluster 5.6.34-26.19 active 1 percona-cluster jujucharms 262 ubuntu
rabbitmq-server 3.5.7 active 1 rabbitmq-server jujucharms 265 ubuntu

Unit Workload Agent Machine Public address Ports Message
keystone/0* active idle 0 172.16.1.157 5000/tcp Unit is ready
manila/0* blocked idle 1 172.16.1.110 8786/tcp Ports which should be open, but are not: 8786
...

This gets corrected on the next update-status. 8786 is the api service port for manila. It's probably a race-hazard with (re)starting the service, and that service opening the port, during the last relation join hook, before the update-status got to check the port. The service is (most likely) started as otherwise the status message would show 'services not running ...'

Fix is probably complicated, as it would require mapping the service to the port, checking if the service is then running, and then waiting for a "while" until the port either opens or we declare it dead/blocked.

Changed in charm-manila:
importance: Undecided → Medium
Alex Kavanagh (ajkavanagh) wrote :

It's been set to low, as it's only an install issue and doesn't stop the charm progressing to an installed/running state.

Changed in charm-manila:
importance: Medium → Low
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers