interface has no unit test coverage

Bug #1729413 reported by Ryan Beisner on 2017-11-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack RabbitMQ Charm Interface
Low
Unassigned

Bug Description

The rabbitmq charm interface has no unit test coverage. It also tries to build an impossible virtualenv, as charm-tools does not yet support py3.

ubuntu@beisner-bastion:~/git/charm-interface-rabbitmq⟫ tree
.
├── copyright
├── interface.yaml
├── requires.py
├── test-requirements.txt
└── tox.ini

Ryan Beisner (1chb1n) wrote :

I've raised the following review to update tox.ini and test-requirements accordingly.
 This does not add unit tests, but does allow the basic pep8 to pass and the virtualenv to build.

https://review.openstack.org/#/c/517101/

Reviewed: https://review.openstack.org/517101
Committed: https://git.openstack.org/cgit/openstack/charm-interface-rabbitmq/commit/?id=2e153d9b70b82fc22d618c7d8762a0d55c52cfdd
Submitter: Zuul
Branch: master

commit 2e153d9b70b82fc22d618c7d8762a0d55c52cfdd
Author: Ryan Beisner <email address hidden>
Date: Wed Nov 1 20:12:44 2017 +0000

    Update tests and requirements

    Charm-tools and ostestr are not necessary as there are
    no unit tests in this repo. This update allows
    the virtualenv to successfully build, and the pep8
    test to successfully execute.

    Change-Id: If4b64f6c42e58dd3e4b9536a0143434a5f636f1c
    Partial-bug: #1729413

James Page (james-page) on 2017-11-02
Changed in charm-interface-rabbitmq:
importance: Undecided → Low
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers