Ceph storage setup incomplete

Bug #1846480 reported by Liam Young on 2019-10-03
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gnocchi Charm
Critical
Liam Young

Bug Description

Gnocchi requests the creation of a ceph pool but for some reason the reactive event indicating that the pool creation was successful never happens. As a result gnocchi does not render its configs and start service leading to reporting:

"Services not running that should be: gnocchi-metricd, apache2; Ports which should be open, but are not: 8041"

Liam Young (gnuoy) wrote :

To reproduce just run the charms amulet smoke test.

Changed in charm-gnocchi:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Liam Young (gnuoy)
milestone: none → 19.10

Fix proposed to branch: master
Review: https://review.opendev.org/686584

Changed in charm-gnocchi:
status: Confirmed → In Progress

Reviewed: https://review.opendev.org/686584
Committed: https://git.openstack.org/cgit/openstack/charm-gnocchi/commit/?id=d0d2ac8864504b62a75f15de5824501152b0d7e0
Submitter: Zuul
Branch: master

commit d0d2ac8864504b62a75f15de5824501152b0d7e0
Author: Liam Young <email address hidden>
Date: Fri Oct 4 12:20:34 2019 +0000

    Gate sending ceph pool creation request.

    Add new state ceph.create_pool.req.sent to gate sending the ceph
    pool creation request. This fixes a problem where the changed
    method in requires of ceph-client interface raises the
    '{relation_name}.pools.available' state but the create_pool
    method then removes it again.

    Also remove snap functional tests as they are no longer
    needed since that install method via charms is not
    actively supported.

    Change-Id: Iaf986d24f005bcc7c8f485cfc2eb1775e6dbbbdd
    Closes-Bug: #1846480

Changed in charm-gnocchi:
status: In Progress → Fix Committed
David Ames (thedac) on 2019-10-24
Changed in charm-gnocchi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers