ssl_ca not supported

Bug #1802407 reported by Narinder Gupta on 2018-11-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack glance-simplestreams-sync charm
Medium
Alex Kavanagh
simplestreams (Ubuntu)
Medium
Unassigned

Bug Description

Glance simplestream sync charm does not support ssl_ca option. which causes failed to connect to openstack api for image sync.

This bug has been created to add an option ssl_ca so that rest of openstack operation can be completed.

Related branches

tags: added: cpe-onsite
Narinder Gupta (narindergupta) wrote :

As customer wanted to use juju on top of stack and simplestreams created on cloud so it is blocked currently so marking as field critical

Ryan Beisner (1chb1n) on 2018-11-29
Changed in charm-glance-simplestreams-sync:
milestone: none → 19.04
assignee: nobody → Alex Kavanagh (ajkavanagh)
importance: Undecided → Medium
status: New → Confirmed
Dean Henrichsmeyer (dean) wrote :

Missing features don't qualify under the Field SLA, removing ~field-*

Alex Kavanagh (ajkavanagh) wrote :

@narindergupta, please could you elaborate on what which bit(s) are missing an SSL option that you need to implement in the customer environment?

Do you mean:

1. SSL between gss and the other OpenStack services within the cloud
2. SSL as part of the syncing process as part of simplestreams? (e.g. specifying the cert chain for an https endpoint).
3. Something else?

Thanks

Alex hats a starting point I can see. AS this cloud has keystone V3 with
ssl enabled and certs were required to access openstack cloud.

Thanks and Regards,
Narinder Gupta
Canonical, Ltd.
+1.281.736.5150

Ubuntu- Linux for human beings | www.ubuntu.com | www.canonical.com

On Thu, Nov 29, 2018 at 9:26 AM Alex Kavanagh <email address hidden>
wrote:

> @narindergupta, please could you elaborate on what which bit(s) are
> missing an SSL option that you need to implement in the customer
> environment?
>
> Do you mean:
>
> 1. SSL between gss and the other OpenStack services within the cloud
> 2. SSL as part of the syncing process as part of simplestreams? (e.g.
> specifying the cert chain for an https endpoint).
> 3. Something else?
>
> Thanks
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1802407
>
> Title:
> ssl_ca not supported
>
> Status in OpenStack glance-simplestreams-sync charm:
> Confirmed
>
> Bug description:
> Glance simplestream sync charm does not support ssl_ca option. which
> causes failed to connect to openstack api for image sync.
>
> This bug has been created to add an option ssl_ca so that rest of
> openstack operation can be completed.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/charm-glance-simplestreams-sync/+bug/1802407/+subscriptions
>

Alex Kavanagh (ajkavanagh) wrote :

So having done some preliminary work around adding ssl_ca functionality to the charm, the following areas need to be covered:

1. Adding the ssl_* options to the glance-simple-streams charm
2. Modifying the gss charm to actually use the values
3. Adding tests to the gss charm to ensure that the contract around ssl_* options is maintained over time.
4. Changing simplestreams python package to use SSL endpoints; at present it is unaware of certs, etc.

Thus to provide this feature, both simplestreams and the gss charm need to be modified.

Fix proposed to branch: master
Review: https://review.openstack.org/623488

Changed in charm-glance-simplestreams-sync:
status: Confirmed → In Progress
Alex Kavanagh (ajkavanagh) wrote :

Status: so I've submitted my changes to g-s-s charm and to simplestreams module (on LP). Now just need to get those reviewed, and probably raise an SRU to get simplestreams changes backported to bionic.

Scott Moser (smoser) on 2019-01-07
Changed in simplestreams (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium

This bug is fixed with commit 99ba3f21 to simplestreams on branch master.
To view that commit see the following URL:
https://git.launchpad.net/simplestreams/commit/?id=99ba3f21

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package simplestreams - 0.1.0-22-g409fdc15-0ubuntu1

---------------
simplestreams (0.1.0-22-g409fdc15-0ubuntu1) disco; urgency=medium

  * debian/README.source: update to refer to upstream packaging
    ubuntu/devel branch.
  * debian/new-upstream-snapshot: remove obsolete bzr tool.
  * New upstream snapshot.
    - tools: rename export-tarball to make-tarball.
    - Do not run flake8 during 'make test', remove 'trusty-flake8' tox env.
    - Add SSL support to simplestreams/openstack.py
      [Alex Kavanagh] (LP: #1802407)
    - Add 'ubuntu' alias to CURRENT_LTS. [Daniel Watkins]
    - tenv: Put topdir/bin before topdir/tools in PATH [Daniel Watkins]

 -- Scott Moser <email address hidden> Mon, 07 Jan 2019 15:38:04 -0500

Changed in simplestreams (Ubuntu):
status: Confirmed → Fix Released

Reviewed: https://review.openstack.org/623488
Committed: https://git.openstack.org/cgit/openstack/charm-glance-simplestreams-sync/commit/?id=ac1d2b5dda9cbbe56a6657971f5f7c01d5cb9ac9
Submitter: Zuul
Branch: master

commit ac1d2b5dda9cbbe56a6657971f5f7c01d5cb9ac9
Author: Alex Kavanagh <email address hidden>
Date: Fri Dec 7 13:07:31 2018 +0000

    Add ssl_ca option to enable to gss

    This patch enables SSL to be used with glance-simplestreams-sync.
    The ssl_ca option allows a base64 encoded PEM CA certificate to be
    used with g-s-s such that the keystone and glance HTTPS sessions are
    verified using that certificate.

    A new basic_deployment_ssl.py is introduced that just verifies that the
    gss charm can get gss to perform a sync; this verifies that gss can
    communicate with https versions of keystone and glance.

    Note that the simplestreams package also requires a change for SSL to
    function properly. As simplestreams doesn't seem to use PyPi, the
    version from the git master will need to be used.

    Change-Id: Idcdcb2c933a92a558e729aeb718b58d4077621a7
    Closes-Bug: #1802407

Changed in charm-glance-simplestreams-sync:
status: In Progress → Fix Committed
Alex Kavanagh (ajkavanagh) wrote :

Narinder: So now the charm and gss should support ssl (at least in my tests!) Please could you test them and comment back here the results. Thanks, Alex.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers