Upgrade from queens to rocky uninstalls nova-compute

Bug #1802400 reported by Liam Young on 2018-11-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack ceilometer-agent charm
Critical
Unassigned

Bug Description

Upgrading a nova-compute node from Queens to Rocky has resulted in the nova-compute package (among others) being purged from the system. This seems to be down to the ceilometer-agent charm running:

apt-get --assume-yes purge python-memcache python-ceilometer

Liam Young (gnuoy) wrote :
Changed in charm-ceilometer-agent:
importance: Undecided → Critical
milestone: none → 18.11
Liam Young (gnuoy) wrote :

What appears to be happening is that our testing sets the openstack-origin of nova-compute to the new release and then immediately sets the openstack-origin of ceilometer-agent to the new release too and then waits. However, it seems juju does not guarente the order that those two config-changed events fire. So in the case of this bug ceilometer-agent config-changed fired first and caused havoc.

Short term:
Document: Upgrade ceilometer-agent after nova-compute has finished in your deployment

Medium Term:
Make ceilometer-agent upgrades less destructive if they are triggered out of order.

Longer term:
Remove openstack-origin from ceilometer-agent and have upgrades triggered from the principle.

Liam Young (gnuoy) wrote :

I am testing changes atm which remove openstack-origin from ceilometer-agent and trigger upgrades from the principle

cs:~gnuoy/ceilometer-3
cs:~gnuoy/ceilometer-agent-1
cs:~gnuoy/nova-compute-13

Reviewed: https://review.openstack.org/617148
Committed: https://git.openstack.org/cgit/openstack/charm-ceilometer-agent/commit/?id=1a40c275d553e8f85395dcb811ee3249ae257d41
Submitter: Zuul
Branch: master

commit 1a40c275d553e8f85395dcb811ee3249ae257d41
Author: Liam Young <email address hidden>
Date: Sun Nov 11 15:52:22 2018 +0000

    Remove independent OpenStack upgrade

    Ceilometer has had an openstack-origin and supported upgrading
    the Ceilometer version independently of the principle that it is
    associated with. This can cause issues with clashes in package
    dependencies between the two. This change makes the
    ability for the agent to be upgraded independently of the principle
    and instead has the upgrade triggered by the principle. This brings
    this charm inline with the other OpenStack subordinate charms.

    Change-Id: I641ac2168ac705191d916eaa0624214791e1745d
    Closes-Bug: #1802400

Changed in charm-ceilometer-agent:
status: New → Fix Committed

Change abandoned by Corey Bryant (<email address hidden>) on branch: master
Review: https://review.openstack.org/616753
Reason: This was fixed here: https://review.openstack.org/#/c/617148/

Reviewed: https://review.openstack.org/616753
Committed: https://git.openstack.org/cgit/openstack/charm-ceilometer-agent/commit/?id=d9430f9bd206d1778e12f0f01ef1e19e1deed7f6
Submitter: Zuul
Branch: master

commit d9430f9bd206d1778e12f0f01ef1e19e1deed7f6
Author: Corey Bryant <email address hidden>
Date: Thu Nov 8 21:33:14 2018 -0500

    py3: handle shared subordinate dependencies on upgrade

    Switch to marking non-leaf python-* packages as automatically
    installed so that they will be purged once the last remaining
    package that depends on them that was manually installed is
    removed.

    Change-Id: If821cb511a2fdb65ac3e8ad8db88a00770864d42
    Closes-Bug: 1802400

David Ames (thedac) on 2018-11-20
Changed in charm-ceilometer-agent:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers