extraneous vim editor configuration comments

Bug #1229324 reported by Terri Yu on 2013-09-23
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ceilometer
Fix Released
Low
Terri Yu
Cinder
Low
Mike Perez
Glance
Undecided
Noboru Arai
Glance Client
Low
Noboru Arai
Manila
Undecided
Marc Koderer
OpenStack Compute (nova)
Low
Liusheng
OpenStack Dashboard (Horizon)
Wishlist
Yongli He
OpenStack Heat
Fix Released
Low
Oleksii Chuprykov
OpenStack Object Storage (swift)
Undecided
Xurong Yang
manila-ui
Low
Tatiana Ovchinnikova
neutron
Wishlist
Liusheng
oslo-incubator
Low
Joe Gordon
python-ceilometerclient
Low
gordon chung
python-cinderclient
Low
Jay Bryant
python-neutronclient
Undecided
Christian Berendt
python-swiftclient
Undecided
Xurong Yang
python-troveclient
Wishlist
Yongli He
storyboard
Undecided
Yongli He
taskflow
Undecided
Xurong Yang
tempest
Undecided
Masayuki Igawa
tuskar
Low
Yongli He

Bug Description

Many of the source code files have a beginning line

# vim: tabstop=4 shiftwidth=4 softtabstop=4

This should be deleted.

Many of these lines are in the ceilometer/openstack/common directory.

Fix proposed to branch: master
Review: https://review.openstack.org/47894

Changed in ceilometer:
assignee: nobody → Terri Yu (terriyu)
status: New → In Progress
Terri Yu (terriyu) on 2013-09-23
summary: - extraneous text editor configuration in audit.py
+ extraneous vim editor configuration comments
description: updated
Julien Danjou (jdanjou) on 2013-09-24
Changed in ceilometer:
importance: Undecided → Low
Mark McLoughlin (markmc) wrote :

I think it would be good to send a brief RFC email to <email address hidden> - someone might come up with a plausible reason to keep these.

Also, I think it's best to defer this churn until Icehouse.

Changed in oslo:
status: New → Confirmed
importance: Undecided → Low
Mike Perez (thingee) on 2013-09-30
Changed in cinder:
importance: Undecided → Low
status: New → Confirmed
assignee: nobody → Mike Perez (thingee)
John Griffith (john-griffith) wrote :

Personally I'm not sure why this is of concern, and definitely not something worth dealing with until the next release IMO.

Changed in cinder:
importance: Low → Undecided
importance: Undecided → Low

Reviewed: https://review.openstack.org/47894
Committed: http://github.com/openstack/ceilometer/commit/3142a317532beb28534ea28731f6d0c2999b1b07
Submitter: Jenkins
Branch: master

commit 3142a317532beb28534ea28731f6d0c2999b1b07
Author: Terri Yu <email address hidden>
Date: Fri Sep 27 01:17:55 2013 +0000

    Remove extraneous vim configuration comments

    Fixes bug # 1229324

    Remove line containing

    comment - # vim: tabstop=4 shiftwidth=4 softtabstop=4

    at the top of source code files, except for files in
    ceilometer/openstack/common and bin/ceilometer-rpc-zmq-receiver

    Change-Id: Ic8643afbc3510c36c41871b8a840a9b9e21eaba7

Changed in ceilometer:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/51875
Committed: http://github.com/openstack/swift/commit/a0017e053734ea5e72bfcc3fdc630c8a7a25431a
Submitter: Jenkins
Branch: master

commit a0017e053734ea5e72bfcc3fdc630c8a7a25431a
Author: Greg Lange <email address hidden>
Date: Tue Oct 15 16:23:00 2013 +0000

    Removes vim comment

    Change-Id: Ibc930638ee2d839e8499a13018c205b615f8b854
    Partial-Bug: 1229324

Download full text (24.9 KiB)

Reviewed: https://review.openstack.org/54029
Committed: http://github.com/openstack/swift/commit/94d3671b0bbf87fdbff845643963f3f9a97c58b5
Submitter: Jenkins
Branch: feature/ec

commit abcecd26a7b5871f75f0fbddf0d08bbac95bb089
Author: Kun Huang <email address hidden>
Date: Wed Oct 23 21:19:01 2013 +0800

    utf8 encode tempurl key

    In tempurl middleware, hmac uses the value of account metadata to
    generate HMAC-SHA1 signature and hmac must accept a str-type string, not
    a unicode string. The meta dict returned from get_info stroges special
    chars as unicode however. So just encode it for tempurl using.

    Closes-Bug: #1242644
    Change-Id: I4be62eea014a573efc4748470de57dccf00e431d

commit cd2e7df0b69bbd269cd3c4170e0fee8186a07c95
Author: Pete Zaitcev <email address hidden>
Date: Tue Oct 22 17:18:04 2013 -0600

    Add an __str__ method to brokers

    A few uses of broker.db_file are in printouts where we do need
    them, so the administrator may know what's up. Seems like an easy
    way to get rid of those is to make brokers identify themselves
    with common __str__. Alternative back-end implementations may
    supply something other than a filename here, for example a cluster
    name and a volume name.

    Note that I'm not sure if correct coercion would occur when
    brokers are bounced through dictionaries, hence explicit str().

    Change-Id: I329788ebd1fbe39ffadcf9f9d5194a74a88dde58

commit 9807a358c6d1314d25e3a41da75be5851fa0ac27
Author: Donagh McCabe <email address hidden>
Date: Fri Aug 23 15:03:08 2013 +0100

    Add WWW-Authenticate to 401 responses

    Per http://www.ietf.org/rfc/rfc2616.txt, when a 401 error is returned, the
    Www-Authenticate response header MUST also be returned. The format is
    described in http://www.ietf.org/rfc/rfc2617.txt.

    Swift supports and/or implements a number of authentication schemes
    including tempauth, Keystone, tempurl, formpost and container sync. In
    this fix, we use a catch-all, "Swift". The realm is the account (where
    known) or "unknown" (bad path or where the 401 is returned from code
    that does not have the request). Examples:

         Www-Authenticate: Swift realm="AUTH_1234567889"
         Www-Authenticate: Swift realm="unknown"

    Fixes bug #1215491

    Change-Id: I03362789318dfa156d3733ef9348795062a9cfc4

commit ed5101b2002b877518466ae5f9a6d652581238f2
Author: Yuan Zhou <email address hidden>
Date: Sat Oct 19 11:40:35 2013 +0800

    Adding more unit tests for audit_location_generator

    Change-Id: I40410fbbb79cea8647074f703e4675364c69d930

commit 5202b0e58613738cc81ec63e7c6da14ce5429526
Author: Peter Portante <email address hidden>
Date: Thu Sep 12 19:51:18 2013 -0400

    DiskFile API, with reference implementation

    Refactor on-disk knowledge out of the object server by pushing the
    async update pickle creation to the new DiskFileManager class (name is
    not the best, so suggestions welcome), along with the REPLICATOR
    method logic. We also move the mount checking and thread pool storage
    to the new ondisk.Devices object, which then also becomes th...

Changed in python-ceilometerclient:
assignee: nobody → Victoria Martínez de la Cruz (vkmc)
Changed in python-ceilometerclient:
assignee: Victoria Martínez de la Cruz (vkmc) → nobody
Changed in python-ceilometerclient:
assignee: nobody → Sphoorti (sphoorti-joglekar)
Changed in python-ceilometerclient:
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/55703

Changed in python-ceilometerclient:
status: Confirmed → In Progress
Changed in oslo:
assignee: nobody → Sphoorti (sphoorti-joglekar)

Fix proposed to branch: master
Review: https://review.openstack.org/55779

Changed in oslo:
status: Confirmed → In Progress
Thierry Carrez (ttx) on 2013-12-04
Changed in ceilometer:
milestone: none → icehouse-1
status: Fix Committed → Fix Released
ZhiQiang Fan (aji-zqfan) on 2013-12-28
Changed in python-heatclient:
assignee: nobody → ZhiQiang Fan (aji-zqfan)
Changed in heat:
assignee: nobody → ZhiQiang Fan (aji-zqfan)
ZhiQiang Fan (aji-zqfan) on 2013-12-28
Changed in heat:
assignee: ZhiQiang Fan (aji-zqfan) → nobody
Changed in python-neutronclient:
assignee: nobody → ZhiQiang Fan (aji-zqfan)
Changed in heat:
assignee: nobody → ZhiQiang Fan (aji-zqfan)
Changed in neutron:
assignee: nobody → ZhiQiang Fan (aji-zqfan)

Fix proposed to branch: master
Review: https://review.openstack.org/64326

Changed in python-heatclient:
status: New → In Progress

Reviewed: https://review.openstack.org/63990
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=ff3f2e5735f0d486b72b6881b05ace94d6d34d03
Submitter: Jenkins
Branch: master

commit ff3f2e5735f0d486b72b6881b05ace94d6d34d03
Author: DennyZhang <email address hidden>
Date: Tue Dec 24 22:37:04 2013 -0600

    Remove vim header

    No need to set tabstop tons of times, this can be set in your vimrc
    file instead.

    More disucssion:
    http://openstack.10931.n7.nabble.com/Remove-vim-modelines-td21780.html

    Partial-Bug: #1229324
    Change-Id: Ib3a31c8819ee1950d72f7da5627593623d351560

Changed in heat:
status: New → Triaged
importance: Undecided → Low

Fix proposed to branch: master
Review: https://review.openstack.org/64691

Changed in heat:
assignee: ZhiQiang Fan (aji-zqfan) → DennyZhang (denny-6)
status: Triaged → In Progress
huangtianhua (huangtianhua) wrote :

Missing the tempest?

DennyZhang (denny-6) on 2014-01-06
Changed in cinder:
status: Confirmed → Fix Committed
Doug Hellmann (doug-hellmann) wrote :
Changed in oslo:
status: In Progress → Fix Committed
assignee: Sphoorti (sphoorti-joglekar) → Joe Gordon (jogo)
milestone: none → icehouse-2

Reviewed: https://review.openstack.org/64326
Committed: https://git.openstack.org/cgit/openstack/python-heatclient/commit/?id=d80462893351d36b4495756773d4f9ad2682f4cc
Submitter: Jenkins
Branch: master

commit d80462893351d36b4495756773d4f9ad2682f4cc
Author: ZhiQiang Fan <email address hidden>
Date: Sat Dec 28 15:51:05 2013 +0800

    Remove vim header

    Vim settings can be done in your vimrc file, there is no need to add
    them in each source files. Also if set incorrectly, gate (pep8 check)
    will catch your mistakes.

    NOTE: openstack.common files are left untouched because they should be
    fixed in oslo.

    Change-Id: I96fe6479e64a13766e7a974727405423a66cd496
    Closes-Bug: #1229324

Changed in python-heatclient:
status: In Progress → Fix Committed

Fix proposed to branch: master
Review: https://review.openstack.org/66507

Changed in tempest:
assignee: nobody → Masayuki Igawa (igawa)
status: New → In Progress
Noboru Arai (arai-h) on 2014-01-14
Changed in glance:
assignee: nobody → Noboru Arai (arai-h)
status: New → In Progress
Changed in python-glanceclient:
assignee: nobody → Noboru Arai (arai-h)
status: New → In Progress
Noboru Arai (arai-h) wrote :

The patch of glance/python-glnaceclient is as follows:

* glance(master)
    -https://review.openstack.org/#/c/66504/

* python-glanceclient(master)
    -https://review.openstack.org/#/c/66511/

Reviewed: https://review.openstack.org/66504
Committed: https://git.openstack.org/cgit/openstack/glance/commit/?id=8de10b0f34df60494ceaee29daf79427e7a38d82
Submitter: Jenkins
Branch: master

commit 8de10b0f34df60494ceaee29daf79427e7a38d82
Author: Noboru arai <email address hidden>
Date: Tue Jan 14 15:56:33 2014 +0000

    Remove vim header

    No need to set tabstop tons of times, this can be set in your vimrc
    file instead.

    More disucssion:
    http://openstack.10931.n7.nabble.com/Remove-vim-modelines-td21780.html

    Change-Id: I3b830a5bb831a63c188109e6fad66ba48884fff3
    Partial-Bug: #1229324

Reviewed: https://review.openstack.org/66511
Committed: https://git.openstack.org/cgit/openstack/python-glanceclient/commit/?id=869ea2e61ced4d7ae1e4aa902782090996e2736d
Submitter: Jenkins
Branch: master

commit 869ea2e61ced4d7ae1e4aa902782090996e2736d
Author: Noboru arai <email address hidden>
Date: Tue Jan 14 16:39:41 2014 +0000

    Remove vim header

    No need to set tabstop tons of times, this can be set in your vimrc
    file instead.

    More disucssion:
    http://openstack.10931.n7.nabble.com/Remove-vim-modelines-td21780.html

    Change-Id: I2b37758f9dbb2cad6457a879d4ed7ff0aa69ef8e
    Partial-Bug: #1229324

Feilong Wang (flwang) on 2014-01-20
Changed in python-glanceclient:
importance: Undecided → Low
Noboru Arai (arai-h) on 2014-01-22
Changed in glance:
status: In Progress → Fix Committed
Changed in python-glanceclient:
status: In Progress → Fix Committed
Changed in tempest:
status: In Progress → Fix Released
Thierry Carrez (ttx) on 2014-01-22
Changed in glance:
milestone: none → icehouse-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-01-22
Changed in cinder:
milestone: none → icehouse-2
status: Fix Committed → Fix Released
Liusheng (liusheng) on 2014-01-23
Changed in nova:
assignee: nobody → Liusheng (liusheng)
Thierry Carrez (ttx) on 2014-01-23
Changed in oslo:
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/68552
Committed: https://git.openstack.org/cgit/openstack/tempest/commit/?id=aa175f619425fc638fe489f7b8e0cd1f621ad79f
Submitter: Jenkins
Branch: master

commit aa175f619425fc638fe489f7b8e0cd1f621ad79f
Author: Masayuki Igawa <email address hidden>
Date: Thu Jan 23 12:53:06 2014 +0900

    Remove vim headers 2nd round

    We don't need to have the vim headers in each source files. So we have
    already removed all of it at
     Change-Id: I43703e2289212389c7841f44691ae7849ed1f505
    However, some files still have it now because of the patch time lag.
    Maybe, we should have a hacking rule for this. But it's out of scope
    here.

    Change-Id: I8d09cb41ad633719857973a3ea228cd8dd3a9270
    Closes-Bug: #1229324

ZhiQiang Fan (aji-zqfan) on 2014-01-26
Changed in python-neutronclient:
assignee: ZhiQiang Fan (aji-zqfan) → nobody
Changed in neutron:
assignee: ZhiQiang Fan (aji-zqfan) → nobody
Matt Riedemann (mriedem) on 2014-01-26
Changed in nova:
importance: Undecided → Low
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/69263

Changed in nova:
status: Confirmed → In Progress
Changed in swift:
assignee: nobody → Sphoorti (sphoorti-joglekar)
Changed in swift:
assignee: Sphoorti (sphoorti-joglekar) → nobody

Reviewed: https://review.openstack.org/69318
Committed: https://git.openstack.org/cgit/openstack/tempest/commit/?id=2e9f23e3cb9f0fb430b558bd845e73f285ebca57
Submitter: Jenkins
Branch: master

commit 2e9f23e3cb9f0fb430b558bd845e73f285ebca57
Author: Joe H. Rahme <email address hidden>
Date: Mon Jan 27 11:29:13 2014 +0100

    Removes vim headers 3rd round

    This is a follow up on:
      Change-Id: I8d09cb41ad633719857973a3ea228cd8dd3a9270

    The vim headers in all the files are being removed. We've missed these
    files because of delays in the patches.

    Change-Id: Ie8097db6c60481749c88991864187ade64f39ecb
    Closes-Bug: #1229324

Liusheng (liusheng) on 2014-02-07
Changed in neutron:
assignee: nobody → Liusheng (liusheng)

Fix proposed to branch: master
Review: https://review.openstack.org/71717

Changed in neutron:
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/71722

Fix proposed to branch: master
Review: https://review.openstack.org/71724

Liusheng (liusheng) on 2014-02-07
Changed in python-neutronclient:
assignee: nobody → Liusheng (liusheng)

Fix proposed to branch: master
Review: https://review.openstack.org/71832

Changed in python-neutronclient:
status: New → In Progress
Changed in keystone:
assignee: nobody → Eric Guo (glongwave)
Changed in python-keystoneclient:
assignee: nobody → Eric Guo (glongwave)

Fix proposed to branch: master
Review: https://review.openstack.org/72083

Changed in python-keystoneclient:
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/72089

Changed in keystone:
status: New → In Progress
Jay Bryant (jsbryant) on 2014-02-10
Changed in python-cinderclient:
assignee: nobody → Jay Bryant (jsbryant)
importance: Undecided → Low
Dolph Mathews (dolph) on 2014-02-11
Changed in keystone:
importance: Undecided → Wishlist
Changed in python-keystoneclient:
importance: Undecided → Wishlist
Changed in python-cinderclient:
status: New → In Progress

Reviewed: https://review.openstack.org/72089
Committed: https://git.openstack.org/cgit/openstack/keystone/commit/?id=263b27f2cd9c93adf37528e8822bac00c18eb549
Submitter: Jenkins
Branch: master

commit 263b27f2cd9c93adf37528e8822bac00c18eb549
Author: Eric Guo <email address hidden>
Date: Sat Feb 8 23:15:34 2014 +0800

    Remove vim header

    We don't need vim modelines in each source file, it can be set in
    user's vimrc.

    Change-Id: Ie51ad62946afdf39eadcd59edaf8134ec10265c6
    Closes-Bug: #1229324

Changed in keystone:
status: In Progress → Fix Committed
Changed in python-keystoneclient:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/72083
Committed: https://git.openstack.org/cgit/openstack/python-keystoneclient/commit/?id=d6d0d66374ac8cc70835d4e809c302bfbbeb798b
Submitter: Jenkins
Branch: master

commit d6d0d66374ac8cc70835d4e809c302bfbbeb798b
Author: Eric Guo <email address hidden>
Date: Sat Feb 8 22:22:08 2014 +0800

    Remove vim header

    We don't need vim modelines in each source file, it can be set in
    user's vimrc.

    Change-Id: Ic7a61430a0a320ce6b0c4518d9f5d988e35f8aae
    Closes-Bug: #1229324

Yongli He (yongli-he) on 2014-02-13
Changed in trove:
assignee: nobody → Yongli He (yongli-he)
Yongli He (yongli-he) on 2014-02-13
Changed in tuskar:
assignee: nobody → Yongli He (yongli-he)
Yongli He (yongli-he) on 2014-02-13
Changed in horizon:
assignee: nobody → Yongli He (yongli-he)

Fix proposed to branch: master
Review: https://review.openstack.org/73153

Yongli He (yongli-he) on 2014-02-13
Changed in savanna:
assignee: nobody → Yongli He (yongli-he)
Yongli He (yongli-he) on 2014-02-13
Changed in storyboard:
assignee: nobody → Yongli He (yongli-he)
Yongli He (yongli-he) on 2014-02-13
Changed in ironic:
assignee: nobody → Yongli He (yongli-he)
Xurong Yang (idopra) on 2014-02-13
Changed in swift:
assignee: nobody → Xurong Yang (idopra)
Changed in python-ironicclient:
assignee: nobody → Xurong Yang (idopra)
Changed in swift:
status: New → In Progress
Yongli He (yongli-he) on 2014-02-13
Changed in python-ironicclient:
assignee: Xurong Yang (idopra) → Yongli He (yongli-he)
Xurong Yang (idopra) on 2014-02-13
Changed in python-ironicclient:
status: New → In Progress
Xurong Yang (idopra) on 2014-02-13
Changed in python-troveclient:
assignee: nobody → Xurong Yang (idopra)
status: New → In Progress
Changed in python-ironicclient:
assignee: Yongli He (yongli-he) → Xurong Yang (idopra)
Yongli He (yongli-he) on 2014-02-13
Changed in tuskar:
status: New → In Progress
Yongli He (yongli-he) on 2014-02-13
Changed in python-troveclient:
assignee: Xurong Yang (idopra) → Yongli He (yongli-he)
Xurong Yang (idopra) on 2014-02-13
Changed in python-swiftclient:
assignee: nobody → Xurong Yang (idopra)
status: New → In Progress

Reviewed: https://review.openstack.org/73154
Committed: https://git.openstack.org/cgit/openstack/savanna/commit/?id=4926ded13f82357d1fee8fce46801be4f9a9d2ae
Submitter: Jenkins
Branch: master

commit 4926ded13f82357d1fee8fce46801be4f9a9d2ae
Author: He Yongli <email address hidden>
Date: Thu Feb 13 13:54:57 2014 +0800

    Remove extraneous vim configuration comments

    Remove vim setting

    Remove line containing
    comment - # vim: tabstop=4 shiftwidth=4 softtabstop=4

    at the top of source code files, except for files in
    openstack/common.

    Change-Id: I9fbab33dd368fa65988f590544a626a2ac1b2304
    Close-bug: #1229324

Reviewed: https://review.openstack.org/73156
Committed: https://git.openstack.org/cgit/openstack-infra/storyboard/commit/?id=aec7ddfea31e81dc64638c6a297df33a1dc2e08b
Submitter: Jenkins
Branch: master

commit aec7ddfea31e81dc64638c6a297df33a1dc2e08b
Author: He Yongli <email address hidden>
Date: Thu Feb 13 13:58:42 2014 +0800

    Remove extraneous vim configuration comments

    Remove vim setting:

    Remove line containing
    comment - # vim: tabstop=4 shiftwidth=4 softtabstop=4

    at the top of source code files.

    Change-Id: Ibb15b799433000bb20d744dba7fa0c0ab664bbbb
    Close-bug: #1229324

Xurong Yang (idopra) on 2014-02-13
Changed in taskflow:
assignee: nobody → Xurong Yang (idopra)
status: New → In Progress

Reviewed: https://review.openstack.org/73148
Committed: https://git.openstack.org/cgit/openstack/tuskar/commit/?id=ec057bb073e51b21efef2246ee3428bc80e08a18
Submitter: Jenkins
Branch: master

commit ec057bb073e51b21efef2246ee3428bc80e08a18
Author: He Yongli <email address hidden>
Date: Thu Feb 13 13:07:24 2014 +0800

    Remove extraneous vim configuration comments

    Remove vim setting

    Remove line containing
    comment - # vim: tabstop=4 shiftwidth=4 softtabstop=4

    at the top of source code files, except for files in
    openstack/common.

    Change-Id: I7d43f92e0110b597452183ae22acaf1114efd3f9
    Close-bug: #1229324

Dolph Mathews (dolph) wrote :

Added hacking, as I'm already seeing regressions for this that should be automatically gated.

Dolph Mathews (dolph) on 2014-02-13
Changed in python-keystoneclient:
milestone: none → 0.6.0

Reviewed: https://review.openstack.org/73166
Committed: https://git.openstack.org/cgit/openstack/python-ironicclient/commit/?id=3622dfa2fb4c66fd8cbb76bc8a730195f4c32305
Submitter: Jenkins
Branch: master

commit 3622dfa2fb4c66fd8cbb76bc8a730195f4c32305
Author: He Yongli <email address hidden>
Date: Thu Feb 13 14:42:16 2014 +0800

    Remove vim header

    No need to set tabstop tons of times, this can be set in your vimrc
    file instead.

    More disucssion:
    http://openstack.10931.n7.nabble.com/Remove-vim-modelines-td21780.html

    Change-Id: Iff0d2e4725355800f923a04a1bfcac3003a6abd2
    Close-bug: #1229324

Xurong Yang (idopra) on 2014-02-14
Changed in hacking:
assignee: nobody → Xurong Yang (idopra)
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/73542

Changed in tuskar:
importance: Undecided → Low
Changed in python-heatclient:
importance: Undecided → Medium
milestone: none → v0.2.7

Fix proposed to branch: master
Review: https://review.openstack.org/74596

Reviewed: https://review.openstack.org/74287
Committed: https://git.openstack.org/cgit/openstack/tempest/commit/?id=7709df8dbf753bdea0a166a4f04d248b9fdab081
Submitter: Jenkins
Branch: master

commit 7709df8dbf753bdea0a166a4f04d248b9fdab081
Author: Masayuki Igawa <email address hidden>
Date: Tue Feb 18 17:16:27 2014 +0900

    Removes vim headers 5th round

    This is a follow up on:
       Change-Id: If56b28d0efb6364fe2105f7d62d6a2b05b906070

    The vim headers in all the files are being removed. We've missed these
    files because of delays in the patches.
    I hope this is the last one for Tempest.

    Change-Id: I55dcbc7de4106bc5de852c77d85cf97ac5dab18a
    Closes-Bug: #1229324

Reviewed: https://review.openstack.org/74596
Committed: https://git.openstack.org/cgit/openstack/tempest/commit/?id=fcacf96204590e57266e81ed13c8a60a60f1b73e
Submitter: Jenkins
Branch: master

commit fcacf96204590e57266e81ed13c8a60a60f1b73e
Author: Masayuki Igawa <email address hidden>
Date: Wed Feb 19 14:00:01 2014 +0900

    Introduce T106 rule for vi modelines

    We don't need to have the vi modelines in each source file anymore.
    We've already fixed them several times.
     https://review.openstack.org/#/c/66507/
     https://review.openstack.org/#/c/68552/
     https://review.openstack.org/#/c/69318/
     https://review.openstack.org/#/c/70133/
    However, newly some files still have it in its header. So we should
    check it automatically with our HACKING rule.
    This commit introduces T106 rule for that.

    Note: This code is copied from Nova's hacking rule.
       Change-Id: I347307a5145b2760c69085b6ca850d6a9137ffc6

    Change-Id: I5c94ef041a39c2377ba6321ace8934f324287bcf
    Closes-Bug: #1229324

Yongli He (yongli-he) on 2014-02-24
Changed in ironic:
status: New → In Progress
Changed in horizon:
status: New → In Progress
Mike May (themistymay) on 2014-02-24
Changed in savanna:
assignee: Yongli He (yongli-he) → Mike May (themistymay)

Reviewed: https://review.openstack.org/75809
Committed: https://git.openstack.org/cgit/openstack/oslo.vmware/commit/?id=1ad429d885ba80f0da295137089a57879eb342ff
Submitter: Jenkins
Branch: master

commit 1ad429d885ba80f0da295137089a57879eb342ff
Author: ChangBo Guo(gcb) <email address hidden>
Date: Mon Feb 24 04:17:29 2014 -0500

    Remove vim header

    We don't need vim modelines in each source file, it can be set in
    user's vimrc.

    Change-Id: Ib52a71276d514ca01dd1e21d754c6c150c94a2a5
    Closes-Bug: #1229324

Matthias Runge (mrunge) on 2014-02-25
Changed in horizon:
importance: Undecided → Wishlist
milestone: none → icehouse-3

Reviewed: https://review.openstack.org/73160
Committed: https://git.openstack.org/cgit/openstack/ironic/commit/?id=110074a5946cfde4b5419a62c74fe27aabe75117
Submitter: Jenkins
Branch: master

commit 110074a5946cfde4b5419a62c74fe27aabe75117
Author: He Yongli <email address hidden>
Date: Thu Feb 13 14:13:18 2014 +0800

    Remove extraneous vim configuration comments for ironic

    Remove vim setting:

    comment - # vim: tabstop=4 shiftwidth=4 softtabstop=4

    at the top of source code files, except for files in
    openstack/common.

    Change-Id: Ie80f76f08e27b7f5f747227c4cca8d79ad98bec6
    Partial-Bug: #1229324

Changed in trove:
milestone: none → icehouse-3
status: New → Fix Committed
Changed in savanna:
importance: Undecided → Low
milestone: none → icehouse-3
status: New → Fix Committed
Thierry Carrez (ttx) on 2014-03-05
Changed in savanna:
milestone: icehouse-3 → none
Changed in trove:
milestone: icehouse-3 → none
Thierry Carrez (ttx) on 2014-03-05
Changed in horizon:
milestone: icehouse-3 → none

Reviewed: https://review.openstack.org/77906
Committed: https://git.openstack.org/cgit/openstack/keystone/commit/?id=11da8deb8f40b54781eead78d31dcbbad4f2707e
Submitter: Jenkins
Branch: master

commit 11da8deb8f40b54781eead78d31dcbbad4f2707e
Author: Marc Koderer <email address hidden>
Date: Tue Mar 4 16:09:23 2014 +0100

    Remove vim headers

    Second round to remove all vim headers. We don't need to have the
    vim headers in each source files.

    More discussions:
    http://lists.openstack.org/pipermail/openstack-dev/2013-October/017353.html

    Change-Id: I43703e2289212389c7841f44691ae7849ed1f505
    Closes-Bug: #1229324

Reviewed: https://review.openstack.org/72498
Committed: https://git.openstack.org/cgit/openstack/python-cinderclient/commit/?id=803f0f69a616700329b702b01404d41827c60ce8
Submitter: Jenkins
Branch: master

commit 803f0f69a616700329b702b01404d41827c60ce8
Author: Jay S. Bryant <email address hidden>
Date: Wed Feb 12 10:18:09 2014 -0600

    Remove vim header

    Making this change for python-cinderclient to be consistent
    with Cinder. The same change was made to Cinder via
    commit ff3f2e5735f0d486b72b6881b05ace94d6d34d03 .

    Partial-bug 1229324
    Change-Id: I69fb960f499f0c9a9c9671d46d10170477cf6695

Reviewed: https://review.openstack.org/84186
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=5a701d730ae2db05c549721fccf3409d4390ab61
Submitter: Jenkins
Branch: master

commit 5a701d730ae2db05c549721fccf3409d4390ab61
Author: Mohammad Banikazemi <email address hidden>
Date: Mon Mar 31 13:01:47 2014 -0400

    Removing vim header lines

    Simply removes the vim header line and the empty line
    following it (when present) for files in the api, db, and
    extenssions base directories. In one single _init_ file in
    this patchset, all comment lines are removed.

    Change-Id: I81b7168dc2ad74b8c30a87e50a531e157851499e
    Partial-Bug: 1229324

Thierry Carrez (ttx) wrote :

This bug has now too many tasks, so we can't update those anymore (boo LP). The only way to make them disappear is to delete the tasks entirely.

Keystone, Trove and Sahara were fixed and released, i'm removing them so that they don't appear FixCommitted anymore.

no longer affects: sahara
no longer affects: keystone
no longer affects: trove
no longer affects: python-heatclient
Joe Gordon (jogo) wrote :

I am not too keep on putting this enforcement in hacking, because once all the copies of are gone from a project, I don't think new ones will re-appear (ignoring any works in progress that copied from a file with the header). that being said, if someone wants to add it, I am fine with that.

This can also be gated on using local hacking rules.

Changed in hacking:
importance: Undecided → Wishlist
Thierry Carrez (ttx) on 2014-04-14
no longer affects: ironic
Thierry Carrez (ttx) on 2014-04-17
Changed in oslo:
milestone: icehouse-2 → 2014.1
Thierry Carrez (ttx) on 2014-04-17
Changed in ceilometer:
milestone: icehouse-1 → 2014.1
Thierry Carrez (ttx) on 2014-04-17
Changed in cinder:
milestone: icehouse-2 → 2014.1
Thierry Carrez (ttx) on 2014-04-17
Changed in glance:
milestone: icehouse-2 → 2014.1
gordon chung (chungg) on 2014-04-28
Changed in python-ceilometerclient:
assignee: Sphoorti (sphoorti-joglekar) → gordon chung (chungg)
importance: Undecided → Low
status: In Progress → Triaged

Reviewed: https://review.openstack.org/90811
Committed: https://git.openstack.org/cgit/openstack/python-ceilometerclient/commit/?id=334739663cb2f724b19585dd0010df5ef2620f0b
Submitter: Jenkins
Branch: master

commit 334739663cb2f724b19585dd0010df5ef2620f0b
Author: Gordon Chung <email address hidden>
Date: Mon Apr 28 16:21:40 2014 -0400

    extraneous vim editor configuration comments

    Many of the source code files have a beginning line:
    vim: tabstop=4 shiftwidth=4 softtabstop=4

    This should be deleted.

    Change-Id: I0b7bd4e727c0597e7c7fb61d42684e908e001134
    Closes-Bug: #1229324

Changed in python-ceilometerclient:
status: Triaged → Fix Committed

Reviewed: https://review.openstack.org/73152
Committed: https://git.openstack.org/cgit/openstack/horizon/commit/?id=e790ac070e9b8b735c54c613d26e1ee92b7af0b0
Submitter: Jenkins
Branch: master

commit e790ac070e9b8b735c54c613d26e1ee92b7af0b0
Author: He Yongli <email address hidden>
Date: Thu Feb 13 13:43:57 2014 +0800

    Remove extraneous vim configuration comments

    Remove vim setting:
    comment - # vim: tabstop=4 shiftwidth=4 softtabstop=4

    at the top of source code files, except for files in
    openstack/common.

    Change-Id: I9a5c6b17c6ef7ecec601f4503dfc7b31fc72e90a
    Close-bug: #1229324

Changed in python-troveclient:
importance: Undecided → Wishlist
Joshua Harlow (harlowja) on 2014-05-24
Changed in taskflow:
status: In Progress → Fix Committed
Kyle Mestery (mestery) on 2014-06-18
Changed in neutron:
importance: Undecided → Wishlist
milestone: none → juno-2
Liusheng (liusheng) on 2014-06-23
Changed in neutron:
status: In Progress → Fix Committed
Changed in nova:
status: In Progress → Fix Committed
Changed in nova:
milestone: none → juno-2
Kyle Mestery (mestery) on 2014-07-23
Changed in neutron:
milestone: juno-2 → juno-3
Thierry Carrez (ttx) on 2014-07-29
Changed in neutron:
milestone: juno-3 → none
status: Fix Committed → Fix Released
milestone: none → juno-2
Changed in nova:
milestone: juno-2 → none
status: Fix Committed → Fix Released
milestone: none → juno-2
Dmitry Tantsur (divius) on 2014-09-22
no longer affects: python-ironicclient
Dougal Matthews (d0ugal) on 2014-09-25
Changed in tuskar:
status: In Progress → Fix Committed
Morgan Fainberg (mdrnstm) wrote :

I can't mark this as fixed released for keystoneclient. It was released in 0.6.0 (a long while ago) I'm going to remove keystoneclient from this bug.

no longer affects: python-keystoneclient
Marc Koderer (m-koderer) on 2014-10-06
Changed in manila:
assignee: nobody → Marc Koderer (m-koderer)
Changed in manila:
status: New → In Progress

Reviewed: https://review.openstack.org/126258
Committed: https://git.openstack.org/cgit/openstack/manila/commit/?id=ecf603bc0504f8fc090519e91dbc0d972e602b39
Submitter: Jenkins
Branch: master

commit ecf603bc0504f8fc090519e91dbc0d972e602b39
Author: Marc Koderer <email address hidden>
Date: Mon Oct 6 14:56:03 2014 +0200

    Remove vim headers

    As discussed in [1] remove all vim headers from manila files.

    [1]: http://lists.openstack.org/pipermail/openstack-dev/2013-October/017353.html

    Change-Id: I341486c66ffe4dad7db8608fdc66868ceb7ad95a
    Closes-Bug: #1229324

Changed in manila:
status: In Progress → Fix Committed

Fix proposed to branch: master
Review: https://review.openstack.org/127009

Changed in python-neutronclient:
assignee: Liusheng (liusheng) → Christian Berendt (berendt)

Reviewed: https://review.openstack.org/126996
Committed: https://git.openstack.org/cgit/openstack/manila/commit/?id=025f68504a8ac7445f5626ecad18acd0edfcf3ee
Submitter: Jenkins
Branch: master

commit 025f68504a8ac7445f5626ecad18acd0edfcf3ee
Author: Christian Berendt <email address hidden>
Date: Wed Oct 8 22:40:24 2014 +0200

    Remove extraneous vim editor configuration comments

    Change-Id: I3cecf4e2a0f00e14e144124512ce8f7b8928d7f8
    Partial-Bug: #1229324

Thierry Carrez (ttx) on 2014-10-16
Changed in nova:
milestone: juno-2 → 2014.2
Thierry Carrez (ttx) on 2014-10-16
Changed in neutron:
milestone: juno-2 → 2014.2

Fix proposed to branch: master
Review: https://review.openstack.org/128943

Changed in heat:
assignee: DennyZhang (denny-6) → Oleksii Chuprykov (ochuprykov)

Reviewed: https://review.openstack.org/128943
Committed: https://git.openstack.org/cgit/openstack/heat/commit/?id=29dfc78d046811dc21c934e3866a293eafc28665
Submitter: Jenkins
Branch: master

commit 29dfc78d046811dc21c934e3866a293eafc28665
Author: Oleksii Chuprykov <email address hidden>
Date: Thu Oct 16 17:51:57 2014 +0300

    Remove vim headers

    No need to set tabstop tons of times, this can be set in your vimrc
    file instead.

    Closes-Bug: #1229324

    Change-Id: Ib859c0af8a29437540a0586dc0af77bb544ece23

Changed in heat:
status: In Progress → Fix Committed
Jay Dobies (jdob) on 2014-10-16
Changed in tuskar:
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/127009
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=27f02acc71e48cbeb3855952ab9fef613916c757
Submitter: Jenkins
Branch: master

commit 27f02acc71e48cbeb3855952ab9fef613916c757
Author: Christian Berendt <email address hidden>
Date: Wed Oct 8 22:52:02 2014 +0200

    Remove extraneous vim editor configuration comments

    Change-Id: I792f24c28063bb57dc2fd295903a7d73c43578d9
    Partial-Bug: #1229324

Change abandoned by pritesh (<email address hidden>) on branch: master
Review: https://review.openstack.org/99508

Joe Gordon (jogo) on 2014-11-13
no longer affects: hacking
Thierry Carrez (ttx) on 2014-12-18
Changed in heat:
milestone: none → kilo-1
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-12-18
Changed in manila:
milestone: none → kilo-1
status: Fix Committed → Fix Released
Joshua Harlow (harlowja) on 2014-12-19
Changed in taskflow:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2015-04-30
Changed in heat:
milestone: kilo-1 → 2015.1.0
Thierry Carrez (ttx) on 2015-04-30
Changed in manila:
milestone: kilo-1 → 2015.1.0
Changed in python-ceilometerclient:
status: Fix Committed → Fix Released
Changed in python-glanceclient:
milestone: none → 1.0.0
status: Fix Committed → Fix Released
Changed in python-cinderclient:
status: In Progress → Fix Released
Akihiro Motoki (amotoki) on 2015-12-03
Changed in python-neutronclient:
status: In Progress → Fix Released
Changed in manila-ui:
assignee: nobody → Tatiana Ovchinnikova (tmazur)
Changed in horizon:
status: In Progress → Fix Released

Fix proposed to branch: master
Review: https://review.openstack.org/340815

Changed in manila-ui:
status: New → In Progress

Reviewed: https://review.openstack.org/340815
Committed: https://git.openstack.org/cgit/openstack/manila-ui/commit/?id=e3fec776b8900cc200e488ea11472433708668f7
Submitter: Jenkins
Branch: master

commit e3fec776b8900cc200e488ea11472433708668f7
Author: Tatiana Ovchinnikova <email address hidden>
Date: Tue Jul 12 12:21:38 2016 +0300

    Remove vim headers

    We don't need vim settings in each source file:

    comment - # vim: tabstop=4 shiftwidth=4 softtabstop=4

    It can be set in user's vimrc.

    Change-Id: I205123ae076cf5801f24992cb4897ba2a37bd4b5
    Partial-Bug: #1229324

Changed in manila-ui:
status: In Progress → Fix Committed
Zhao Chao (zhaochao1984) wrote :
Changed in python-troveclient:
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
Changed in manila-ui:
importance: Undecided → Low
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers