After Image is deleted, the resource status of that image is still in queued in Ceilometer

Bug #1201701 reported by xingzhou on 2013-07-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ceilometer
Fix Released
Medium
Unassigned
Glance
Undecided
Unassigned

Bug Description

When the image is deleted from Glance side, the resource data recorded in ceilometer showed that the image is still under queued status, and the update time/delete_at attribute are not updated.

As Ceilometer directly record the event data as metadata, so need to identify whether this issue shall be fixed in Ceilometer side or Glance side

Steps to reproduce:
1. create one image in glance
2. wait until the image resource has been captured and recorded in ceilometer
3. delte the image in glance
4. back to ceilometer, see that the image is still in queued status
5. back to glance, use glance image-list, the image is no longer in the list

Julien Danjou (jdanjou) on 2013-07-17
Changed in ceilometer:
status: New → Triaged
importance: Undecided → Medium
Changed in ceilometer:
assignee: nobody → Thomas Maddox (thomas-maddox)
tags: added: grizzly-backport-potential
Changed in ceilometer:
status: Triaged → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/45008

Reviewed: https://review.openstack.org/44277
Committed: http://github.com/openstack/ceilometer/commit/64f17d6552cde85e87ba394815fd27ceeebdb103
Submitter: Jenkins
Branch: master

commit 64f17d6552cde85e87ba394815fd27ceeebdb103
Author: Thomas Maddox <email address hidden>
Date: Tue Aug 20 18:10:17 2013 +0000

    Fix to return latest resource metadata

    Addresses the latest resource metadata not being returned in
    the MongoDB, SQLAlchemy, DB2, and HBase drivers. A schema
    change was required for HBase, because it was overwriting
    historical metadata.

    Closes-Bug: #1208547
    Related-Bug: #1201701
    Implements: blueprint hbase-meter-table-enhancement
    Change-Id: Ib09e21cbc7bbd45a6ecc321403e9947df837e14b

Iccha Sethi (iccha-sethi) wrote :
Changed in glance:
status: New → Triaged
Alan Pevec (apevec) on 2014-03-30
tags: removed: grizzly-backport-potential
Anurag (anurag-kumar) on 2014-10-06
Changed in glance:
status: Triaged → Opinion
Anurag (anurag-kumar) on 2014-10-06
Changed in glance:
status: Opinion → Incomplete
Thomas Maddox (thomas-maddox) wrote :

Did not mean to leave my name attached to this as I haven't been working on Ceilometer for several months.

Changed in ceilometer:
assignee: Thomas Maddox (thomas-maddox) → nobody
Ian Cordasco (icordasc) on 2014-12-26
Changed in ceilometer:
status: In Progress → Fix Released
Changed in glance:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers