OpenStack Telemetry (Ceilometer)

ceilometer should require pymongo>=2.0

Reported by Armando Migliaccio on 2012-11-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ceilometer
Medium
Unassigned

Bug Description

I am running this on trunk and with devstack, after enabling the services as documented on:

http://ceilometer.readthedocs.org/en/latest/install.html#configuring-devstack

I get the stacktrace below when starting the collector:

cd /opt/stack/ceilometer && /usr/local/bin/ceilometer-collector --config-file /etc/ceilometer/ceilometer.conf

2012-11-09 17:50:01 29184 CRITICAL ceilometer [-] __init__() got an unexpected keyword argument 'safe'
2012-11-09 17:50:01 29184 TRACE ceilometer Traceback (most recent call last):
2012-11-09 17:50:01 29184 TRACE ceilometer File "/usr/local/bin/ceilometer-collector", line 7, in <module>
2012-11-09 17:50:01 29184 TRACE ceilometer execfile(__file__)
2012-11-09 17:50:01 29184 TRACE ceilometer File "/opt/stack/ceilometer/bin/ceilometer-collector", line 37, in <module>
2012-11-09 17:50:01 29184 TRACE ceilometer launcher.wait()
2012-11-09 17:50:01 29184 TRACE ceilometer File "/opt/stack/ceilometer/ceilometer/openstack/common/service.py", line 126, in wait
2012-11-09 17:50:01 29184 TRACE ceilometer super(ServiceLauncher, self).wait()
2012-11-09 17:50:01 29184 TRACE ceilometer File "/opt/stack/ceilometer/ceilometer/openstack/common/service.py", line 98, in wait
2012-11-09 17:50:01 29184 TRACE ceilometer service.wait()
2012-11-09 17:50:01 29184 TRACE ceilometer File "/usr/local/lib/python2.7/dist-packages/eventlet/greenthread.py", line 166, in wait
2012-11-09 17:50:01 29184 TRACE ceilometer return self._exit_event.wait()
2012-11-09 17:50:01 29184 TRACE ceilometer File "/usr/local/lib/python2.7/dist-packages/eventlet/event.py", line 116, in wait
2012-11-09 17:50:01 29184 TRACE ceilometer return hubs.get_hub().switch()
2012-11-09 17:50:01 29184 TRACE ceilometer File "/usr/local/lib/python2.7/dist-packages/eventlet/hubs/hub.py", line 177, in switch
2012-11-09 17:50:01 29184 TRACE ceilometer return self.greenlet.switch()
2012-11-09 17:50:01 29184 TRACE ceilometer File "/usr/local/lib/python2.7/dist-packages/eventlet/greenthread.py", line 192, in main
2012-11-09 17:50:01 29184 TRACE ceilometer result = function(*args, **kwargs)
2012-11-09 17:50:01 29184 TRACE ceilometer File "/opt/stack/ceilometer/ceilometer/openstack/common/service.py", line 68, in run_service
2012-11-09 17:50:01 29184 TRACE ceilometer service.start()
2012-11-09 17:50:01 29184 TRACE ceilometer File "/opt/stack/ceilometer/ceilometer/collector/service.py", line 61, in start
2012-11-09 17:50:01 29184 TRACE ceilometer self.storage_conn = self.storage_engine.get_connection(cfg.CONF)
2012-11-09 17:50:01 29184 TRACE ceilometer File "/opt/stack/ceilometer/ceilometer/storage/impl_mongodb.py", line 73, in get_connection
2012-11-09 17:50:01 29184 TRACE ceilometer return Connection(conf)
2012-11-09 17:50:01 29184 TRACE ceilometer File "/opt/stack/ceilometer/ceilometer/storage/impl_mongodb.py", line 178, in __init__
2012-11-09 17:50:01 29184 TRACE ceilometer self.conn = self._get_connection(opts)
2012-11-09 17:50:01 29184 TRACE ceilometer File "/opt/stack/ceilometer/ceilometer/storage/impl_mongodb.py", line 212, in _get_connection
2012-11-09 17:50:01 29184 TRACE ceilometer return pymongo.Connection(opts['host'], opts['port'], safe=True)
2012-11-09 17:50:01 29184 TRACE ceilometer TypeError: __init__() got an unexpected keyword argument 'safe'
2012-11-09 17:50:01 29184 TRACE ceilometer

Any clue?

Doug Hellmann (doug-hellmann) wrote :

Which version of PyMongo is installed?

Doug,

apologies...I should have provided more details.

I am running DevStack on 12.04 and the version of PyMongo is 1.11.

Thanks,
Armando

John Tran (jtran) wrote :

Armando, I believe the version of pymongo you are using is the problem. You should try pymongo>=2.0 .

Doug, should we put this in pip-requires?

Yup, that fixes it.

Nick Barcet (nijaba) on 2012-11-13
summary: - ceilometer-collector fail to start
+ ceilometer should require pymongo>=2.0
Changed in ceilometer:
status: New → Confirmed
importance: Undecided → Medium
Doug Hellmann (doug-hellmann) wrote :

It's not clear how to handle this. We don't want to always require PyMongo, because users of the SQLAlchemy storage backend don't need it. Do we just need to document better which version to install? Do we need a script to install the extra dependencies for the selected backend?

Reviewed: https://review.openstack.org/15902
Committed: http://github.com/openstack/ceilometer/commit/566f4ccd6511b82a2b31ce51ab6e83deca5f613e
Submitter: Jenkins
Branch: master

commit 566f4ccd6511b82a2b31ce51ab6e83deca5f613e
Author: Julien Danjou <email address hidden>
Date: Mon Nov 12 20:16:13 2012 +0100

    Fix pymongo requirements

    This fixes bug #1077104

    Change-Id: Ib2d936d71d6c253a141abed65794ea800d0c8354
    Signed-off-by: Julien Danjou <email address hidden>

Changed in ceilometer:
status: Confirmed → Fix Committed
Download full text (4.6 KiB)

I think we need to document this clearly so that it is sorted out
properly by packagers.

On Tue, Nov 13, 2012 at 4:55 PM, OpenStack Hudson
<email address hidden> wrote:
> Reviewed: https://review.openstack.org/15902
> Committed: http://github.com/openstack/ceilometer/commit/566f4ccd6511b82a2b31ce51ab6e83deca5f613e
> Submitter: Jenkins
> Branch: master
>
> commit 566f4ccd6511b82a2b31ce51ab6e83deca5f613e
> Author: Julien Danjou <email address hidden>
> Date: Mon Nov 12 20:16:13 2012 +0100
>
> Fix pymongo requirements
>
> This fixes bug #1077104
>
> Change-Id: Ib2d936d71d6c253a141abed65794ea800d0c8354
> Signed-off-by: Julien Danjou <email address hidden>
>
>
> ** Changed in: ceilometer
> Status: Confirmed => Fix Committed
>
> --
> You received this bug notification because you are subscribed to
> Ceilometer.
> https://bugs.launchpad.net/bugs/1077104
>
> Title:
> ceilometer should require pymongo>=2.0
>
> Status in Openstack Metrics (ceilometer):
> Fix Committed
>
> Bug description:
> I am running this on trunk and with devstack, after enabling the
> services as documented on:
>
> http://ceilometer.readthedocs.org/en/latest/install.html#configuring-
> devstack
>
> I get the stacktrace below when starting the collector:
>
> cd /opt/stack/ceilometer && /usr/local/bin/ceilometer-collector
> --config-file /etc/ceilometer/ceilometer.conf
>
>
> 2012-11-09 17:50:01 29184 CRITICAL ceilometer [-] __init__() got an unexpected keyword argument 'safe'
> 2012-11-09 17:50:01 29184 TRACE ceilometer Traceback (most recent call last):
> 2012-11-09 17:50:01 29184 TRACE ceilometer File "/usr/local/bin/ceilometer-collector", line 7, in <module>
> 2012-11-09 17:50:01 29184 TRACE ceilometer execfile(__file__)
> 2012-11-09 17:50:01 29184 TRACE ceilometer File "/opt/stack/ceilometer/bin/ceilometer-collector", line 37, in <module>
> 2012-11-09 17:50:01 29184 TRACE ceilometer launcher.wait()
> 2012-11-09 17:50:01 29184 TRACE ceilometer File "/opt/stack/ceilometer/ceilometer/openstack/common/service.py", line 126, in wait
> 2012-11-09 17:50:01 29184 TRACE ceilometer super(ServiceLauncher, self).wait()
> 2012-11-09 17:50:01 29184 TRACE ceilometer File "/opt/stack/ceilometer/ceilometer/openstack/common/service.py", line 98, in wait
> 2012-11-09 17:50:01 29184 TRACE ceilometer service.wait()
> 2012-11-09 17:50:01 29184 TRACE ceilometer File "/usr/local/lib/python2.7/dist-packages/eventlet/greenthread.py", line 166, in wait
> 2012-11-09 17:50:01 29184 TRACE ceilometer return self._exit_event.wait()
> 2012-11-09 17:50:01 29184 TRACE ceilometer File "/usr/local/lib/python2.7/dist-packages/eventlet/event.py", line 116, in wait
> 2012-11-09 17:50:01 29184 TRACE ceilometer return hubs.get_hub().switch()
> 2012-11-09 17:50:01 29184 TRACE ceilometer File "/usr/local/lib/python2.7/dist-packages/eventlet/hubs/hub.py", line 177, in switch
> 2012-11-09 17:50:01 29184 TRACE ceilometer return self.greenlet.switch()
> 2012-11-09 17:50:01 29184 TRACE ceilometer File "/usr/local/lib/python2.7/dist-packages/eventlet/greenthread.py", line 192, in main
> 2012-11-09 17...

Read more...

Thierry Carrez (ttx) on 2013-01-09
Changed in ceilometer:
milestone: none → grizzly-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-04-04
Changed in ceilometer:
milestone: grizzly-2 → 2013.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers