Adapt ceilometer for multiple publication conduits

Bug #1073988 reported by Eoghan Glynn
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ceilometer
High
jiang, yunhong

Bug Description

Provide a config-driven mechanism to allow ceilometer publish to alternative conduits other than the message bus (e.g. via CloudWatch PutMetricData call, statsd UDP packets, RRD files etc.)

As discussed here:

  http://lists.openstack.org/pipermail/openstack-dev/2012-October/001840.html

Revision history for this message
Julien Danjou (jdanjou) wrote :
Revision history for this message
Eoghan Glynn (eglynn) wrote :

Thanks Julien, I just wanted to capture the ML discussion referenced above, but looks like you beat me to it with the blueprint.

Changed in ceilometer:
assignee: nobody → jiang, yunhong (yunhong-jiang)
Nick Barcet (nijaba)
Changed in ceilometer:
status: New → Confirmed
importance: Undecided → High
Julien Danjou (jdanjou)
Changed in ceilometer:
status: Confirmed → In Progress
Julien Danjou (jdanjou)
Changed in ceilometer:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints