OpenStack Telemetry (Ceilometer)

allow different polling interval for each pollster

Reported by Doug Hellmann on 2012-06-07
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ceilometer
Wishlist
jiang, yunhong

Bug Description

See the email thread at https://lists.launchpad.net/openstack/msg12916.html for details.

Julien Danjou (jdanjou) on 2012-06-12
Changed in ceilometer:
assignee: nobody → Julien Danjou (jdanjou)
Nick Barcet (nijaba) on 2012-07-06
Changed in ceilometer:
importance: Undecided → Wishlist
status: New → Confirmed
tags: added: agent effort-m pollster
Julien Danjou (jdanjou) on 2012-10-08
Changed in ceilometer:
assignee: Julien Danjou (jdanjou) → nobody
John Tran (jtran) wrote :

If we were to implement this, it seems like we would no longer be able to use nova's Service and possibly Manager. Has anyone given thoughts on an approach?

Doug Hellmann (doug-hellmann) wrote :

It seems like we will need to schedule a separate task for each pollster, instead of running them all from one task. I haven't looked at the updated API closely, but the new service/manager/periodic task code in common may make this easier to implement.

ronghui duan (ronghui-duan) wrote :

What is the status about this wish list? I have an idea about it.
1: let each pollster have its own interval like computer pollster with 10 ticks for example.
2: When Periodic Service is scheduled we check each pollster’s timer. If left ticks is 0, we will invoke that pollster then reset it.
3:The Periodic Service’s frequency should be adjust to little grain size
4:We can also set the interval at run time for each pollster.
How about this? I can supply a patch for review.

Doug Hellmann (doug-hellmann) wrote :

This work is idea was subsumed into the multi-publisher blueprint (https://blueprints.launchpad.net/ceilometer/+spec/multi-publisher).

ronghui duan (ronghui-duan) wrote :

Thanks for the info. Please help to review: https://review.openstack.org/#/c/20010/
I wish this can be acceptable as a part of the bp. The pipeline manager can set each pollster's interval by calling set_ticks.
I read the in progress patch. As my understanding:
1:Pipeline manager will transfer pollster data to different type of output for publish.
2:Only one timer for each type of pollster
3:The timer should be determined by the pipeline manager with the input of all publishers.
Am I right?

Changed in ceilometer:
assignee: nobody → ronghui duan (ronghui-duan)

Fix proposed to branch: master
Review: https://review.openstack.org/20012

Changed in ceilometer:
status: Confirmed → In Progress
jiang, yunhong (yunhong-jiang) wrote :

I talked with Ronghui and I will work on this patch since I'm working on the related BPs.

Changed in ceilometer:
assignee: ronghui duan (ronghui-duan) → jiang, yunhong (yunhong-jiang)
Julien Danjou (jdanjou) on 2013-06-20
Changed in ceilometer:
status: In Progress → Fix Released

I am out of the office until 07/01/2013.

I will be on vacation until Monday, July 1st and will not be able to
respond to emails for the majority of my time away. Please contact Johanna
Koester, my manager, in case of emergencies.

Note: This is an automated response to your message "[Bug 1010037] Re:
allow different polling interval for each pollster" sent on 06/20/2013
7:00:50 AM.

This is the only notification you will receive while this person is away.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers