Packaged version unable to start plainbox service

Bug #1225121 reported by Chris Gregan on 2013-09-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical Driver Test Suite
Critical
Daniel Manrique

Bug Description

  Installed: 0.1+bzr2299+bzr40~ubuntu13.04.1

Plainbox service cannot be reached when using the packaged version.

Daniel Manrique (roadmr) wrote :

Oops! I'm unable to reproduce this problem :( Could you provide some more details? I think the most important thing is which version of python3-plainbox you have installed, as driver-testing depends on that so we know it *is* installed.

I installed all the required packages by following this procedure:

#Start with a clean install of Ubuntu 13.04
#Add four PPAs:
sudo apt-add-repository ppa:ubuntu-sdk-team/ppa
sudo apt-add-repository ppa:canonical-qt5-edgers/qt5-proper
sudo apt-add-repository ppa:checkbox-ihv-ng/ppa
sudo apt-add-repository ppa:checkbox-dev/ppa
#Update/upgrade
sudo apt-get update
sudo apt-get upgrade
#Install driver-testing and a small demo-specific package:
sudo apt-get install driver-testing plainbox-ihv-demo-config
#Run driver-testing
driver-testing

driver-testing ran correctly, reached the plainbox service and showed the ihv whitelists.

Here are the package versions I had:

$ dpkg --list *plainbox* *driver-testing*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-=========================-=================-=================-========================================================
ii driver-testing 0.1+bzr2299+bzr40 amd64 Tool for testing driver compatibility with Ubuntu.
ii plainbox 0.3+bzr2365+bzr16 all Simple replacement for CheckBox
ii plainbox-ihv-demo-config 0.3+bzr2365+bzr16 all A configuration file that selects the 'ihv' provider by
un plainbox-policy <none> (no description available)
ii plainbox-secure-policy 0.3+bzr2365+bzr16 all PolicyKit action file needed by PlainBox for prompting t
ii plainbox-service 0.3+bzr2365+bzr16 all File(s) needed for auto-starting PlainBox D-Bus service
ii python3-plainbox 0.3+bzr2365+bzr16 all Simple replacement for CheckBox

Zygmunt Krynicki (zyga) wrote :

Please try to include any error messages that you can find the next time. I believe we should have a file that contains information about potential problems when the service fails to start. In general ~/.cache/plainbox/logs is a good source of information to attach if there are no other clues as to what is going on.

Are you sure it can't start the service? What are you seeing exactly - is the suite selection screen empty? I'm asking because I'm observing a similar issue, but the service does start just fine - so I'm wondering if you're maybe overdiagnosing here.

Changed in checkbox-ihv-ng:
assignee: Daniel Manrique (roadmr) → Chris Gregan (cgregan)
status: Confirmed → Incomplete
Chris Gregan (cgregan) wrote :

Plainbox package that is called by driver-testing fails to start due to a bug that was fixed in a later version. We must peg the package version called by driver-testing to a later version which fixes this error.

Changed in checkbox-ihv-ng:
status: Incomplete → Confirmed
Daniel Manrique (roadmr) wrote :

Awesome, thanks for triaging that! Do you know the bug that was causing this? then we can look at version numbers and maybe require a newer one in the driver-testing packaging.

Chris Gregan (cgregan) wrote :

The bug causing the failure was the one we fixed that had to do with the error: whitelist contains an illegal character "-".
I could not find the actual bug that tracked that issue.

Daniel Manrique (roadmr) wrote :

Thanks, that was good enough, it's checkbox/plainbox rev 2359. So packaging for driver-testing could require plainbox >=0.3+bzr2359.

Changed in checkbox-ihv-ng:
status: Confirmed → Triaged
Daniel Manrique (roadmr) on 2013-09-18
Changed in checkbox-ihv-ng:
status: Triaged → In Progress
assignee: Chris Gregan (cgregan) → Daniel Manrique (roadmr)
Changed in checkbox-ihv-ng:
status: In Progress → Fix Released
Daniel Manrique (roadmr) wrote :

Ugh, I'm sorry to say that my fix is bogus :( because it only changes the build-depends, not the actual install-time binary package dependency. I'll fix the fix in a short while

Changed in checkbox-ihv-ng:
status: Fix Released → In Progress
Changed in checkbox-ihv-ng:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers