Barbican plugin needs config it could get from catalog

Bug #1497993 reported by Duncan Thomas on 2015-09-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
castellan
High
Unassigned

Bug Description

The cinder barbican plugin requires both the barbican and the keystone endpoints to be hard coded in cinder.conf, when both are usually present in the service catalog

summary: - Baribican plugin needs config it could get from catalog
+ Barbican plugin needs config it could get from catalog
Changed in cinder:
assignee: nobody → francis moorehead (francis-moorehead)
Changed in cinder:
assignee: francis moorehead (francis-moorehead) → nobody
Jeremy Liu (liujiong) wrote :

This should be fix released for now!

Nate Potter (ntpttr) on 2016-07-21
Changed in cinder:
assignee: nobody → Nate Potter (ntpttr)

Fix proposed to branch: master
Review: https://review.openstack.org/346981

Changed in cinder:
status: New → In Progress

Change abandoned by Nate Potter (<email address hidden>) on branch: master
Review: https://review.openstack.org/346981
Reason: These files were removed from cinder and moved to castellan - these fixes will need to be made there.

Nate Potter (ntpttr) on 2016-08-31
affects: cinder → castellan
Changed in castellan:
assignee: Nate Potter (ntpttr) → nobody
status: In Progress → Confirmed
Kaitlin Farr (kaitlin-farr) wrote :

The barbican endpoint is found from the service catalog if there is no value in the config file:

https://github.com/openstack/castellan/blob/master/castellan/key_manager/barbican_key_manager.py#L179-L186

Changed in castellan:
status: Confirmed → Invalid
Kaitlin Farr (kaitlin-farr) wrote :

Ok, but I can see how it would be useful to reuse the auth_url from the [keystone_authtoken] section since it's already there.

Changed in castellan:
status: Invalid → Confirmed
Changed in castellan:
importance: Undecided → High

Reviewed: https://review.openstack.org/483457
Committed: https://git.openstack.org/cgit/openstack/castellan/commit/?id=17e8b29067e93dbe5f13d0d18e62b06fcd148d3f
Submitter: Jenkins
Branch: master

commit 17e8b29067e93dbe5f13d0d18e62b06fcd148d3f
Author: Paul Bourke <email address hidden>
Date: Thu Jul 13 16:49:16 2017 +0100

    Fix retrieving barbican endpoint from service catalog

    The context wrapper classes under castellan.common.credentials were
    missing an auth_url property resulting in calls to get_endpoint()
    failing with 'Could not determine a suitable URL for the plugin' unless
    users set barbican/auth_endpoint.

    Change-Id: I1be3a1e11e3f4c2170062927ad359bf679eb25d9
    Closes-Bug: #1497993

Changed in castellan:
status: Confirmed → Fix Released

This issue was fixed in the openstack/castellan 0.13.0 release.

Reviewed: https://review.openstack.org/526052
Committed: https://git.openstack.org/cgit/openstack/castellan/commit/?id=ee575f290ca2f82bf34d184d6f1f91901dff4684
Submitter: Zuul
Branch: stable/pike

commit ee575f290ca2f82bf34d184d6f1f91901dff4684
Author: Paul Bourke <email address hidden>
Date: Thu Jul 13 16:49:16 2017 +0100

    Fix retrieving barbican endpoint from service catalog

    The context wrapper classes under castellan.common.credentials were
    missing an auth_url property resulting in calls to get_endpoint()
    failing with 'Could not determine a suitable URL for the plugin' unless
    users set barbican/auth_endpoint.

    Change-Id: I1be3a1e11e3f4c2170062927ad359bf679eb25d9
    Closes-Bug: #1497993
    (cherry picked from commit 17e8b29067e93dbe5f13d0d18e62b06fcd148d3f)

tags: added: in-stable-pike

This issue was fixed in the openstack/castellan 0.12.2 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers