Set a category to be shown as default on startup

Bug #604664 reported by bunghole on 2010-07-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cardapio
Low
Unassigned

Bug Description

---NOT A BUG, BUT A FEATURE REQUEST---

Right now, Cardapio shows 'All' the menu elements on the right segment of the window by default on startup, in an top to down order. Thus, having 'Places' on top, but only as long as I don't add something to 'Pinned applications'. Thats ok, I guess, but I'd love to have 'Pinned applications' AND nevertheless have my 'Places' shown on startup as default.

So my request is: Could you implement a feature which allows me to set by myself what category (e.g. 'Places', 'Pinned Applications', [...]) is shown on startup?

Besides solving the issue mentioned above, it would look a lot more cleaner if, for example, just the 'Places' related stuff was shown without parts of the 'Office' section following right behind it.

Hope I made myself clear. ;)

bunghole (mienjung) on 2010-07-12
description: updated

Maybe we should add »Pinned applications«, »System« and »Uncategorized« to the plugins menu so that they can be reordered.

A disadvantage is that it will get pretty crowded then.

bunghole (mienjung) wrote :

Well, I'm not too keen on programing, but wouldn't it be easier to add some checkbox-options to the settings? Something like "Show 'Places' on startup" or "Show 'Pinned Applications' on startup" instead of, like its status quo, showing the category 'All' by default.

This is a very specific feature and certainly sounds as if it would lead to confusion because of inconsistent display.

I went ahead and implemented a kind-of-fix for this, so that you can reorder the pinned applications to be below the places menu.

bunghole (mienjung) wrote :

Yeh, that will do the trick as well, I guess.

One question though: What exactly will the "Uncategorized" section be used for?

And by the way [OT]: You guys are doing a kickass job! What I love most (besides the great menu as such) is how you take suggestions from your userbase into consideration. Keep up the good work! :)

Changed in cardapio:
assignee: nobody → Jan-Christoph Borchardt (inquata)
status: New → In Progress
importance: Undecided → Low

»Uncategorized« are applications and system menu entries that are in the main folder (i. e. not in any subfolder) of the respective menu. On Ubuntu for example this is only Software Center. Renaming it would certainly be appropriate, for that please see https://blueprints.launchpad.net/cardapio/+spec/rethink-uncategorized

And don’t hesitate to edit the whiteboard there if you have any ideas. :)

Thiago Teixeira (tvst) wrote :

I agree with Jan-Christoph's comment (#3). Plus, this seemingly small feature would require a lot of changes to the code. So I don't think it's going to happen.

I will consider merging the "reorderable" branch, though :)

Thiago Teixeira (tvst) wrote :

Ok, the reorderable branch has been partially merged.

Note that I left out the part where you can reorder 'system' and 'uncategorized', because it added a bit too much information to the plugin window. I may reconsider this part of the code, provided someone comes up with a better way to list the plugins...

I’d then suggest to simplify the plugin window a bit:
* Reduce »Usage« to »Drag plugins to reorder them« (you may also leave the »Use the checkboxes to activate or deactivate plugins«, but I’d say the checkboxes are rather obvious to anyone who got this far. ;)
* Automatically apply any changes. It is only a list of plugins after all.
* It really does not matter (especially at this stage) if the plugin is community-supported or core, it’s only confusing. The first column and the tooltip can be removed.
* With the tooltip removed, it can be used to display the long description of the plugin. It obscures it a bit but the description is really only needed once, if at all.
* »by [plugin_author]« is cool, but can either be fit into the end of the tooltip like »Made by [plugin_author]« or just moved to the credits of About Cardapio.

Some of these may be radical or obscuring but they all really help to keep the overview clear and get details on demand. :)

Bert de Bruijn (lpdebruijn) wrote :

I agree with the suggestions in #8. Especially the second would be useful. :) Maybe also removing the checkboxes for the fields that can not be deactivated.

To propose a different setup of the plugin window: only list the names of the plugins (together with the checkboxes of course) and make a seperate field that displays all the other relevant information of the selected plugin, such as the description, the author, whether it is community-supported or core, et cetera. This field could also display a general helptext if no plugin is selected, or not be there.

On a slightly related note, I would like to add that I've tried to translate the "Usage: ..." part several times, but the English line is still used in the Dutch translation. Really weird, because all the other translatable sentences do work. Don't know if this also happens in other languages.

Changed in cardapio:
status: In Progress → Fix Committed
Thiago Teixeira (tvst) on 2010-07-19
Changed in cardapio:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions