applet button does not honor panel config

Bug #593632 reported by Massimo Branchini on 2010-06-14
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Cardapio
Medium
Unassigned

Bug Description

cardapio applet button inherits only default panel config. if you set a transparency or a backgroung image for a fading effect, applet button remain with full opaque gtk theme default color.
this is only for version > 0.9.93, revision 129 if i'm not mistaken

Thiago Teixeira (tvst) wrote :

Hmm...

This seems to be theme-dependent. When I use a theme like Radiance, for example, this works as expected:

1) Background: None - looks like my Gtk theme
2) Background: Solid color - looks like the color I choose, even if transparent
3) Background: Image - looks like the image, even if transparent

But when I try Clearlooks, items (2) and (3) above look like (1).

yes, you're right.
but what is really strange is that until version 0.9.93, the applet button behavior was the expected.
I'll try me too to figure out what's happening...

same theme, same system.
panel with half transparent background image. same behavior with standard panel transparency.

up: rev. 129
bottom: rev. 162

Thiago Teixeira (tvst) wrote :

> but what is really strange is that until version 0.9.93, the applet button behavior was the expected.

Well, there were other bugs up to version 0.9.93, which is why I changed that part of the code :) . I will try to find out what's happening, although these kinds of bugs are tough -- the Gnome applet API offers very little debugging help... ugh...

Thiago Teixeira (tvst) on 2010-06-15
Changed in cardapio:
importance: Undecided → Medium
status: New → Confirmed

rev. 179
:confused:
problem is gone!!! but reading your changelog i think you haven't worked on this 'bug'. or not?
my last revision tried before was 162.

Thiago Teixeira (tvst) wrote :

No, I haven't worked on it. This is indeed strange.

Plus it still happens on my machine...

rev. 220
still no problem. panel button behaves as expected.

Thiago Teixeira (tvst) wrote :

Ok, I'm closing this for now. If anyone runs into it again, please reopen.

Changed in cardapio:
status: Confirmed → Invalid
TheCaméléon (pictuga) on 2010-06-26
Changed in cardapio:
status: Invalid → Incomplete
TheCaméléon (pictuga) wrote :

I have this problem too with themes. The icon is white and opaque when we add the applet while using a theme which isn't Ubuntu default (Ambiance). But if we put the applet with the default theme (ambiance) and then change the theme, it will look fine...

2 screenshots to show you
http://img535.imageshack.us/img535/9445/capturewhite.png (custom theme)
http://img683.imageshack.us/img683/2360/capturegood.png (default theme)

Btw I changed back to "incomplete"

Thiago Teixeira (tvst) wrote :

I will take a look at this...

Changed in cardapio:
status: Incomplete → Confirmed
Wilbert Seele (wjseele) wrote :

Sorry about the duplicate bug. I've gone through several themes that didn't give problems (I can give those if it's needed), but on installing the mac 4 lin theme (http://sourceforge.net/projects/mac4lin/) it remains blue as if it's pressed. Seeing as this theme is pretty exhaustive (also changes nautilus for example) it may be related. I'm using Cardapio 0.9.114 on Ubuntu 10.04 64 bit on a Dell XPS 1330 laptop.

foxnbk (foxnbk) wrote :

Hey there,

bug still exists.. I am using Cardapio since 2 months with a transparent panel but I never expirienced this problem... I just updated to version 0.9.147 and it turned out that cardapio ignores the transparency of my panel. That looks strange, until fixed I am going to use the normal gnome-menu.

Thanks in advance

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments