Merge back "upstream" the Jenkins API relation in its charm

Bug #1387601 reported by Caio Begotti on 2014-10-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Capomastro
Medium
Caio Begotti

Bug Description

We need to merge back upstream (if possible) the Jenkins API relation we're using to talk to it from Capomastro as the current charm in the store does not support it even if the Jenkins service actually does.

Related branches

Caio Begotti (caio1982) on 2014-10-30
Changed in capomastro:
assignee: nobody → Caio Begotti (caio1982)
Caio Begotti (caio1982) wrote :

Hmm apparently now there's an extension hook available, so it seems merging our changes will be easy.

Changed in capomastro:
status: New → Confirmed
Caio Begotti (caio1982) wrote :

My mistake, the current extension hook from the IS charm enters an infinite setup loop with our charm when we set relations between the services because it's meant to be used by subordinate charms, which is not our case here even though the relation code is nearly 90% of what we need. We'll need to merge the API relation we had upstream after all...

Caio Begotti (caio1982) on 2014-11-27
Changed in capomastro:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers