Google 204 not reachable in China

Bug #1432524 reported by Michael on 2015-03-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Captive Portal Assistant
Fix Released
Medium
Unassigned

Bug Description

Several times now, a window with the title "Home | elementary OS" has popped up randomly on the screen. I can't close it, minimize, or move it, and it floats above everything else, blocking much of the screen. The only thing I can do to get rid of it is restart the entire system. I suppose it's some sort of link to the elementary OS download page, although the window is always blank, so I can't be sure. In any case, it's already become a serious problem. (I'm running Freya, if that helps).

Ken Harkey (kenny727) wrote :

May be a dumb question but did you get the iso from the official elementary source http://beta.elementary.io/? And has it been updated since?

Thanks for such a quick response. Yes, I did get the iso from the official source, and yes, it is fully up to date (at least as far as I can tell). One thing that might be an issue, though, is that I'm in China, and what with the firewall here I'm wondering if that might be blocking access to some of the repositories, at least temporarily. Could that have anything to do with it?

> Date: Mon, 16 Mar 2015 09:01:52 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 1432524] Re: "Home" window pops up spontaneously and can't be closed
>
> May be a dumb question but did you get the iso from the official
> elementary source http://beta.elementary.io/? And has it been updated
> since?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1432524
>
> Title:
> "Home" window pops up spontaneously and can't be closed
>
> Status in elementary OS:
> New
>
> Bug description:
> Several times now, a window with the title "Home | elementary OS" has
> popped up randomly on the screen. I can't close it, minimize, or move
> it, and it floats above everything else, blocking much of the screen.
> The only thing I can do to get rid of it is restart the entire system.
> I suppose it's some sort of link to the elementary OS download page,
> although the window is always blank, so I can't be sure. In any case,
> it's already become a serious problem. (I'm running Freya, if that
> helps).
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/elementaryos/+bug/1432524/+subscriptions

That could definitely be the issue. This is likely the Captive Portal Assistant. It attempts to access a certain Google page to verify that you have internet access. If you don't, it will pop up this window in an attempt to catch a redirect to a login form.

affects: elementaryos → capnet-assist
summary: - "Home" window pops up spontaneously and can't be closed
+ Google 204 not reachable in China
John Chan (goacross) wrote :

I can confirm this. The log in window keeps popping up and I have to close it by `killall captive-login`. I am in China, where http://clients3.google.com/generate_204 is inaccessible, and running the latest stable release of Freya.

John Chan (goacross) wrote :

In addition, I can still see this behaviour on a wired connection.

Cameron Norman (cameronnemo) wrote :

Can you run the captive-login command from the command line and paste the output here. I am specifically interested in the line "Return code: ..."

John Chan (goacross) wrote :

The return code is 4. The full terminal output looks like this:

goacross@dell:~$ captive-login
Getting 204 page
[A long pause for about five minutes]
Return code: 4
Opening browser to login
[A window titled "Log in" poped up, shortly redirects to "Download elementary OS" and then hangs]
^C

This may be why Google switched to using http://connectivitycheck.android.com/generate_204 in Android 5.0 or 5.1, if Google.com is blocked in China or elsewhere. We might be better off switching to a URL on elementary.io

Daniel Fore (danrabbit) on 2015-06-10
Changed in capnet-assist:
status: New → Fix Committed
milestone: none → loki-beta1

We now have elementary.io/generate_204 available to us and should migrate to that.

Cody Garver (codygarver) on 2015-08-17
Changed in capnet-assist:
importance: Undecided → Medium
milestone: loki-beta1 → 0.1.1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers