unicode decode error in job posts

Bug #612564 reported by Matthew Nuzum
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical wikithemes
High
Matthew Nuzum

Bug Description

Sometimes when posting a job this error is shown when you try to view it:

Traceback (most recent call last):
File "/srv/webapps.ubuntu.com/python-packages/django/core/handlers/base.py" in get_response
  77. response = callback(request, *callback_args, **callback_kwargs)
File "/srv/webapps.ubuntu.com/python-packages/trainingwebsite/employment/views.py" in post
  23. return render_to_response('employment/views/post.html', mapping)
File "/srv/webapps.ubuntu.com/python-packages/django/shortcuts/__init__.py" in render_to_response
  10. return HttpResponse(loader.render_to_string(*args, **kwargs))
File "/srv/webapps.ubuntu.com/python-packages/django/template/loader.py" in render_to_string
  106. return t.render(context_instance)
File "/srv/webapps.ubuntu.com/python-packages/django/template/__init__.py" in render
  168. return self.nodelist.render(context)
File "/srv/webapps.ubuntu.com/python-packages/django/template/__init__.py" in render
  705. bits.append(self.render_node(node, context))
File "/srv/webapps.ubuntu.com/python-packages/django/template/__init__.py" in render_node
  718. return(node.render(context))
File "/srv/webapps.ubuntu.com/python-packages/django/template/loader_tags.py" in render
  82. return compiled_parent.render(context)
File "/srv/webapps.ubuntu.com/python-packages/django/template/__init__.py" in render
  168. return self.nodelist.render(context)
File "/srv/webapps.ubuntu.com/python-packages/django/template/__init__.py" in render
  705. bits.append(self.render_node(node, context))
File "/srv/webapps.ubuntu.com/python-packages/django/template/__init__.py" in render_node
  718. return(node.render(context))
File "/srv/webapps.ubuntu.com/python-packages/django/template/loader_tags.py" in render
  23. result = self.nodelist.render(context)
File "/srv/webapps.ubuntu.com/python-packages/django/template/__init__.py" in render
  705. bits.append(self.render_node(node, context))
File "/srv/webapps.ubuntu.com/python-packages/django/template/__init__.py" in render_node
  718. return(node.render(context))
File "/srv/webapps.ubuntu.com/python-packages/django/template/loader_tags.py" in render
  23. result = self.nodelist.render(context)
File "/srv/webapps.ubuntu.com/python-packages/django/template/__init__.py" in render
  705. bits.append(self.render_node(node, context))
File "/srv/webapps.ubuntu.com/python-packages/django/template/__init__.py" in render_node
  718. return(node.render(context))
File "/srv/webapps.ubuntu.com/python-packages/django/template/__init__.py" in render
  767. output = self.filter_expression.resolve(context)
File "/srv/webapps.ubuntu.com/python-packages/django/template/__init__.py" in resolve
  579. obj = func(obj, *arg_vals)
File "/srv/webapps.ubuntu.com/python-packages/django/contrib/markup/templatetags/markup.py" in markdown
  40. return markdown.markdown(value)
File "/srv/webapps.ubuntu.com/python-packages/markdown.py" in markdown
  1722. return md.convert(text)
File "/srv/webapps.ubuntu.com/python-packages/markdown.py" in convert
  1614. self.source = removeBOM(self.source, self.encoding)
File "/srv/webapps.ubuntu.com/python-packages/markdown.py" in removeBOM
  74. if text.startswith(bom):

  UnicodeDecodeError at /employment/canonical_OEMFENA/
  'ascii' codec can't decode byte 0xc2 in position 314: ordinal not in range(128)

It is caused by their being a unicode character in the content and can often be difficult to locate and resolve.

Matthew Nuzum (newz)
visibility: private → public
Matthew Nuzum (newz)
Changed in canonical-webmonkeys:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers