1/2 screen on external monitor

Bug #1511538 reported by kevin gunn on 2015-10-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical Pocket Desktop
High
kevin gunn
Mir
Fix Released
High
Alan Griffiths
0.17
Fix Released
High
Unassigned
mir (Ubuntu)
High
Unassigned

Bug Description

using N7 latest PD image

connect bt mouse and keyboard
connected to monitor
opened several apps (clock, msg, phone, browser, twitter, u-s-s, terminal, camera, gallery, calculator, pathwind) - did quite a bit of window moving, max, min, close, relaunch

after a while, disconnected n7 from monitor, then reconnected
only 1/2 the screen on the monitor was used
disconnected, reconnected, still only 1/2 the screen used, possible low mem ?

Related branches

kevin gunn (kgunn72) wrote :
Changed in canonical-pocket-desktop:
assignee: nobody → kevin gunn (kgunn72)
importance: Undecided → High
Changed in mir (Ubuntu):
importance: Undecided → High
Changed in qtmir (Ubuntu):
importance: Undecided → High
Andrea Bernabei (faenil) wrote :

I can confirm, we had the same issue today when we tested it, I was about to file this

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mir (Ubuntu):
status: New → Confirmed
Changed in qtmir (Ubuntu):
status: New → Confirmed
tags: added: multimonitor
Gerry Boland (gerboland) wrote :

Note the upside-down shell on the external monitor is a separate unity8 bug.

Alberto Aguirre (albaguirre) wrote :

This seems to be addressed by lp:mir r3056

Changed in mir:
status: New → Fix Committed
milestone: none → 0.18.0
Changed in mir:
importance: Undecided → High
kevin gunn (kgunn72) on 2015-11-06
Changed in canonical-pocket-desktop:
status: New → Fix Committed
Changed in mir (Ubuntu):
status: Confirmed → Fix Committed
no longer affects: qtmir (Ubuntu)
Launchpad Janitor (janitor) wrote :
Download full text (152.7 KiB)

This bug was fixed in the package mir - 0.17.1+16.04.20151105.1-0ubuntu1

---------------
mir (0.17.1+16.04.20151105.1-0ubuntu1) xenial; urgency=medium

  [ Alberto Aguirre ]
  * New upstream release 0.17.1 (https://launchpad.net/mir/+milestone/0.17.1)
    - No ABI changes. Bug fix release only.
    - Bugs fixed:
      . compositing never stops when external monitor is connected
        (LP: #1499039)
      . half screen on external monitor (LP: #1511538)
      . Nested servers don't apply their display configuration at startup
        (LP: #1492269)
      . libmircookie1 package does not list libnettle as dependency
        (LP: #1513225)
      . unity-system-compositor crash, no interaction on windowed mode
        (LP: #1511095)
      . mir_connection_get_egl_pixel_format() crashes (LP: #1510218)
      . [regression] mir-client-platform-mesa-dev pkg-config file dropped
        (LP: #1509005)

  [ CI Train Bot ]
  * New rebuild forced.

mir (0.17.0+15.10.20151008.2-0ubuntu1) wily; urgency=medium

  [ Alexandros Frantzis ]
  * New upstream release 0.17.0 (https://launchpad.net/mir/+milestone/0.17.0)
    - ABI summary: Only servers and graphics drivers need rebuilding;
      . Mirclient ABI unchanged at 9
      . Mirserver ABI bumped to 35
      . Mircommon ABI unchanged at 5
      . Mirplatform ABI bumped to 11
      . Mirprotobuf ABI bumped to 3
      . Mirplatformgraphics ABI bumped to 6
      . Mirclientplatform ABI unchanged at 3
    - Enhancements:
      . Introduce libmircookie, a simple mechanism for a group of cooperating
        processes to hand out and verify difficult-to-forge timestamps to
        untrusted 3rd parties.
      . More refactorings to support renderers other than GL.
      . Add MirBlob to the client API - a tool for serializing and
        deserializing data.
      . Introduce a libinput based input platform, not yet used by default.
      . Provide a mechanism for the shell to send events on surface
        construction.
      . Provide mir::shell::DisplayConfigurationController allowing shells
        to correctly change the display configuration, notifying clients
        as appropriate.
      . New DSO versioning guide.
      . Send events pertaining to the output a surface is currently on (dpi,
        form factor, scale) to clients.
    - Bug fixes:
      . [enhancement] XMir specific documentation should live in its own
        subsection (LP: #1200114)
      . Nested servers need cursor support (LP: #1289072)
      . Mir cursor is missing/invisible until the client sets it multiple
        times (LP: #1308133)
      . [regression] Fullscreen software surfaces (like Xmir -sw) can crash
        the Mir server (LP: #1493721)
      . [usc] Mir gives up and shuts down due to input with multimonitor qtmir
        (std::exception::what: Failure sending input event) (LP: #1496069)
      . Mouse cursor disappears upon entering the surface area of a nested
        client (LP: #1496849)
      . [android] input is not dispatched when attaching an external monitor
        (LP: #1498045)
      . [android] input coordinates are scaled incorrectly when an external
        display is connected (LP: #1498540)
      . [andro...

Changed in mir (Ubuntu):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

So based on comment #7 was this really fixed by lp:~alan-griffiths/mir/nested-server-applies-display-config-policy ?

Changed in mir:
status: Fix Committed → Incomplete

This sounds like the cumulative effect of a number of Mir bugs in the display configuration handling that resulted in the surfaces composited by a nested server appearing in the wrong place.

It is plausible that the fixes landed up to -r3056 have resolved this (they certainly address Mir issues in this area) - but I was waiting for the 0.18 release to test with the full stack.

Changed in mir:
status: Incomplete → Fix Committed
assignee: nobody → Alan Griffiths (alan-griffiths)
Kevin DuBois (kdub) on 2015-12-22
Changed in canonical-pocket-desktop:
status: Fix Committed → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments