If the user shows the desktop while paying, the software-center ui gets blocked

Bug #648677 reported by Ara Pulido on 2010-09-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Payment service
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Steps to reproduce:

1. Open the software center
2. Click on buy the new background
3. When the payment dialog is opened, show the desktop (with Super-D key, i.e.)
4. Restoring the software centre ui shows the main software center UI and it is blocked (because there is a dialog opened somewhere).

I wasn't able to restore the payment dialog and I had to kill the application

Ara Pulido (ara) on 2010-09-27
visibility: private → public
Changed in canonical-payment-service:
status: New → Invalid
Michael Vogt (mvo) on 2010-09-27
Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Michael Vogt (mvo) wrote :

It looks like this is a problem with compiz and its stacking (z) order. It works correctly with metacity, but with compiz I can reproduce the problem.

Gary Lasker (gary-lasker) wrote :

This bug is fixed with software-center 4.0 in Natty as purchases are now implemented in-line and we no longer show a separate dialog.

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
Changed in compiz (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers