launchpad login service doesn't render in w3m (<= precise)

Bug #1193136 reported by Chris J Arges on 2013-06-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical SSO provider
Low
Dave Morley
w3m (Ubuntu)
Medium
Unassigned
Precise
Medium
Colin Watson

Bug Description

Occasionally it is useful to log into Launchpad using w3m (on servers, etc). When I log in I see the following:

"""
Log in or create account
[launchpad-]

Log in

You are here because Launchpad uses the Launchpad Login Service.

Email address

Password
[ ]
Forgot your password?

Create account

Log in or go back to Launchpad
"""

Where the field for 'Email address' is missing. This was working at some point, so this seems like a regression.

William Grant (wgrant) on 2013-06-21
affects: launchpad → canonical-identity-provider
Dave Morley (davmor2) wrote :

This seems to be fine for me on Raring.

Can I check what version of Ubuntu you are running.

Changed in canonical-identity-provider:
assignee: nobody → Dave Morley (davmor2)
importance: Undecided → Low
status: New → Incomplete
tags: added: u1-by-user u1-on-production
Colin Watson (cjwatson) wrote :

This is http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=615843, fixed in quantal but not in precise. We should probably SRU this.

Changed in w3m (Ubuntu):
status: New → Fix Released
Changed in w3m (Ubuntu Precise):
status: New → Triaged
Changed in w3m (Ubuntu):
importance: Undecided → Medium
Changed in w3m (Ubuntu Precise):
importance: Undecided → Medium
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

I've uploaded an SRU for precise with the Debian patch linked above, awaiting review.

Dave: It's up to you whether you want to keep this open on canonical-identity-provider. Using <input type="text"> rather than <input type="email"> would work around this, but that's probably deep in the guts of Django somewhere and presumably there's a reason it's using an HTML5-specific value for <input type> here. I suppose it depends on whether any other browsers we care about have this problem.

Changed in w3m (Ubuntu Precise):
status: Triaged → In Progress
Dave Morley (davmor2) wrote :

I'd say fix released it's been working fine for a while now.

Changed in canonical-identity-provider:
status: Incomplete → Fix Released

On Thu, Sep 19, 2013 at 10:51:59AM -0000, Dave Morley wrote:
> I'd say fix released it's been working fine for a while now.

Well, that's technically incorrect because nothing changed on your end
and you never properly reproduced Chris' original report; it's just that
w3m in quantal learned how to cope with <input type="email"> and you
didn't test with precise. But whatever :-)

summary: - launchpad login service doesn't render in w3m
+ launchpad login service doesn't render in w3m (<= precise)
Dave Morley (davmor2) wrote :

Meh indeed. Testing on precise confirms the issue. Sorry for the bug noise everyone.

Changed in canonical-identity-provider:
status: Fix Released → Confirmed

Hello Chris, or anyone else affected,

Accepted w3m into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/w3m/0.5.3-5ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in w3m (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Chris J Arges (arges) wrote :

It works!
Email address
[ ]

Password
[ ]

Thanks.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package w3m - 0.5.3-5ubuntu1.1

---------------
w3m (0.5.3-5ubuntu1.1) precise; urgency=low

  * Backport from Debian (Tatsuya Kinoshita):
    - Assume "text" if a form input type is unknown (closes: #615843,
      LP: #1193136).
 -- Colin Watson <email address hidden> Thu, 19 Sep 2013 10:22:30 +0100

Changed in w3m (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.