Can not add google account any more (Zesty)

Bug #1673984 reported by Khurshid Alam on 2017-03-18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
David Barth
signon-ui (Ubuntu)
Alberto Mardegan

Bug Description

After updating Unity-Control-Center to 15.04.0+17.04.20170314-0ubuntu2 and liboxidecore to 1.20.4-0ubuntu1 on Zesty I could not able to add to add Google account.

### How to reproduce:

1. Go online account try adding google account.

2. Infobar will appear for a moment and the it will disappear. Screenshot:

3. The login page doesn't load at all.

Running online-accounts-preferences from terminal gives:
(unity-control-center:7866): credentials-cc-panel-CRITICAL **: cc-credentials-authorization-page.vala:182: Error completing auth session process: userActionFinished error: 2

Installed Packages (Ubuntu 17.04 32 bit):
account-plugin-google: 0.13+17.04.20161206-0ubuntu1
signon-ui-x11: 0.17+17.04.20161109-0ubuntu1
unity-control-center: 15.04.0+17.04.20170314-0ubuntu2
unity-control-center-signon: 0.1.9+16.10.20160825-0ubuntu1

All other packages are up-to-date

Related branches

description: updated
Khurshid Alam (khurshid-alam) wrote :

Note : I can also reproduce on 64 bit os.

description: updated
description: updated
description: updated
Alberto Mardegan (mardy) wrote :
Download full text (3.5 KiB)

Thanks for the report, Alam!
I can confirm this. Here's the stack trace:

signon: browser-request.cpp 585 buildDialog Dialog was built
signon: request.cpp 137 setWindow Requesting window embedding

Thread 1 "signon-ui" received signal SIGSEGV, Segmentation fault.
QWindow::show (this=0x0) at kernel/qwindow.cpp:1851
1851 kernel/qwindow.cpp: No such file or directory.
(gdb) bt
#0 0x00007ffff40bf8de in QWindow::show() (this=0x0) at kernel/qwindow.cpp:1851
#1 0x000055555558b5e2 in SignOnUi::RequestPrivate::setWindow(QWindow*) (this=this@entry=0x5555558d0070, window=0x0) at request.cpp:139
#2 0x000055555558b7e0 in SignOnUi::Request::setWidget(QWidget*) (this=<optimized out>, widget=0x5555558d07f0) at request.cpp:308
#3 0x000055555556c25b in SignOnUi::BrowserRequestPrivate::start() (this=0x5555558d01f0) at browser-request.cpp:599
#4 0x000055555558d794 in SignOnUi::ServicePrivate::runQueue(QQueue<SignOnUi::Request*>&) (this=this@entry=0x5555558ba200, queue=...) at service.cpp:141
#5 0x000055555558da62 in SignOnUi::ServicePrivate::enqueue(SignOnUi::Request*) (this=this@entry=0x5555558ba200, request=request@entry=0x5555558d03a0) at service.cpp:126
#6 0x000055555558def0 in SignOnUi::Service::queryDialog(QMap<QString, QVariant> const&) (this=0x5555558ba790, parameters=...) at service.cpp:227
#7 0x0000555555593571 in SignOnUi::Service::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7fffffffd360) at moc_service.cpp:107
#8 0x00005555555936d8 in SignOnUi::Service::qt_metacall(QMetaObject::Call, int, void**) (this=0x5555558ba790, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7fffffffd360)
    at moc_service.cpp:169
#9 0x00007ffff3d56650 in () at /usr/lib/x86_64-linux-gnu/
#10 0x00007ffff3d5a4fd in () at /usr/lib/x86_64-linux-gnu/
#11 0x00007ffff3d5aadc in () at /usr/lib/x86_64-linux-gnu/
#12 0x00007ffff3d5d5ae in () at /usr/lib/x86_64-linux-gnu/
#13 0x00007ffff21bb359 in QObject::event(QEvent*) () at /usr/lib/x86_64-linux-gnu/
#14 0x00007ffff484835c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/
#15 0x00007ffff484fb11 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/
#16 0x00007ffff218e8a0 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/
#17 0x00007ffff219102d in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib/x86_64-linux-gnu/
#18 0x00007ffff21e2b03 in () at /usr/lib/x86_64-linux-gnu/
#19 0x00007ffff2ca2377 in g_main_context_dispatch () at /lib/x86_64-linux-gnu/
#20 0x00007ffff2ca25e0 in () at /lib/x86_64-linux-gnu/
#21 0x00007ffff2ca268c in g_main_context_iteration () at /lib/x86_64-linux-gnu/
#22 0x00007ffff21e2f0f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/
#23 0x00007ffff218c88a ...


affects: account-plugins (Ubuntu) → signon-ui (Ubuntu)
Changed in signon-ui (Ubuntu):
assignee: nobody → Alberto Mardegan (mardy)
importance: Undecided → Critical
status: New → Confirmed
affects: signon-ui → canonical-devices-system-image
Changed in canonical-devices-system-image:
milestone: none → u8c-2
assignee: nobody → David Barth (dbarth)
importance: Undecided → Critical
Alberto Mardegan (mardy) wrote :

Fix available here, waiting for QA:

Gunnar Hjalmarsson (gunnarhj) wrote :

I installed the zesty packages from <> and can confirm that it fixes this bug.

Marcos Alano (mhalano) wrote :

I installed the packages and the problem was solved.

Khurshid Alam (khurshid-alam) wrote :

Yes. It fixes the bug.

cl-netbox (cl-netbox) wrote :

I installed the packages from and can confirm that it fixes the issue.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package signon-ui - 0.17+17.04.20170320-0ubuntu1

signon-ui (0.17+17.04.20170320-0ubuntu1) zesty; urgency=medium

  * Update for Unity7 session renaming. (LP: #1673984)

 -- Alberto Mardegan <email address hidden> Mon, 20 Mar 2017 15:04:17 +0000

Changed in signon-ui (Ubuntu):
status: Confirmed → Fix Released
Khurshid Alam (khurshid-alam) wrote :

Ubuntu-session is now unity-session. This again breaks the code.

BenHoughton (ben-houghton-tk) wrote :

Having this same issue with 16.04 xenial. signon-ui is at version 0.17+16.04.20151125-0ubuntu1 but apt-get tells me I'm as up to date as I can be for this LTS. Does this fix need pushing to 16.04 also?

(unity-control-center:5967): account-plugin-CRITICAL **: Couldn't store identity: Server internal error occurred.Could not access Signon Database.

(unity-control-center:5967): credentials-cc-panel-CRITICAL **: cc-credentials-authorization-page.vala:182: Error completing auth session process: Server internal error occurred.Could not access Signon Database

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers