Install an app from Ubuntu Terminal and it doesn't show up in the app drawer

Bug #1672392 reported by Pete Woods on 2017-03-13
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
ubuntu-app-launch (Ubuntu)
High
Ted Gould
unity8 (Ubuntu)
High
Michael Zanetti

Bug Description

On a fresh Zesty Qemu VM, I installed dconf-editor from the archive using the terminal.

  sudo apt install dconf-editor

and it didn't show up in the app drawer, either in the scrollable list or searching by name.

After a reboot (can't logout due to bug #1670657) dconf-editor is there.

Related branches

Pete Woods (pete-woods) on 2017-03-13
tags: added: unity8-desktop
description: updated
description: updated
Michał Sawicz (saviq) on 2017-03-13
Changed in unity8 (Ubuntu):
status: New → Incomplete
status: Incomplete → Triaged
importance: Undecided → High
Changed in canonical-devices-system-image:
status: New → Triaged
importance: Undecided → High
Michael Zanetti (mzanetti) wrote :

u-a-l doesn't emit the required signals yet.

The linked unity8 branch implements this update functionality but it is not tested yet as u-a-l only provides a stub API at this point.

Changed in ubuntu-app-launch (Ubuntu):
importance: Undecided → High
Changed in unity8 (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Michael Zanetti (mzanetti)
Changed in ubuntu-app-launch (Ubuntu):
assignee: nobody → Ted Gould (ted)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-app-launch (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
assignee: nobody → Alejandro J. Cura (alecu)
milestone: none → u8c-2
Ted Gould (ted) on 2017-03-30
Changed in ubuntu-app-launch (Ubuntu):
status: Confirmed → In Progress
Michał Sawicz (saviq) on 2017-03-31
Changed in canonical-devices-system-image:
status: Triaged → In Progress
Pat McGowan (pat-mcgowan) wrote :

Bumped milestone as its a major usability issue, in case it can land

Changed in canonical-devices-system-image:
milestone: u8c-2 → u8c-z
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-app-launch - 0.12+17.04.20170404.2-0ubuntu1

---------------
ubuntu-app-launch (0.12+17.04.20170404.2-0ubuntu1) zesty; urgency=medium

  [ Michael Terry ]
  * Bump version for new AppID methods

  [ Ted Gould ]
  * Cleanup registry references to make them consistent (LP: #1676361)
  * Watch system folders for apps added and removed (LP: #1630997,
    #1672392)
  * Wait with a timeout for the libertine service to start
  * Provide equality operators for Application and Application::Instance
    objects. (LP: #1677345)
  * Force GTK and Qt backends when using XMir

 -- Ted Gould <email address hidden> Tue, 04 Apr 2017 21:48:48 +0000

Changed in ubuntu-app-launch (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers