Unity8 window shadows have gone missing

Bug #1671449 reported by dinamic on 2017-03-09
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu)
Medium
Albert Astals Cid
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

[unity8] windows don't have shadow

i see this on both 16.04 and 17.04 unity8 after the last update
i think? i've also seen this before by installing silo 2540

see attached screenshot

Related branches

dinamic (dinamic6661) wrote :
dinamic (dinamic6661) wrote :
dinamic (dinamic6661) wrote :

something changed after this update

ubuntu-system-settings-online-accounts 1 hour 40 minutes ago
Successfully built
ubuntu-ui-toolkit-gles 1 hour 50 minutes ago
Successfully built
ubuntu-ui-toolkit 1 hour 50 minutes ago
Successfully built
content-hub 11 hours ago
Successfully built

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Gerry Boland (gerboland) wrote :

Hey dinamic! Thanks for the bug!

Did this happen suddenly, or you never see shadows at all?

What GPU and driver are you using?

Could you provide a pastebin of the unity8.log file, ideally just after unity8 starts up so we get the initial output as unity8 starts.

dinamic (dinamic6661) wrote :

suddenly after the last update. using intel gpu (sandy bridge something). worked great before the last update.
ok, i'll remove the logs and restart.

Gerry Boland (gerboland) wrote :

Thanks for that. Can confirm it is nothing gpu/graphics related, it is a bug in our UITK. Fix on the way...

tags: added: unity8
kevin gunn (kgunn72) on 2017-03-09
tags: added: unity8-desktop
Changed in canonical-devices-system-image:
milestone: none → u8c-1
assignee: nobody → Zoltan Balogh (bzoltan)
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Christian Dywan (kalikiana)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
summary: - [unity8] windows don't have shadow
+ Unity8 window shadows have gone missing
Changed in canonical-devices-system-image:
status: New → Triaged
importance: Undecided → Medium
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Triaged → Fix Committed
assignee: Christian Dywan (kalikiana) → Albert Astals Cid (aacid)
Changed in canonical-devices-system-image:
status: Triaged → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Michał Sawicz (saviq) wrote :
Changed in canonical-devices-system-image:
status: Fix Released → In Progress
Changed in unity8 (Ubuntu):
status: Confirmed → Invalid
Changed in canonical-devices-system-image:
milestone: u8c-1 → u8c-z
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.2190+17.04.20170327

---------------
ubuntu-ui-toolkit (1.3.2190+17.04.20170327) zesty; urgency=medium

  [ Christian Dywan ]
  * Make AdaptivePageLayout handle layoutDirection out of the box.
  * Change layoutDirection from gallery (via UCApplication). Fixes LP: #1666869
  * Use layoutDirection to select icon for Back button. Fixes LP: #1665938
  * Ellipsize subtitle in the PageHeader. Fixes LP: #1660390

  [ Albert Astals Cid ]
  * Fix regression that broke BorderImage. Fixes LP: #1671449

 -- Zoltán Balogh <email address hidden> Mon, 27 Mar 2017 09:27:32 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers