GTK apps have wrong font thickness/hinting under Mir

Bug #1666435 reported by Daniel van Vugt on 2017-02-21
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Unassigned
GTK+
Fix Committed
Undecided
Unassigned
gtk+3.0 (Ubuntu)
Medium
William Hua
unity8 (Ubuntu)
Undecided
Unassigned
unity8-desktop-session (Ubuntu)
Undecided
Unassigned

Bug Description

GTK apps have wrong font/thickness/hinting under Unity8/Mir (compared to Unity7 where they look much better).

Changed in unity8 (Ubuntu):
status: New → Invalid
summary: - GTK apps have wrong font/thickness/hinting under Unity8
+ GTK apps have wrong font/thickness/hinting under Mir
description: updated
Will Cooke (willcooke) on 2017-02-28
Changed in gtk+3.0 (Ubuntu):
assignee: nobody → William Hua (attente)

Is GTK really responsible for setting up the session settings? It's the default hinting setting that's wrong and that might simply be because there is no gnome-settings-daemon to read the Ubuntu default settings for hinting.

Normally you could fix it with:
   gsettings set org.gnome.settings-daemon.plugins.xsettings hinting slight
But that doesn't seem to work under Unity8.

Possibly related: http://peter.kingofcoders.com/?p=177

Sebastien Bacher (seb128) wrote :

the gtk wayland backend reads the value directly from gsettings, the mir backend should probably do the same?
https://git.gnome.org/browse/gtk+/tree/gdk/wayland/gdkscreen-wayland.c#n169

Daniel van Vugt (vanvugt) wrote :

Sounds like the right answer. The GDK-Mir backend could copy that implementation (mostly)...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Changed in unity8-desktop-session (Ubuntu):
status: New → Confirmed
summary: - GTK apps have wrong font/thickness/hinting under Mir
+ GTK apps have wrong font thickness/hinting under Mir
William Hua (attente) wrote :

Committed as 01b73072961f8c62255cf2b66dba4e55d36fd646

Changed in gtk:
status: New → Fix Committed
Changed in canonical-devices-system-image:
status: New → In Progress
importance: Undecided → Medium
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Medium
Changed in canonical-devices-system-image:
milestone: none → u8c-z
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.22.11-0ubuntu3

---------------
gtk+3.0 (3.22.11-0ubuntu3) zesty; urgency=medium

  * debian/patches/series:
  * debian/patches/0001-mir-always-emit-a-resize-when-creating-windows.patch:
  * debian/patches/0024-mir-re-write-settings-implementation.patch:
  * debian/patches/0025-mir-remove-keymap-and-input-device-state-warnings.patch:
  * debian/patches/0026-mir-set-application-name-when-creating-connection.patch:
    - Add upstream patches from gtk-3-22 branch
    - Fix LP: #1670390, LP: #1666435, LP: #1618298

 -- William Hua <email address hidden> Tue, 04 Apr 2017 14:31:11 -0400

Changed in gtk+3.0 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers