[performance] unity8.log flooded with debug messages about window position and cursor shape

Bug #1664151 reported by Daniel van Vugt on 2017-02-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Michał Sawicz
qtmir (Ubuntu)
Medium
Daniel d'Andrada
unity8 (Ubuntu)
Medium
Unassigned

Bug Description

[performance] qtmir.surfaces messages about cursor position and appearance flood unity8.log when dragging a window, or when moving the cursor over some apps:

[2017-02-13:14:03:45.132] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setRequestedPosition(QPoint(577,109))
[2017-02-13:14:03:45.140] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setRequestedPosition(QPoint(580,109))
[2017-02-13:14:03:45.148] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setRequestedPosition(QPoint(582,109))
[2017-02-13:14:03:45.148] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setRequestedPosition(QPoint(582,107))
[2017-02-13:14:03:45.162] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setRequestedPosition(QPoint(586,107))
[2017-02-13:14:03:45.164] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setRequestedPosition(QPoint(588,107))
[2017-02-13:14:03:45.172] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setRequestedPosition(QPoint(591,107))
[2017-02-13:14:03:45.180] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setRequestedPosition(QPoint(593,107))
[2017-02-13:14:03:45.188] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setRequestedPosition(QPoint(595,107))
[2017-02-13:14:03:45.196] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setRequestedPosition(QPoint(597,107))
[2017-02-13:14:03:45.196] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setRequestedPosition(QPoint(597,108))
[2017-02-13:14:03:45.204] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setRequestedPosition(QPoint(599,108))
[2017-02-13:14:03:45.220] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setRequestedPosition(QPoint(601,108))
[2017-02-13:14:03:45.279] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setRequestedPosition(QPoint(602,108))
[2017-02-13:14:03:53.564] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setCursor(Arrow)
[2017-02-13:14:03:53.572] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setCursor(Arrow)
[2017-02-13:14:03:53.604] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setCursor(Arrow)
[2017-02-13:14:03:53.612] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setCursor(Arrow)
[2017-02-13:14:03:53.620] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setCursor(Arrow)
[2017-02-13:14:03:53.628] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setCursor(Arrow)
[2017-02-13:14:03:54.916] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setCursor(Arrow)
[2017-02-13:14:03:54.972] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setCursor(Arrow)
[2017-02-13:14:03:54.988] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setCursor(Arrow)
[2017-02-13:14:03:55.012] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setCursor(Arrow)
[2017-02-13:14:03:55.044] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setCursor(Arrow)
[2017-02-13:14:03:55.100] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setCursor(Arrow)
[2017-02-13:14:03:55.156] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setCursor(Arrow)
[2017-02-13:14:03:55.196] qtmir.surfaces: MirSurface[0x5562bca913b0,"unity8-dash"]::setCursor(Arrow)

Related branches

Changed in canonical-devices-system-image:
importance: High → Medium
Changed in qtmir (Ubuntu):
importance: Undecided → Medium
description: updated
summary: - [performance] qtmir.surfaces messages about cursor position and
- appearance flood unity8.log
+ [performance] unity8.log flooded with debug messages about cursor
+ position and appearance
Changed in unity8 (Ubuntu):
importance: Undecided → Medium
tags: added: unity8-performance
tags: added: unity8-desktop
removed: unity8-performance

According to the source code, the debug messages come from:
  DEBUG_MSG
which calls:
  qCDebug(QTMIR_SURFACES).nospace()

So that sounds reasonable. It would appear at some point we will need to define QT_NO_DEBUG_OUTPUT during QtMir builds to stop excess debug messages in release binaries. Or to remove any truly excessive debug messages like those above which can appear on simple cursor movements.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtmir (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
status: New → Confirmed
summary: - [performance] unity8.log flooded with debug messages about cursor
- position and appearance
+ [performance] unity8.log flooded with debug messages about window
+ position and cursor shape
Changed in unity8 (Ubuntu):
status: Confirmed → Invalid
Changed in qtmir (Ubuntu):
assignee: nobody → Daniel d'Andrada (dandrader)
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
assignee: nobody → Michał Sawicz (saviq)
Daniel van Vugt (vanvugt) wrote :

Come to think of it, I would expect this bug to cause rendering hiccups every 5 seconds or so while dragging windows. Same as https://bugs.launchpad.net/ubuntu/+source/unity8/+bug/1664150/comments/8

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtmir - 0.5.1+17.04.20170307-0ubuntu1

---------------
qtmir (0.5.1+17.04.20170307-0ubuntu1) zesty; urgency=medium

  [ Albert Astals Cid ]
  * Fix clang build

  [ Daniel d'Andrada ]
  * Some qtmir::Session fixes
  * Make TaskController absorb SessionManager
  * Don't pass command line arguments to Mir
  * Reduce default log verbosity (LP: #1664151)
  * DBusFocusInfo: fix crash when trying to access a null session from
    an application (LP: #1670710)

  [ Gerry Boland ]
  * Workaround for Mir changing GL state unexpectedly on Qt, breaking
    font rendering. (LP: #1583088)

  [ Lukáš Tinkl ]
  * Use the shell chrome, as provided by miral window info (LP:
    #1658117)

 -- Lukáš Tinkl <email address hidden> Tue, 07 Mar 2017 23:43:16 +0000

Changed in qtmir (Ubuntu):
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2017-03-13
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers