system collapses when user presses 'next' in the wizard with dbus 1.10.6-1ubuntu3.2

Bug #1654241 reported by Jean-Baptiste Lallement on 2017-01-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Pat McGowan

Bug Description

frieza arm64 114

On first boot, when the user press 'Next' on the first page of the wizard the system becomes unresponsive and a hard reboot is required. Syslog shows that several services are segfault'ing.

logs and crash files attached.

Jean-Baptiste Lallement (jibel) wrote :
description: updated
Changed in canonical-devices-system-image:
importance: Undecided → Critical
milestone: none → x1
Michał Sawicz (saviq) wrote :

The direct cause for the collapse is the lack of session dbus: bug #1654365

Another question is why is the image built with proposed?

There's all kinds of other crashes going on that I'll be filing bugs for.

Michał Sawicz (saviq) wrote :

unity-system-compositor: bug #1654536

Michał Sawicz (saviq) wrote :

click: bug #1654543 (unlikely to be a bigger problem)

Jean-Baptiste Lallement (jibel) wrote :

diff of the rootfs between 102 (last known good image) and 116
device tarballs are identical

Jean-Baptiste Lallement (jibel) wrote :

Images have been rebuilt with proposed disabled and boot successfully now. I added a comment to the SRU bug 1644323 and marked it as verification-failed. I'm closing this report.

Changed in canonical-devices-system-image:
status: New → Fix Released
Jean-Baptiste Lallement (jibel) wrote :

Reopening until root cause of the problem with dbus 1.10.6-1ubuntu3.2 in xenial-proposed is fixed and unblock the promotion of dbus to xenial updates.

summary: - system collapses when user presses 'next' in the wizard
+ system collapses when user presses 'next' in the wizard with dbus
+ 1.10.6-1ubuntu3.2
Changed in canonical-devices-system-image:
status: Fix Released → Confirmed
assignee: nobody → Pat McGowan (pat-mcgowan)

Hello Jean-Baptiste, or anyone else affected,

Accepted dbus into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/dbus/1.10.6-1ubuntu3.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for dbus has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers