Hotspot crashes the device and reboots

Bug #1629782 reported by Kugi Eusebio on 2016-10-03
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Alejandro J. Cura
indicator-network (Ubuntu)
Undecided
Pete Woods
ubuntu-system-settings (Ubuntu)
Critical
Jonas G. Drange

Bug Description

The device hangs and reboots after some tasks related to hotspot.

There are a couple of ways that this bug occurred.

1. While the hotspot is on, try to change hotspot settings like requiring passwords. Upon clicking the Change button, the bug occurs. (happens always)

2. Turning on the hotspot from the settings app while the wifi is off the bug occurs. (happened once)

Not sure what log will be helpful. Please let me know and I'll attach them.

Device:
bq E5 HD (OTA 13)

Joan CiberSheep (cibersheep) wrote :

Since OTA13 on bq e5 I couldn't make hotspot work. Reboots happens after trying to change password or turning hotspot on and off from settings, hotspot

Pat McGowan (pat-mcgowan) wrote :

Confirmed on an E4.5 running ota13. Could not reproduce on MX4.

Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → Critical
milestone: none → 14
status: New → Confirmed
tags: added: regression-release
Bill Filler (bfiller) wrote :

works fine on rc-proposed krillin (E4.5), will flash ota13 and try again

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Jonas G. Drange (jonas-drange)
importance: Undecided → Critical
Pat McGowan (pat-mcgowan) wrote :

I did what is in the description, turned off requiring a password.
I will note that this phone does not have a working cellular connection but that would seem unrelated.

Pat McGowan (pat-mcgowan) wrote :

Connectivity api?

Changed in canonical-devices-system-image:
assignee: Bill Filler (bfiller) → Alejandro J. Cura (alecu)
Changed in indicator-network (Ubuntu):
assignee: nobody → Pete Woods (pete-woods)
Changed in canonical-devices-system-image:
milestone: 14 → backlog
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-network (Ubuntu):
status: New → Confirmed
Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
Jan Baarda (j-baarda1) wrote :

E5 OTA-14, After switching of hotspot system will hang within a few minutes (not immediately). When called mobile rings, no possibility to answer. The device heats up when system hangs. This till signal "battery critical low", after which the system resumes normal operation.

N.B. System also hangs when battery fully loaded (>90%)

In all cases the system can only be restarted after prolonged pressing (>40 sec.) of the restart/switch-off button.

Jan Baarda (j-baarda1) wrote :

E5 OTA-14 updated 4 Jan 2017: The problems with Hotspot operations, as mentioned above seems resolved.

Jan Baarda (j-baarda1) wrote :

E5 OTA-14 updated 7 Jan 2017: The hotspot problem as mentioned in #8 still exist. With exception of the fully loaded battery hang-up. The battery can be fully loaded without hanging the system.

Nicolas Jungers (unbug) wrote :

For me the phone hang if and when I turn the hotspot off. It doesn't hang immediately, but in the minutes that follow. It's pretty reliable.

OTOH, if I switch to plane mode, and then back to normal mode, the hotspot is turned off an my phone doesn't hang. That's also pretty reliable.

Costa davide (davide-cst00) wrote :

Hey all
the situation worsened after doing OTA 15 update. Now on klilin when you enable hotspot the device power off and it wont power up anymore. Recovery mode is not working. The device restarted to work 'magically' connecting via usb to pc during bootsrap session

Pete Woods (pete-woods) on 2017-11-14
Changed in indicator-network (Ubuntu):
status: Confirmed → Won't Fix
Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers