My activity child link disappears after logged in fitbit account

Bug #1622423 reported by Evan Wang on 2016-09-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Michał Sawicz
Today Scope
Medium
Kyle Nitzsche
unity-scopes-shell (Ubuntu)
Undecided
Paweł Stołowski
unity8 (Ubuntu)
Medium
Albert Astals Cid

Bug Description

$ system-image-cli -i
current build number: 15
device name: turbo
channel: ubuntu-touch/rc/meizu-pd.en
last update: 2016-09-05 03:19:44
version version: 15
version ubuntu: 20160903
version tag: OTA-13-rc
version device: 20160824-d33b825
version custom: 20160831-992-8-12

The child arrow link of My Activity session disappears once logged in fitbit account in Today scope, so unable to open My Activity child scope from Today scope

Steps to reproduce:
1. Open Today scope and navigate to My Activity session,
2. Existing a child link, tap it will open My Activity scope
2. Tap 'Add your fitbit account' and login with Google account
3. Once logged in, back to Today scope and refresh, check if the child link still exist.

Actual results:
Once logged in fitbit account, some items of fitbit displayed in session, but the child scope link has gone, unable to open My Activity scope from Today scope
If open My Activity scope from manage page by swiping up, blank scope page shown

Related branches

Evan Wang (wsy324) wrote :
Kyle Nitzsche (knitzsche) wrote :

I continue to see the arrow in the My Activity category header which when tapped after login opens fitbit child scope using:
* com.canonical.scopes.dashboard 4.11.1
* com.canonical.scopes.dashboard 4.11.2

on

phablet@ubuntu-phablet:~$ system-image-cli -i
current build number: 131
device name: cooler
channel: ubuntu-touch/rc-proposed/bq-aquaris-pd.en
last update: 2016-09-12 11:45:06
version version: 131
version ubuntu: 20160910
version device: 20160809.0
version custom: 20160831--42-26-vivid

Evan Wang (wsy324) wrote :

Hmmm, seems the arrow will not show until reboot, if login fitbit then pull down to refresh, the arrow is not shown, if move up My Activity category header to the top of Today scope, the arrow appears, then move it down the arrow disappears again.
After reboot, the arrow show normally, i got the same behavior on both OTA-13-rc and latest rc-proposed image.

Evan Wang (wsy324) wrote :
Evan Wang (wsy324) wrote :
Kyle Nitzsche (knitzsche) wrote :

Hi Evan,

I was just able to duplicate this. Thanks for reporting.

After logging in to fitbit and returning to and refreshing Today scope (which is favorited), my fitbit results show, but, as you said, the category header (With title "My Activity" does not have the "link to child" tappable arrow to open the child scope (fitbit).

Kyle Nitzsche (knitzsche) wrote :

If I then unfavorite the Today scope then relaunch it, the click to child arrow in the category header is present.

Kyle Nitzsche (knitzsche) wrote :

I think the solution is to handle fitbit presentation in today scope the same as the twitter scope, that is: the link to child should be present in the category header even when the user is not logged in. I'll look into this.

Changed in today-scope:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Kyle Nitzsche (knitzsche)
Kyle Nitzsche (knitzsche) wrote :

Some debug info:

I've attached a debug version of the today scope that only aggregates twitter and fitbit.

After installing, find it in Manage with this title "FLToday".

Starting condition:
* disable twitter in this agg scope from settings
* disable your login to fitbit account in settings > accounts > fitbit
(It does not matter whether you are logged into twitter).
* don't have the fltoday scope favorited (not sure if this matters)

Reproduce:
1) Launch FLToday
The fitbit login result should display, and it should have a visible link to the fitbit child scope

2) Tap the login result and enable your fitbit account
You are returned to the agg scope.
Now we are using the surfacing category that *should* have a link to child, but it does not display.
There are two results.

3) in FLToday settings, enable the twitter scope
On return to surfacing, you should now see twitter AND our fitbit category. But now, the fitbit category DOES have a link to child.

Note: if twitter had been initially enabled and in step 3) you *disable* it, the result is the same: the fitbit category DOES have the expected link to child.

Changed in unity-scopes-shell (Ubuntu):
assignee: nobody → Paweł Stołowski (stolowski)
Kyle Nitzsche (knitzsche) wrote :

Hi Pawel, Per our irc conversation, this is the link-to-child bug I was referring to. See comment #9 particularly.Thanks for your input.

Kyle Nitzsche (knitzsche) wrote :

Just noting that another bug relates to the link to child, which may be a display issue: https://bugs.launchpad.net/today-scope/+bug/1508905

Kyle Nitzsche (knitzsche) wrote :

And an annotated pastebin of the unity8-dash log:
https://pastebin.canonical.com/165995/

Paweł Stołowski (stolowski) wrote :

Ok, I was able to reproduce the issue.

I've checked unity-scopes-shell plugin with a debug branch (https://code.launchpad.net/~stolowski/unity-scopes-shell/debug-category-link; packages available here https://code.launchpad.net/~unity-api-team/+archive/ubuntu/dev-build-1/+packages) and it seems to be innocent, according to my debug the category header link is correctly exposed to the QML (the getter for header link gets called when the issue happens, but for some reason is not rendered). Assigning to unity8 project.

Changed in unity8 (Ubuntu):
assignee: nobody → Albert Astals Cid (aacid)
status: New → In Progress
Michał Sawicz (saviq) on 2016-11-08
Changed in unity-scopes-shell (Ubuntu):
status: New → Invalid
Changed in today-scope:
status: Confirmed → Invalid
Changed in canonical-devices-system-image:
status: New → In Progress
importance: Undecided → Medium
Changed in unity8 (Ubuntu):
importance: Undecided → Low
Changed in canonical-devices-system-image:
assignee: nobody → Michał Sawicz (saviq)
milestone: none → 14
Changed in unity8 (Ubuntu):
importance: Low → Medium
Michał Sawicz (saviq) on 2016-11-10
Changed in canonical-devices-system-image:
milestone: 14 → backlog
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.14+17.04.20161109-0ubuntu1

---------------
unity8 (8.14+17.04.20161109-0ubuntu1) zesty; urgency=medium

  [ Albert Astals Cid ]
  * Make more CardTool properties readonly
  * Make the > in Dash Section Header be after text (LP: #1508905)
  * Rework Dash Preview column margins
  * Improve LVWPH <-> GenericScopeView interaction (LP: #1508905,
    #1622423)
  * Make the PreviewButtons be of the width of the button and not half
    the total width
  * Fix first column of the preview table to be 25%

  [ Andrea Cimitan ]
  * Remove background under header pagination dots, update dots assets,
    remove dash paper background, update bottom edge asset
  * Few styling changes for cards
  * various tweaks to fonts inside previews
  * More visual tweaks

  [ Brian Douglass ]
  * Add a new setting to enable/disable the launcher

  [ Lukáš Tinkl ]
  * Stabilize test_doubleTapToMaximizeWindow()
  * Enable loading the main Qt catalog which in turn allows for using
    RTL languages
  * Fix the pixelated notification icon by setting sourceSize (LP:
    #1637712)

  [ Michael Terry ]
  * More path lookup fixes for running inside of a snap. (LP: #1629009)

  [ Michael Zanetti ]
  * Added blur and darkening to wallpaper while in spread
  * Fixes in the spread after design review (LP: #1637502, #1638848)
  * More fixes to the unified stages code (LP: #1637205, #1637249,
    #1637258)
  * Delay alt tab for tiny bit in order to avoid flickering on quick alt-
    tabs

  [ Tomás Tormo ]
  * Reload Infographics userdata when the day changes (LP: #1378814)

 -- Michał Sawicz <email address hidden> Wed, 09 Nov 2016 15:10:32 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers