System settings app crashes when doing the second checking for updates

Bug #1617217 reported by Evan Wang on 2016-08-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Bill Filler
ubuntu-system-settings (Ubuntu)
Critical
Jonas G. Drange

Bug Description

$ system-image-cli -i
current build number: 166
device name: turbo
channel: ubuntu-touch/rc-proposed/meizu-pd.en
last update: 2016-08-26 00:46:47
version version: 166
version ubuntu: 20160826
version device: 20160812-8b46c21
version custom: 20160805-985-8-9

Steps to reproduces:
1. Ubuntu One account signed in
2. Press option of 'Check for updates' from System Settings-->About-->Check for updates
3. Waiting for the updates checking is done, but do nothing then back to About page instead
4. Press 'Check for updates' again

Actual results:
System Settings crashed, quit directly.

Related branches

Evan Wang (wsy324) wrote :
Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
milestone: none → 13
status: New → Confirmed
Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Jonas G. Drange (jonas-drange)
status: New → Confirmed
tags: added: regression-proposed
Bill Filler (bfiller) on 2016-08-30
Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → High
Bill Filler (bfiller) wrote :

are there any crash files in /var/crash from system-settings, system-image-dbus or ubuntu-download-manager?

Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → In Progress
Bill Filler (bfiller) wrote :

confirmed, can crash it everytime

Changed in ubuntu-system-settings (Ubuntu):
importance: High → Critical
Changed in canonical-devices-system-image:
importance: High → Critical
Jonas G. Drange (jonas-drange) wrote :

One theory is that the plugin manager is not doing the right thing here, because if you, after step 3 exit the About panel, then enter it, then perform step 4—you get a warning from the plugin manager that “system-update” can't be found. The other theory is that the system-update plugin isn't cleaning up properly, which is unlikely because the bug cannot be triggered without going via the About panel.

Will confirm one or the other by changing the plugin instantiated by About with something closer to pure-qml, e.g. Hotspot—or create a brand new, empty one.

It crashes (albeit not as quickly) using the hotspot page, so this is
unrelated to System Update. It looks like a race in the plugin-manager.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.4+16.10.20160831.1-0ubuntu1

---------------
ubuntu-system-settings (0.4+16.10.20160831.1-0ubuntu1) yakkety; urgency=medium

  [ jonas-drange ]
  * fixes two crashes in About -> Check for update and Battery ->
    Brightness (LP: #1617217)

 -- Ken VanDine <email address hidden> Wed, 31 Aug 2016 15:19:48 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers