File Manager crashes when Network is selected

Bug #1609051 reported by Jaap Dekker on 2016-08-02
This bug affects 49 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Bill Filler
Ubuntu File Manager App
Renato Araujo Oliveira Filho
samba4 (Ubuntu)

Bug Description

Ubuntu 15.04, r157, BQ Aquarius M10

Related branches

DansLeRuSH (danslerush) wrote :

Same problem on Meizu Pro 5 (OTA-12) since the last update 0.4.562

sheiko (s-heiko) wrote :

Same Problem OTA12 on BQ 4.5

Simon Jansen (jansense) wrote :

Just reported duplicate bug. Didn't see this one. Will try to remove.

App crashes when selecting the "Network" bookmark. It starts searching and crashes consistently.
- On different networks and with WiFi on or off.
- "Unlock full access" on or off
- "Show Advanced Features" on or off

Goto "smb:\\[ip]\[share]" also doesn't work. It worked with previous versions. Not sure when this got broken.

On BQ Aquaris M10 FHD Ubuntu edition.
OTA 12. File Manager version 0.4.562

Tony Pursell (ajpursell) wrote :

Log file when it crashes on my BQ Aquarius 4.5:

From file /home/phablet/.cache/upstart/application-click-com.ubuntu.filemanager_filemanager_0.4.562.log:
[PERFORMANCE]: Last frame took 40 ms to render.
void DirModel::setPath(const QString&, const QString&, const QString&, bool) DirModel_QML_119(0xc66c68) Ignoring path change request, request already running in "smb://"
tdb(__NULL__): tdb_open_ex: called with name == NULL
tdb(__NULL__): tdb_open_ex: called with name == NULL
tdb(__NULL__): tdb_open_ex: called with name == NULL
tdb(__NULL__): tdb_open_ex: called with name == NULL
no talloc stackframe at ../source3/libsmb/cliconnect.c:2838, leaking memory

Following these actions

- Opened File Manager
- Swipe up for Places
- Press Network

After a few second File Manager crashes.

Tony Pursell (ajpursell) on 2016-08-15
Changed in ubuntu-filemanager-app:
status: New → Confirmed
summary: - App crashes when Network is selected
+ File Manager crashes when Network is selected
Norbert (nrbrtx) wrote :

Same on M10 with OTA-13, filemanager 0.4.562.

vh-d (vencahaus) wrote :

Same on Nexus 4 - rc-proposed - OS build r542
Is there any other way to connect to a samba drive on the Ubuntu Touch? If not it seems as quite critical bug.

DarabosJ (darabosj) wrote :

I found the bug in the samba source in the file source3/libsmb/cliconnect.c:

NTSTATUS cli_tdis(struct cli_state *cli)
 struct tevent_context *ev;
 struct tevent_req *req;

 if (smbXcli_conn_protocol(cli->conn) >= PROTOCOL_SMB2_02) {
  return smb2cli_tdis(cli->conn,

 if (smbXcli_conn_has_async_calls(cli->conn)) {
 ev = samba_tevent_context_init(talloc_tos());
 if (ev == NULL) {
  goto fail;
 req = cli_tdis_send(ev, ev, cli);
 if (req == NULL) {
  goto fail;
 if (!tevent_req_poll_ntstatus(req, ev, &status)) {
  goto fail;
 status = cli_tdis_recv(req);
 return status;

when the ev allocation is not possible on the fail try to free up the unallocated memory.
need to be reported to the samba team also.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in samba4 (Ubuntu):
status: New → Confirmed
Paul (pind) wrote :

Same on M10 with OTA-13, filemanager 0.4.562

pgcor (pgcor) wrote :

Same on E5 with OTA-13, filemanager 0.4.562

Kevin (blackhawkover-gmail) wrote :

Same on Nexus 4 OTA-13. filemanager 0.4.562

Same on ubuntu-emulator. filemanager 0.4.562

Simon Jansen (jansense) wrote :

Same on M10 with OTA-14, filemanager 0.4.562

Jojo (tracehunter) wrote :

Still on Nexus 4 (mako) OTA-14, filemanager 0.4.562

wowo (woutvanvucht) wrote :

Why o why is this very essential bug still unassigned??????????
I have a NAS and I cannot use all of my documents.
Fortunately I have also an iPad, so I am using my Ubuntu tablet no more.

not sure who tracks and assigns bugs on file manager, but if the issue is really in the samba client lib used in the device rootfs that might be the reason it was not yet assigned (might not be the same people as the file manager).

I came by looking for the samba issue from a Server POV, but as far as I can evaluate right now (also discussed with a Teammate) that seems not to be so much of an issue for the server side of things.

If the state really is as reported I agree that this is a severe issue, so I wanted this to be properly handled. I subscribed the devices team and added a matching bug task to get their attention.

wowo (woutvanvucht) wrote :

@ChristianEhrhardt (paelzer)
Thanks for your help!

Markcortbass (markcortbass) wrote :

I confirm this critical bug:

Markcortbass (markcortbass) wrote :

Version 0.4.562 crashes, version 0.4.528 from OpenStore works just fine!

Pat McGowan (pat-mcgowan) wrote :

This seems to have regressed between Feb and August when the bug was reported. I do not think the app was updated between then. 562 was published Aug 1.

Bill Filler (bfiller) on 2017-01-06
Changed in ubuntu-filemanager-app:
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
importance: Undecided → Medium
Changed in ubuntu-filemanager-app:
importance: Medium → Undecided
Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
status: New → Confirmed
Pat McGowan (pat-mcgowan) wrote :

Every places selection results in logging the message "Ignoring path change request, request already running..." so it may be benign but seems there is some busted logic there, the setPath() code never runs after the first time because mAwaitingResults is never set back to false.(in dirmodel.cpp)

Also noticed the pathExists() check will always return false for smb://

Changed in ubuntu-filemanager-app:
importance: Undecided → High
Pat McGowan (pat-mcgowan) wrote :

Verified that version 0.4.543 from June 29 does not crash and does not log the message.

Changed in ubuntu-filemanager-app:
status: Confirmed → In Progress

The filemanager UI used to (I am not sure if it still does) create 2 instances of DirModel class, the second instance was used to check paths being typed by the user, this second instance can be responsible to issue the message "Ignoring path change request, request already running...", I do not remember, it would require some investigation.

The "mAwaitingResults" is set to false in DirModel::onItemsFetched(), see

The "libsmbclient" is hard to work with, but filemanager used to work fine, any change in the "libsmbclient" can affect the filemanager.

Another thing is, the filemanager used to embed the "libsmbclient" in its package (I do not know if it is active or not), it was done because we could not install "libsmbclient" on the phone due to space restrictions (talk to Popey about this), this is something that needs to investigated to make sure which "libsmbclient" version is being loaded by the filemanager.

Changed in canonical-devices-system-image:
status: Confirmed → In Progress
milestone: none → p2

Hey guys I have a fix for that already.
Could someone from filemanager dev team review it, please?

It is interesting that you guys reported that versions 0.4.543 and 0.4.528 do work, I understand that these versions correspond to revisions 543 and 528 respectively.

My last change on "src/folderlistmodel" code was in revision 518 on 2016-01-15.

I have compared "src/folderlistmodel" code from current revision 583 with revisions 543 and 528, there is only one difference, the method DirModel::isAllowedPath() was a private and simple method, it has changed to be a public slot because it is now used in src/app/qml/ui/FolderListPage.qml:230 which may not cause any problem.

Fix committed into lp:ubuntu-filemanager-app at revision None, scheduled for release in ubuntu-filemanager-app, milestone alpha-1

Changed in ubuntu-filemanager-app:
status: In Progress → Fix Committed
Norbert (nrbrtx) wrote :

Same on M10 with OTA-15, filemanager 0.4.562.

Norbert (nrbrtx) on 2017-02-07
tags: added: bq m10 touch
Norbert (nrbrtx) wrote :

Same on M10 with rc-proposed r268.

hellslinger (jhemsing) wrote :

M10 needs fix, ota15 crashes.

Raoul (raoulmaherwork) wrote :

Please sort this out - Still not working accessing network 23-06-17

Seems support died together with ubuntu touch, thank you so very much.

Still not working looks like Ubuntu Touch has become ABANDONWARE - anyone disagree ?

mikahdh (f4tmike) wrote :

That's right. Canonical ditched Ubuntu Phone - it's now a community project. Go to

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers