Snap decisions inhibit notifications - queue can build up indefinitely

Bug #1606202 reported by Michael Zanetti
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Michał Sawicz
Ubuntu UX
Undecided
Unassigned
unity-notifications (Ubuntu)
Undecided
Lukáš Tinkl
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

It happens that I have the phone or tablet just there on the desk for a day without actually using it. Sometimes, during that time, a snap decision is triggered, for example the WiFi password dialog.

This snap decision stays there forever, without timeout and blocks other notifications. There are 2 issues with that:

1) Because other notifications are blocked, I'd miss incoming SMS or other notifications until I deal with the WiFi password prompt.

2) If this situation is stuck for a day, after removing the snap decision, all the built up queue is delivered one by one. This leads to multiple minutes of the device annoying the user with (mostly old and outdated) notifications. See the attached video. Note that I've been swiping notifications away for a while already before deciding to record the video. There were maaaany more in the queue.

Related branches

Revision history for this message
Michael Zanetti (mzanetti) wrote :
summary: - Notification queue can build up indefinitely
+ Snap decisions inhibit notifications - queue can build up indefinitely
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-notifications (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
Revision history for this message
Julia Palandri (julia-palandri) wrote :

Thanks Michael for the bug report, it's super annoying indeed :/

Revision history for this message
Anupam (anupam207) wrote :

Is bug #1516696 happening for the same reason?

Revision history for this message
Michael Zanetti (mzanetti) wrote :

@Anupam, no, I don't think it is the same thing.

description: updated
Changed in unity-notifications (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Lukáš Tinkl (lukas-kde)
Changed in unity8 (Ubuntu):
status: Confirmed → Incomplete
Michał Sawicz (saviq)
Changed in unity8 (Ubuntu):
status: Incomplete → Invalid
Changed in canonical-devices-system-image:
status: New → In Progress
assignee: nobody → Michał Sawicz (saviq)
milestone: none → 13
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-notifications - 0.1.3+16.10.20160809-0ubuntu1

---------------
unity-notifications (0.1.3+16.10.20160809-0ubuntu1) yakkety; urgency=medium

  [ Lukáš Tinkl ]
  * Visible queue improvements (LP: #1606202)

 -- Michał Sawicz <email address hidden> Tue, 09 Aug 2016 23:00:28 +0000

Changed in unity-notifications (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers