[Oxide 1.18] webapp option --enable-media-hub-audio breaks audio stream

Bug #1603729 reported by Uranicus on 2016-07-17
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
David Barth
Oxide
Critical
Justin McPherson
webapps-sprint
Critical
Justin McPherson
media-hub (Ubuntu)
Critical
Jim Hodapp

Bug Description

My webapp "KlassikRadio" does not work any more.

Opening the webapp opens the window as expected. Nevertheless the audio keeps dry. The phone remains silent.

I have played around and found out that the option: --enable-media-hub-audio breaks the audio stream. When I take this option off the KlassikRadio.desktop file it works.

I am using:

current build number: 387
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en
last update: 2016-07-16 08:46:05
version version: 387
version ubuntu: 20160716
version device: 20160606-ab415b2
version custom: 20160701-981-38-14

Nevertheless this issue is around since several weeks. I assume the option still works with OTA11 but I can not proof this right now.

Can someone have a look? Is the option not available any more in the latest release or is it just a bug? The option is still mentioned in:

https://developer.ubuntu.com/en/phone/web/ubuntu-webapps-guide/

Thanks for your support. If someone wants to test this, the KlassikRadio app version 0.30 has this option enabled. I will put another version (0.31) in the store in the next days before OTA12 comes along, where I will take this option out and replace it with "keep-display-on" in the apparmor-file.

The keep-display-on solution is not nice. Are there any other options I could use alternatively?

Related branches

David Barth (dbarth) on 2016-07-18
Changed in webapps-sprint:
milestone: none → sprint-25
assignee: nobody → Justin McPherson (justinmcp)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
Nicolas Delvaux (malizor) wrote :

I confirm this issue with my "uFip" webapp.
Also I confirm this is a regression from the OTA 12 development cycle: I flashed back my Nexus 4 to OTA 11 and it started working again.

Here are some logs that may be interesting:

[DD 2016-07-18 21:37:17.822452] [player_stub.cpp:189@operator()] PlaybackStatusChanged signal arrived via the bus (status: PlaybackStatus::stopped)
[TT 2016-07-18 21:37:18.270156] [service.cpp:29@instance]
[DD 2016-07-18 21:37:18.741299] [player_stub.cpp:189@operator()] PlaybackStatusChanged signal arrived via the bus (status: PlaybackStatus::ready)
long long unsigned int mediahub_get_duration(MediaHubClientHandle) org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
void mediahub_play(MediaHubClientHandle) Problem starting playback on remote object
[DD 2016-07-18 21:37:20.538491] [player_stub.cpp:207@operator()] BufferingChanged signal arrived via the bus (percent: 1
[DD 2016-07-18 21:37:20.538705] [player_stub.cpp:207@operator()] BufferingChanged signal arrived via the bus (percent: 2
[DD 2016-07-18 21:37:20.538918] [player_stub.cpp:207@operator()] BufferingChanged signal arrived via the bus (percent: 3
[DD 2016-07-18 21:37:20.539101] [player_stub.cpp:207@operator()] BufferingChanged signal arrived via the bus (percent: 4
[DD 2016-07-18 21:37:20.539315] [player_stub.cpp:207@operator()] BufferingChanged signal arrived via the bus (percent: 5
[DD 2016-07-18 21:37:20.539529] [player_stub.cpp:207@operator()] BufferingChanged signal arrived via the bus (percent: 6
[DD 2016-07-18 21:37:20.539712] [player_stub.cpp:207@operator()] BufferingChanged signal arrived via the bus (percent: 12
[DD 2016-07-18 21:37:20.539925] [player_stub.cpp:207@operator()] BufferingChanged signal arrived via the bus (percent: 100
long long unsigned int mediahub_get_duration(MediaHubClientHandle) org.freedesktop.DBus.Error.ServiceUnknown: The name core.ubuntu.media.Service was not provided by any .service files
long long unsigned int mediahub_get_position(MediaHubClientHandle) org.freedesktop.DBus.Error.ServiceUnknown: The name core.ubuntu.media.Service was not provided by any .service files
qml: [JS] (http://www.fipradio.fr/sites/all/modules/custom/rf_lecteur_commun/js/player.js:842) nextRefresh 7: 7000
qml: [JS] (http://www.fipradio.fr/sites/all/modules/custom/rf_lecteur_commun/js/player.js:848) [object Object]
long long unsigned int mediahub_get_duration(MediaHubClientHandle) org.freedesktop.DBus.Error.UnknownMethod: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist

The last line is then repeated endlessly.

Mateo Salta (mateo-salta) wrote :

same on MX4 ota 12 and M10 rc-proposed, making a music webapp and enable-media-hub-audio works on neither.

Changed in canonical-devices-system-image:
assignee: nobody → David Barth (dbarth)
importance: Undecided → Critical
milestone: none → 13
status: New → Confirmed
David Barth (dbarth) on 2016-08-22
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
no longer affects: webbrowser-app (Ubuntu)
Changed in media-hub (Ubuntu):
status: New → In Progress
assignee: nobody → Jim Hodapp (jhodapp)
importance: Undecided → Critical
Changed in webapps-sprint:
importance: Undecided → Critical
status: New → Fix Committed
tags: added: regression-proposed
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Nicolas Delvaux (malizor) wrote :

Since OTA 13 this is even worse: now the webview of my webapp just crashes when the audio playback starts.
Before there was no sound but it was possible to browse the website. Now there is a white page with an error message and a refresh button.

As before, removing "--enable-media-hub-audio" fixes everything, except (of course) that the app has to remain focused to continue streaming.

I tried to play around with alternate webapp containers, but without success.
Is there any known workaround? I'm getting bad reviews on my app because of this bug…

Justin McPherson (justinmcp) wrote :

Due to some issues with landing the change, the fix for this has not made it just yet. I apologise for the inconvenience, it should not be much longer.

Changed in canonical-devices-system-image:
status: Fix Released → In Progress
milestone: 13 → 14
summary: - webapp option --enable-media-hub-audio breaks audio stream
+ [Oxide 1.18] webapp option --enable-media-hub-audio breaks audio stream
Changed in canonical-devices-system-image:
milestone: 14 → x1
Pat McGowan (pat-mcgowan) wrote :

Can we get this landed now

Changed in oxide:
importance: Undecided → Critical
assignee: nobody → Justin McPherson (justinmcp)
David Barth (dbarth) on 2017-01-10
Changed in webapps-sprint:
milestone: sprint-25 → sprint-29
Changed in oxide:
status: New → Fix Released
milestone: none → branch-1.22
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers