No way to uninstall clicks which do not contain apps or scopes

Bug #1600593 reported by dinamic
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Fix Released
High
Alejandro J. Cura
unity-scope-click (Ubuntu)
Fix Released
High
dobey

Bug Description

so.. i installed "Desktop Applications" from the store https://uappexplorer.com/app/com.ubuntu.puritine

and now i can't uninstall :'( there is no icon that i can long press and if i click the icon in ubuntu store in just give me a blank page (no uninstall button)

:'(

Related branches

Revision history for this message
dinamic (dinamic6661) wrote :

i was lucky because i have the MX4 but it looks like installing desktop apps bricks the Bq phones https://bugs.launchpad.net/canonical-devices-system-image/+bug/1600582

Revision history for this message
Alejandro J. Cura (alecu) wrote :

Seems the click scope is failing to show the Uninstall button for packages that have been removed from the store.

Changed in canonical-devices-system-image:
importance: Undecided → High
assignee: nobody → Alejandro J. Cura (alecu)
milestone: none → 13
Changed in unity-scope-click (Ubuntu):
importance: Undecided → High
assignee: nobody → Rodney Dawes (dobey)
Revision history for this message
Alejandro J. Cura (alecu) wrote :

And, the installed click has no launchable app, and the click has been removed from the store, so it shouldn't show up in store results. Interesting chicken and egg problem.

Perhaps we should add an "Installed" section to the store scope.

Revision history for this message
Alejandro J. Cura (alecu) wrote :

While we work on this bug I would suggest removing the click manually like explained here:
http://askubuntu.com/questions/347879/how-do-i-un-install-remove-a-click-package

summary: - no way to uninstall "Desktop Applications"
+ No way to uninstall clicks with no launchable apps that have been
+ removed from the store
dobey (dobey)
Changed in unity-scope-click (Ubuntu):
status: New → In Progress
Revision history for this message
dobey (dobey) wrote : Re: No way to uninstall clicks with no launchable apps that have been removed from the store

No, the issue isn't that the package was removed from the store. It's neither an app nor a scope, so the only way to get a preview is from the store scope. The problem is that the click scope code is designed to work specifically with apps and scopes, because it's what the store and click were designed to work for. Since we have a click which breaks that, the way we handle a couple of things when building the preview is apparently causing a blank preview to be returned.

Unfortunately, running the scope with debug output doesn't tell me anything overly useful, and looking at the code, I don't see exactly why it would fail. My best guess would be that we are trying to build the URI for launching the thing, from a .desktop file (assuming an app, since it's not a scope), which fails since there is no .desktop file. I have another branch in the works which refactors that code, to fix another bug, and which seems to fix this one as well, though.

Changed in canonical-devices-system-image:
status: New → In Progress
dobey (dobey)
summary: - No way to uninstall clicks with no launchable apps that have been
- removed from the store
+ No way to uninstall clicks which do not contain apps or scopes
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
dobey (dobey)
Changed in unity-scope-click (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-click - 0.1.1+16.10.20160808-0ubuntu1

---------------
unity-scope-click (0.1.1+16.10.20160808-0ubuntu1) yakkety; urgency=medium

  * Use shortened appid for click app launching url. (LP: #1594874,
    #1600593)
  * Remove some old unused code that is not needed any longer. (LP:
    #1289526)

 -- Rodney Dawes <email address hidden> Mon, 08 Aug 2016 15:12:29 +0000

Changed in unity-scope-click (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers