wifi slows to a crawl when bluetooth is enabled

Bug #1598584 reported by Tomas Öqvist on 2016-07-03
64
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Alfonso Sanchez-Beato
arale
Undecided
Unassigned
frieza
Critical
Alfonso Sanchez-Beato
indicator-network (Ubuntu)
Undecided
Unassigned

Bug Description

I am having serious wifi performance issues on my Aquaris M10 (running rc-proposed r133). When measuring the wifi speed, I get download speeds of less than 1/20 compared to my Pro 5 at the same distance from the wifi router. This seems to be consistent through reboots. I had similar wifi performance also before recently upgrading to rc-proposed, which I thought would have fixed the issue.

I am in the same place testing 3 different ubuntu devices and these are the readings of the wifi download speed:
Laptop: 4 MB/s
Pro 5: 3.5 MB/s
Aquaris M10: 0.16 MB/s

However, upload speed is about the same on all three devices.

Turning bluetooth off gets Aquaris M10 wifi speed back to sort of normal, 2.5-3.4 MB/s. Bluetooth on, again 0.1-0.2 MB/s. Seems the two wireless technologies interfere with each other on the M10, while the Pro 5 doesn't have that problem.

Changed in canonical-devices-system-image:
assignee: nobody → John McAleely (john.mcaleely)
Changed in indicator-network (Ubuntu):
status: New → Invalid
Tomas Öqvist (tomoqv) wrote :

After hours trying out different settings on the router, and only at one occasion with bluetooth enabled have I managed to get a decent download speed on the M10. My conclusion, after doing some further reading, is that the Bq Aquaris M10 is what you would call a "poorly designed" device, such that it is not able to find a good enough channel for wifi when it competes with bluetooth in the 2.4 GHz band. The tplink router with the latest firmware has 13 different channels to chose from, and I have tried more than half of them with different combinations of b/g/n or mixed. Unfortunately the M10 wifi stays at about 0.1 MB/s unless I turn bluetooth off and then immediately reach about 30 times that speed.

After upgrading the router to ddwrt firmware the issue appears to be resolved for now, but I don't take it for granted until I have connected more times with bluetooth enabled. Still believe it is an issue with the M10 though, as it was the only out of 6 different Ubuntu, UT, Win7 and IOS devices having any problems at all with wifi on the original tp-link router firmware.

I'll report back.

Tomas Öqvist (tomoqv) wrote :

Forgot to mention that the router is a TP-link TL-WR841ND version 8.

Jean-Baptiste Lallement (jibel) wrote :

I observed the same behaviour with an arale running rc-proposed (build 369 today but earlier builds too). With the phone connected to a BT speaker (JBL Charge 3) and streaming music from the internet, I get frequent disconnections from either the internet stream or the speaker.
Listening to the same streams with a wired headset works perfectly.

I did the following speed tests measurement this morning:
1. Streaming + BT on, 5 runs
(kbps) 390, 794, 767, 618 and 455
avg: 604kbps

2. Steaming + BT off (loud speaker of the phone), 5 runs:
(Mbps) 8.26, 11.30, 11.33, 11.62 and 10.61
avg: 10.62Mbps

It is 17.6 times slower with BT on than off, and the reliability of the internet and BT connections is really bad.

Changed in canonical-devices-system-image:
status: New → Confirmed
summary: - M10 wifi slows to a crawl when bluetooth is enabled
+ wifi slows to a crawl when bluetooth is enabled
Changed in canonical-devices-system-image:
importance: Undecided → Critical
milestone: none → 13
Tomas Öqvist (tomoqv) wrote :

I checked back in to this issue again today. After a router reboot, it apparantly hit a channel that didn't play well with my M10. After some further fiddling with the router normal wifi speed came back. Disturbing though, that it seems very difficult to find a wifi broadcast channel on the router that doesn't interfere with bluetooth on the M10. I keep wondering if at home, I am mostly on the 5 GHz band, and therefore haven't experienced this issue there.

Jean-Baptiste Lallement (jibel) wrote :

I don't think it's a problem with the router but more likely the way the device negotiate with the router. The router I use is the DSL box from my provider and there is not much I can configure. I tried with a linksys flashed with dd-wrt and the problem remains the same.
Besides, I tried with an Android tablet and it works without any issue (fast Internet with BT on, no reliability issue, quick pairing)

Jean-Baptiste Lallement (jibel) wrote :

I did more tests with other BT devices on the M10:
1. BT disabled:
  Avg: 13.38Mbps

2. BT mouse + kbd (kept the mouse moving during the test)
  Avg: 2.61Mbps

3. BT mouse + kbd + headset (local music playing)
  Avg: 1.46Mbps

Changed in frieza:
status: New → Confirmed
importance: Undecided → Critical

Same here with Aquaris M10 FHD (frieza, rc-proposed 173).
When connecting to mouse and keyboard both via bluetooth, network works unreliably.
Keyboard is a CSL Mini Keyboard, mouse is a Tonor optical mouse, wifi is provided by an older Fritz Box (sorry, don't know the exact model).

Wayne Ward (waynepaulward) wrote :

same problem with mt ubuntu m10 connected to a BT home hub
i have a logitech t400 mouse and a logitech k480 keyboard
was tring to install a libertine container which kept failing, name resolution etc so i switched to another wireless access point in the house and checked my connection which was fine on my laptop
so just by chance i turned of my bluetooth devices and the wifi just kicked back in to action like it was perfect ?!

Changed in canonical-devices-system-image:
milestone: 13 → backlog
Mathijs Veen (matv1) wrote :

I have just done some more test together with Alan Pope. Although I first saw this happening on my M10FHD, Other devices also are affected: popeys bq e4.5 and my N4 have similar drops in wifi download speeds when paired with a bt device.

Changed in canonical-devices-system-image:
milestone: backlog → 14
Pat McGowan (pat-mcgowan) wrote :

From the E4.5 and mx4 kernel config

# CONFIG_MTK_COMBO_BT is not set
CONFIG_MTK_COMBO_GPS=y
CONFIG_MTK_COMBO_WIFI=y

From the M10 there are a couple other interesting options

# CONFIG_MTK_COMBO_COMM is not set
# CONFIG_MTK_COMBO_BT is not set
# CONFIG_MTK_COMBO_ANT is not set

Be interesting to see what the pro5 has since that is reported to work ok. I assume that at least the COMBO_BT should be

Lorn Potter (lorn-potter) wrote :

I have seen this (and similar disconnections) happen on non Ubuntu related devices where the bluetooth and wifi share the antenna.

Mathijs Veen (matv1) wrote :

I have also heard other experts say this. And that the problem might be more pronounced in mediatek devices. That would suggest that solving this might not be possible from within UT.
But in that case we would need some one to confirm that using BT and wifi together on -for example- the M10 running android has the same issue.

If not, this should be fixable.

And at the risk of stating the obvious, I would add that in the context of convergence, having this working properly is pretty essential because users connecting mice/keyboards is almost a given.

Attached there is the kernel with CONFIG_MTK_COMBO_BT enabled. For those wanting to give it a try, it can be flashed with

$ fastboot flash boot boot.img

Pat McGowan (pat-mcgowan) wrote :

regrettably the performance is worse with the new kernel, downloads dropped from 10mbps to 3mbps, oddly upload speed remained consistent
I did a browser based speed test while typing on an attached keyboard
Be good to verify on another internet connection to be sure its not just my setup
Note 5Ghz AP works well, only 2.4Ghz is an issue

@Pat, would you mind giving a try to this new one? The older one was engineering build, which maybe was affecting performance.

Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in frieza:
assignee: nobody → Alfonso Sanchez-Beato (alfonsosanchezbeato)
Pat McGowan (pat-mcgowan) wrote :

over to qa for testing

Changed in canonical-devices-system-image:
assignee: John McAleely (john.mcaleely) → Jean-Baptiste Lallement (jibel)

no improvement on frieza with latest rc-proposed (ubuntu-touch/rc-proposed/bq-aquaris-pd.en 228) and boot.img from comment 15. It even seems to be worse. Sometimes I cannot connect to the network at all with BT on and no activity on BT.

Changed in canonical-devices-system-image:
assignee: Jean-Baptiste Lallement (jibel) → Alfonso Sanchez-Beato (alfonsosanchezbeato)
Changed in canonical-devices-system-image:
milestone: 14 → x1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments