OSK flickers and buttons are sometimes invisble

Bug #1590765 reported by Tommi Tervo on 2016-06-09
52
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Stephen M. Webb
Mir
Fix Released
High
Kevin DuBois
0.23
Fix Released
Critical
Kevin DuBois
mir (Ubuntu)
Undecided
Unassigned
ubuntu-keyboard (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

Latest rc-propoced image r348 for BQ E5, OSK kb buttons are often invisible (pressing white part will refresh it and buttons are visible again) and OSK flickers a lot.

Related branches

Changed in canonical-devices-system-image:
status: New → Confirmed
Pat McGowan (pat-mcgowan) wrote :

The flicker is very visible for example in contacts, swipe up to make a new contact, then dismiss the panel, the osk flickers wildly

TheLinuxUser (derfremde9179) wrote :

I have a video from this bug.

Pat McGowan (pat-mcgowan) wrote :

Also bringing the OSK up for scope search and canceling, it flickers coming up and hiding, and occasionally isn't shown at all.

Changed in canonical-devices-system-image:
importance: Undecided → Critical
Pat McGowan (pat-mcgowan) wrote :

Another symptom, search in the app scope, hit cancel and the osk doesn't always hide

Changed in canonical-devices-system-image:
assignee: nobody → Michał Sawicz (saviq)
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-keyboard (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
Pat McGowan (pat-mcgowan) wrote :

I opened bug #1590820 for the issue in comment #4 as it seems to relate to dash search

Changed in canonical-devices-system-image:
milestone: none → 12
Michał Sawicz (saviq) wrote :

I'm having trouble reproducing it now, there was a release of UITK, Mir and Maliit in the past few images so one of those is likely the culprit.

Changed in unity8 (Ubuntu):
status: Confirmed → Incomplete
Pat McGowan (pat-mcgowan) wrote :

Its more like it jumps in and out, here's an example in contacts

Uranicus (matthias.ritter) wrote :

Same issue as shown in video of comment #2 on:

current build number: 354
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en
last update: 2016-06-09 06:22:08
version version: 354
version ubuntu: 20160609
version device: 20160606-ab415b2
version custom: 20160505-975-38-9

Michał Sawicz (saviq) wrote :

> Its more like it jumps in and out, here's an example in contacts

Yeah, that seems to be the other issue you reported (bug #1590820), this Critical issue is different - and that's what I'm having trouble reproducing.

Michał Sawicz (saviq) wrote :

I mean after I've reproduced it once.

Uranicus (matthias.ritter) wrote :

I have checked it this morning again after the daily update - now on 355.

Problem has disappeared. It seems to be solved.

tags: added: regression-proposed
Uranicus (matthias.ritter) wrote :

Sorry for this early message. The issue reoccured this morning. The I did a restart of the phone. After the restart of the phone everything works ok again.

So there seems to be an effect how long the phone is running after a restart. OSK flickering starts not directly after the restart!

Ilonka (ilonka-o) wrote :

Same for me! I updated this morning but keyboard is still instable

BQ4.5 rc proposed r355

Pat McGowan (pat-mcgowan) wrote :

Opened a separate bug for the symptom in comment #9 which seems specific to that page in Contacts
bug #1591224

Kevin DuBois (kdub) wrote :

We did change some buffering operations in the mir 0.23.0 release. A good way to test it would be to set
initctl set-env MIR_SERVER_NBUFFERS=3
in the unity8.conf upstart file.
If it goes away, we'll probably have to turn that option back off. (will prepare a branch to that effect)

description: updated
Kevin DuBois (kdub) on 2016-06-10
Changed in mir:
milestone: none → 0.23.1
Daniel van Vugt (vanvugt) wrote :

AFAIK this bug has been around a long time. It definitely predates the NBS feature so MIR_SERVER_NBUFFERS probably won't help.

Daniel van Vugt (vanvugt) wrote :

I mean I've been seeing this bug on the phone for months at least.

Pat McGowan (pat-mcgowan) wrote :

Steps to reproduce (there are others it seems)

Show the camera, go back to messaging and the osk is wonky
change orientation while osk is up and it gets fixed

Daniel van Vugt (vanvugt) wrote :

Clarification: I've had randomly missing keys on the OSK for a long time.

The severe flickering is new.

Michał Sawicz (saviq) wrote :

> I mean I've been seeing this bug on the phone for months at least.

I've confirmed with Daniel he means a different issue.

This indeed seems to fix it for me:

initctl restart unity8 MIR_SERVER_NBUFFERS=3

Changed in canonical-devices-system-image:
assignee: Michał Sawicz (saviq) → Stephen M. Webb (bregma)
Changed in mir:
status: New → Confirmed
Changed in ubuntu-keyboard (Ubuntu):
status: Confirmed → Invalid
Changed in unity8 (Ubuntu):
status: Incomplete → Invalid
Changed in mir:
importance: Undecided → Critical
Kevin DuBois (kdub) wrote :

Alright, so plan is to land the workaround in lp:~mir-team/mir/nbs-off-1590765 in mir 0.23.1

In the meantime, changing the options in the unity8.conf file so that MIR_SERVER_NBUFFERS=3 will correct affected images.

Kevin DuBois (kdub) wrote :

most reliable way to see:
start camera and message app. Transition from camera app to message app. Swipe up to compose a new message. Tap the keyboard to see flickering.

Problem is not permanent; rotating the screen will get the keyboard back into a good state.

Changed in mir:
milestone: 0.23.1 → 0.20.4
milestone: 0.20.4 → 0.24.0
Changed in mir (Ubuntu):
status: New → Confirmed
Olivier Tilloy (osomon) wrote :

I’ve observed the flickering OSK on my krillin a couple of times last week, and over the week-end I also got the dialer-app surface to flicker (no OSK involved).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.23.1+16.10.20160610.1-0ubuntu1

---------------
mir (0.23.1+16.10.20160610.1-0ubuntu1) yakkety; urgency=medium

  [ Kevin DuBois ]
  * New upstream release 0.23.1 (https://launchpad.net/mir/+milestone/0.23.1)
    - ABI summary:
      . No ABI changes in any libraries. Bugfix release only.
    - Bugs fixed:
      . Turn off NBS as workaround to LP: #1590765

  [ Daniel van Vugt, Kevin DuBois ]
  * Mir 0.23.1 bugfix release. Fix flickering issue seen with onscreen
    keyboard (LP: 1590765)

 -- Kevin DuBois <email address hidden> Fri, 10 Jun 2016 22:40:55 +0000

Changed in mir (Ubuntu):
status: Confirmed → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Kevin DuBois (kdub) on 2016-06-22
Changed in mir:
assignee: nobody → Kevin DuBois (kdub)
Kevin DuBois (kdub) wrote :

workaround committed to mir 0.23.1 and released to images. Now working on proper fix for lp:mir

Changed in mir:
status: Confirmed → In Progress
Kevin DuBois (kdub) wrote :

Seems the sequence that's happening is:

many resize events happen, with the last resize event resizing to the same size as the keyboard started with. This triggers a reallocation of a buffer with the same size. The new buffer goes into the driver, and comes out unfilled.

So, its looking like the driver is perhaps making a false assumption about buffer ordering... A good way to resolve might be to only trigger buffer allocation/freeing once we're sure that a size change has happened and a buffer is needed. (this would be more efficient in terms of reducing alloc/free anyways)

tags: added: krillin
Kevin DuBois (kdub) on 2016-06-23
Changed in mir:
importance: Critical → High
Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.24.0

Changed in mir:
status: In Progress → Fix Committed
Kevin DuBois (kdub) wrote :

Explanation of targetting:

0.23.1 contained the initial workaround
0.23.5 will contains the cherry pick of the proper workaround from the 0.24.0 series, released along with the new feature.
0.24.0 contains the proper workaround.

Changed in mir:
milestone: 0.24.0 → 0.23.5
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Changed in mir:
milestone: 0.23.5 → 0.24.0
no longer affects: mir/0.24
Daniel van Vugt (vanvugt) wrote :

This is confusing because there are two different fixes in series 0.23 for the same bug.

A more accurate description of release 0.23.5 would be that we updated the fix for bug 1590765 and turned on NBS again.

Although with series 0.24 coming very soon, I would recommend not doing that. We shouldn't be enabling major new features in a stable point release. So forget 0.23.5 I say.

Changed in mir:
status: Fix Committed → Fix Released
Ante Smolcic (supersmola) wrote :

Same here on BQ Aquarius E4.5. The video in comment #9 shows it.

Andrea Bernabei (faenil) wrote :

still happens on Krillin rc-proposed r489

I don't know how to reproduced, it happened a couple of times in the last couple of weeks

tags: added: osk
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers