AltGr composed keys don't work in the browser content

Bug #1590515 reported by Michael Zanetti on 2016-06-08
64
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
qtubuntu (Ubuntu)
Undecided
Lukáš Tinkl
webbrowser-app (Ubuntu)
Undecided
Unassigned

Bug Description

As the title says. Those keys work fine in the address bar, but not in any text fields inside the website. With a german layout I can't type things like ~ \ { } [ ] etc.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
description: updated
fcole90 (fcole90) wrote :

In addition to what described in description, I also experienced that sometimes altgr gets enalbled like a sort of lock,so any key I press results in a key+altgr combination being triggered.

I have yet to figure when this happens.

fcole90 (fcole90) wrote :

With the Italian layout I can't use neither the 'at', nor the 'hash' sign.

Olivier Tilloy (osomon) wrote :

This looks quite similar to bug #1433138.

fcole90 (fcole90) wrote :

In the Italian keyboard I can't type the following (among others): @#[]{}«»`~ which are quite common symbols.

Changed in qtubuntu (Ubuntu):
status: New → In Progress
assignee: nobody → Lukáš Tinkl (lukas-kde)
Daniel van Vugt (vanvugt) wrote :

In bug 1565236 I'm not yet convinced that if a Mir fix is required or exists that we have released it yet. That fix was targeted for Mir 0.24.0 which is not released yet. But also there's no concrete evidence of a Mir fix existing either.

Changed in canonical-devices-system-image:
status: New → Fix Committed
milestone: none → 13
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtubuntu - 0.63+16.10.20160809-0ubuntu1

---------------
qtubuntu (0.63+16.10.20160809-0ubuntu1) yakkety; urgency=medium

  [ Daniel van Vugt ]
  * Use correct scrolling scale of 120 as documented: (LP: #1607223,
    #1607240)

  [ Gerry Boland ]
  * Reapply rev 324 plus fix: EGL convenience, plus workaround for
    hybris not supporting GLESv3. (LP: #1507817, #1594198)
  * Logging: separate graphics & cursor logging into their own logging
    categories

 -- Michał Sawicz <email address hidden> Tue, 09 Aug 2016 23:01:21 +0000

Changed in qtubuntu (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Evandro P. Alves (evandro-pa) wrote :

Fantastic. Thanks to everyone. I can use my M10 now :)

Sergi Quiles Pérez (sergiqp) wrote :

I think webbrowser-app (Ubuntu) state should be changed because it does work in it.

Olivier Tilloy (osomon) on 2016-09-21
Changed in webbrowser-app (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers