Display is washed out, hard to read

Bug #1585534 reported by Alan Pope 🍺🐧🐱 πŸ¦„
82
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
aethercast
High
Simon Fels

Bug Description

Connected my pro 5 to my microsoft dongle. The text is very hard to read, like it's oversaturated, or there's some compression artifacts.

Unfortunately the screenshot doesn't seem to capture it, so the phone/mir seems to think it's all good. So I'm not sure if it's an aethercast issue, dongle or display problem. I'm using the recommended Microsoft dongle, and a Philips 234L monitor.

I also connected my Android OnePlus X to the same dongle / screen and didn't see the same washed out issue.

Revision history for this message
Alan Pope 🍺🐧🐱 πŸ¦„ (popey) wrote :
Revision history for this message
Alan Pope 🍺🐧🐱 πŸ¦„ (popey) wrote :

Screenshot from Android device, albeit at a lower resolution.

Revision history for this message
Alan Pope 🍺🐧🐱 πŸ¦„ (popey) wrote :

Photo of the screen when Ubuntu Pro 5 is in use.

Revision history for this message
Simon Fels (morphis) wrote :

@Alan: Was anything special when you saw this? Can you drop me the content of /var/log/upstart/aethercast.log?

Also I expect you had a bluetooth mouse and keyboard connected, right? Also are you connected to a 2.4 or 5 GHz Wifi network?

Changed in aethercast:
importance: Undecided → High
Revision history for this message
ET (e-timotei) wrote :

This happens also to me.
I had filed a bug, but marked it as a duplicate of this one since this one has high priority.;)

For me the problem is that the aethercast is choosing the resolution 1280x720p30 instead of the 1920x1080p30.

But the screen is still at 1920x1080 so the aethercast is doing a downscale of the desktop transmitted to the dongle and the dongle is doing an upscale of the shrinked desktop so we get this problem.
I have attached the log.
The problem is at line 125 when InitOptimalVideoFormat is deciding to go with 1280x720p30 even if it is clear that the device is supporting 1920x1080p30 (line 76).

Even more digging.
This seams so simple.
The log shows clear at line 2422 that the aethercast itself ONLY supports 1280x720 resolution.

Why is that?

The basesourcemediamanager.cpp:70 states that this is the "best" resolution.

I disagree, since most miracast dongles will work with 1920x1080p30 natively.
We are producing a very ugly image on screen.

Still, can add the resolution that I want?

What is the easiest way to compile a new binary for meizu pro5?

Revision history for this message
ET (e-timotei) wrote :

To just patch things up so it will look nicer you can add the 1920x1080 resolution to the supported resolutions. Test it on my phone and the image is better. How ever there are still problems in the source.

Look at the next comment, should I open a new bug?

Revision history for this message
ET (e-timotei) wrote :

Also there are some problems in src/mcs/mir/screencast.cpp.
Here is the patch.
First of all, "output_.refresh_rate" is populated only for the whole output_ to be populated later, so I moved it at the end of the function.
Second, instead of the screen to be of the dimensions retrieved from the output, it is made from the dimession of the pone screen. It just so happend that my dongle has the same resolution with my phone screen so it worked, but here is the other half of the solution.

Revision history for this message
debb1046 (debb1046) wrote :

Could you provide a binary with the patches applied? Tried to build it myself but seem to be lacking <hybris/media/media_codec_source_layer.h>

Revision history for this message
Andrew Gryaznov (realgrandrew) wrote :

I get the same problem with EZCast. Please find attached the photo of the screen. It may be a problem with encoding though, as different color combinations have different level of distortion severity

Simon Fels (morphis)
Changed in aethercast:
status: New → Triaged
assignee: nobody → Simon Fels (morphis)
Revision history for this message
Mahesh (mahesh-kommareddi) wrote :

Same issue on a Microsoft Miracast Adapter and a Dell monitor. Same issue on the same Miracast device but on a Samsung 4k TV.

Using the builtin receiver on the TV just gives me a black screen.

Jim Hodapp (jhodapp)
Changed in canonical-devices-system-image:
assignee: nobody → John McAleely (john.mcaleely)
Revision history for this message
Martin Weigl (martinweigl48) wrote :

Is there any plan to apply the patches in comment #6 #7 in OTA14? It is really hard to read anything in convergence mode.

Revision history for this message
GT (gleppert) wrote :

Same issue on LG 55UF6809 WebOS smart TV, connected from BQ M10 tablet

(The screen resolution transferred from the tablet to the TV seems to be strange 1181x738, but the tablet allows full HD and the screen allows Ultra HD)

Revision history for this message
Bry Wilson (bry-wilson) wrote :

As a temporary workaround, I am using the Microsoft Wireless Display Adapter v2 and an old Dell 1907FP monitor with a max resolution of 1280 x 1024 at 75 Hz.

I am using an HDMI-DVI adapter to connect the Display Adapter to the monitor (which doesn't have an HDMI port).

The resolution is crisp and a huge improvement!

Changed in canonical-devices-system-image:
assignee: John McAleely (john.mcaleely) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers