Regression: Camera is crashing when app has no Audio permission

Bug #1570240 reported by Michael Zanetti on 2016-04-14
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
qtubuntu-camera
New
Critical
Unassigned

Bug Description

Some apps use the camera, like uTorch, Tagger, Authenticator but they do not actually take pictures. However, on OTA-10.1 they all started crashing because of this:

Setting media to: QUrl( "file:///system/media/audio/ui/camera_click.ogg" )
mpris.Player.Error.InsufficientAppArmorPermissions: Warning: Failed to authenticate necessary apparmor permissions to open uri: Client is not allowed to access: file:///system/media/audio/ui/camera_click.ogg

The camera backend should not crash if can't play the audio.

Changed in qtubuntu-camera:
importance: Undecided → Critical
Gregory Opera (gregoryopera) wrote :

I too am experiencing issues with these three applications - Tagger and uTorch worked fine for me under OTA-9 (I hadn't tried Authenticator yet)...

--

* OS: Ubuntu 15.04 (OTA-10.1)
* OS build number: OTA-10.1
* Ubuntu Image part: 20160408.4
* Ubuntu build description: Ubuntu 15.04 - armf (20160408-211605)
* Device Image part: 20160329-a9bacdb
* Device build description: VEGETA01A-S23A_BQ_L10EN_2012_160408
* Customization image part: 20160324--36-54-vivid

Gregory Opera (gregoryopera) wrote :

It appears to be some sort of issue with granting the permissions... These applications stopped working since upgrade to OTA-10.1, but after a reboot/restart, all three asked for access to the camera (which they did not do previously), then they seem to work fine.

uTorch and Tagger previously had access to the camera, but apparently I needed to grant this again since the upgrade to OTA-10.1.

Hope this information helps with the fault-finding...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers